Bug 166792 - Endless wait at "updating system configuration"
Summary: Endless wait at "updating system configuration"
Status: RESOLVED FIXED
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal with 240 votes (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
: 104444 159128 167342 176707 181220 196636 226964 232185 233265 238193 245713 253327 258718 265978 274420 275186 287891 297891 310423 315179 317906 326784 329764 330993 335936 338539 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-17 01:36 UTC by Grósz Dániel
Modified: 2015-09-20 17:36 UTC (History)
55 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.15


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grósz Dániel 2008-07-17 01:36:52 UTC
Version:            (using KDE 4.0.98)
Installed from:    SuSE RPMs
OS:                Linux

On my system in KDE 4 in every case when, after modifying some settings (language (I have reported this separately before: http://bugs.kde.org/show_bug.cgi?id=158670), file associations, search engines in Konqueror) the updating system configuration window appears, it remains there endlessly (I did not wait for hours, but after several minutes it still does not close while in KDE 3 the progress bar rarely goes from 0 % to 100 % more than twice). So I cannot modify these settings because in most cases, if I cancel the updating, the settings remain unchanged.
Comment 1 Christophe Giboudeaux 2008-07-24 11:31:41 UTC
*** Bug 167342 has been marked as a duplicate of this bug. ***
Comment 2 FiNeX 2008-12-07 19:53:53 UTC
Fixed in current trunk (>4.2beta1)
Comment 3 Murray Colpman 2009-07-04 20:54:55 UTC
No it isn't. KDE 4.2 (Kubuntu 9.04), I've started getting this problem.
Comment 4 Grósz Dániel 2009-09-13 19:28:47 UTC
Still a problem in 4.3.1 in the case of file associations. It can be worked around by running kbuildsycoca manually (which, interestingy, completes in a matter of seconds).
Comment 5 David Faure 2009-10-12 15:41:58 UTC
Indeed, happens to me too. Looks like the callWithCallback in kded.cpp never gets the callback. So the _next_ run of kbuildsycoca via kded never happens.
Comment 6 David Faure 2009-10-12 15:46:17 UTC
*** Bug 104444 has been marked as a duplicate of this bug. ***
Comment 7 Will Stephenson 2009-11-23 17:13:42 UTC
*** Bug 159128 has been marked as a duplicate of this bug. ***
Comment 8 Will Stephenson 2009-11-23 17:30:00 UTC
*** Bug 176707 has been marked as a duplicate of this bug. ***
Comment 9 Will Stephenson 2009-11-23 18:13:09 UTC
*** Bug 196636 has been marked as a duplicate of this bug. ***
Comment 10 Brian Kaye 2010-01-19 17:42:02 UTC
This problem also occurs on my Fedora Core 11 system with KDE 4.3.4
Comment 11 Johannes Linkels 2010-01-31 03:34:48 UTC
I can confirm it is there as well in KDE 4.3.4 on Debian Squeeze

jlinkels
Comment 12 andrew_kde 2010-02-08 02:56:59 UTC
I confirm it on an AMD64 Debian Squeeze 2.6.30-2-amd64 kernel with KDE 4.3.4.

Is anybody listening?  This bug has been around for 2 and a half years, "works for me" is a pretty lame response when many people are obviously affected by it.  By marking another half dozen bugs as "duplicates" has this been swept under the carpet?
Comment 13 Tristan Miller 2010-02-15 13:51:30 UTC
Confirming bug still exists in KDE 4.3.5 (x86-64, openSUSE 11.2 RPMs).  This bug prevents me from using the KDE Menu Editor to add new programs, so it's a fairly serious problem.
Comment 14 Ronny Standtke 2010-02-15 14:07:45 UTC
Confirmed with KDE 4.4.0 ppas on Kubuntu-9.10 when switching the language in "Country/Region & Language".
Comment 15 Dario Andres 2010-02-15 14:52:09 UTC
*** Bug 226964 has been marked as a duplicate of this bug. ***
Comment 16 David Faure 2010-02-18 23:38:36 UTC
Andrew: the bug is open, not closed as "works for me". And please don't accuse anyone of not listening or ignoring the issue, and realize that this is a NON REPRODUCEABLE issue. As in, I saw it sometimes (see comment #5), but I have no idea how to reliably trigger it. If I can't trigger it, I can't fix it.

Give me precise instructions on how to trigger the bug 100% reliably, and I'll fix it in the next 2 working days.
Comment 17 Roman Fietze 2010-03-16 13:32:28 UTC
Can confirm this after switching the embedded viewer for Java applets in KDE 4.4.1 release 227.

No matter if I try this from within Konqueror or Systemsettings directly.

Repeatable 100%

openSUSE 11.2, x86_64
Comment 18 Benjamin M 2010-04-22 11:34:56 UTC
Confirm on openSUSE 11.2 with current SC 4.4 from Factory. This problem also occurs when updating changes to the K-Menu. 

Hope it will be fixed soon! 

Thank you for your hard work, developers. :-)
Comment 19 Christoph Feck 2010-05-20 19:41:52 UTC
*** Bug 238193 has been marked as a duplicate of this bug. ***
Comment 20 Christoph Feck 2010-05-20 19:42:58 UTC
*** Bug 181220 has been marked as a duplicate of this bug. ***
Comment 21 Ronny Standtke 2010-06-29 10:48:46 UTC
I can reliably reproduce this issue with KDE 4.5 RC on Kubuntu-10.04 when switching the language in "Country/Region & Language".
David, can you also reproduce this issue in exactly this environment (Kubuntu-10.04 with KDE 4.5 RC from the Kubuntu beta ppa)?
Comment 22 Christoph Feck 2010-07-26 15:46:41 UTC
*** Bug 245713 has been marked as a duplicate of this bug. ***
Comment 23 Christoph Feck 2010-07-26 15:48:34 UTC
*** Bug 232185 has been marked as a duplicate of this bug. ***
Comment 24 Silver Salonen 2010-07-30 09:52:50 UTC
I currently use KDE SC 4.4.95 on openSUSE 11.3. I tried updating an icon on panel, but when pressing OK, I fell into that endless loop. I tried then update the application launcher via KMenu editor, but the loop happened there too. When closing the editor and re-editing menu, I see that changes weren't saved.
Comment 25 Silver Salonen 2010-07-30 09:55:11 UTC
Ah yes, as suggested in KDE forums, when I run "kbuildsycoca4" from command line while the looping takes place, and then cancel the update process, the change is saved.
Comment 26 Ferdinand Gassauer 2010-10-01 11:17:58 UTC
kbuildsycoca4 produces a very long list of messages like 

type 1
kbuildsycoca4(20390)/kdecore (services) KServicePrivate::init: The desktop entry file "/usr/share/applications/YaST2/sound.desktop" has Type= "Application" but also has a X-KDE-Library key. This works for now, but makes user-prefernce handling difficult, so support for this might be removed at some point. Consider splitting it into two desktop files. 

type 2
kbuildsycoca4(20390) KConfigGroup::readXdgListEntry: List entry MimeType in "/usr/share/applications/xfig.desktop" is not compliant with XDG standard (missing trailing semicolon). 

type 3
kbuildsycoca4(20390) parseLayoutNode: The menu spec file contains a Layout or DefaultLayout tag without the mandatory Merge tag inside. Please fix your file.

type 4
kbuildsycoca4(20390)/kdecore (services) KServicePrivate::init: The desktop entry file  "kgrapheditor.desktop"  has Type= "Application"  but no Exec line 

may be this is an issue ?

how can I fix this ? 
* remove all and reinstall KDE4
I think this will not help much because many files seem to be quite new
Comment 27 David Faure 2010-10-01 17:55:32 UTC
Ferdinand: all these warnings are individual issues that have to be fixed (but e.g. xfig.desktop isn't provided by KDE, it's provided by xfig or by your distro), but this has nothing to do with this bug report, which is about kde not noticing that kbuildsycoca is done (or kded not actually running kbuildsycoca when it should). Let's not mix up things ;)
Comment 28 Christoph Feck 2010-10-19 02:57:58 UTC
*** Bug 253327 has been marked as a duplicate of this bug. ***
Comment 29 Christoph Feck 2010-10-19 03:00:51 UTC
*** Bug 233265 has been marked as a duplicate of this bug. ***
Comment 30 Marcin Gryszkalis 2010-11-19 19:08:10 UTC
Same here on 4.5.3, in .xmessages-log I'm getting (not sure If there's anything wrong):

kwin(4095) KWin::Client::readUserTimeMapTimestamp: User timestamp, ASN: 343158898
kwin(4095) KWin::Client::readUserTimeMapTimestamp: User timestamp, final: 'ID: 56623470 ;WMCLASS: "systemsettings" : "systemsettings" ;Caption: "Updating System Configuration" ' : 343158898
kwin(4095) KWin::Workspace::allowClientActivation: Activation: Belongs to active application
kwin(4095) KWin::Workspace::updateClientArea: screens:  2 desktops:  3
kwin(4095) KWin::Workspace::updateClientArea: Done.
kwin(4095) KWin::Workspace::createTile: Now tiling  "Updating System Configuration"
kwin(4095) KWin::Workspace::allowClientActivation: Activation: Belongs to active application
kwin(4095) KWin::Workspace::updateClientArea: screens:  2 desktops:  3
kwin(4095) KWin::Workspace::updateClientArea: Done.
Comment 31 Christoph Feck 2010-12-03 20:57:05 UTC
*** Bug 258718 has been marked as a duplicate of this bug. ***
Comment 32 András Manţia 2010-12-03 21:03:05 UTC
David, I can always reproduce when changing file associations, as you know I'm a trunk user. Now you will tell me, I should fix it then. :)
Comment 33 Kostichvej 2011-01-18 22:53:29 UTC
Application: kbuildsycoca4 (1.1)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 2"
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-default i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
Update applet shows me, that there is new updates. When I click more, hdd activity is seen for a while and then update process crashes. My open Suse installation is nearly absolutely clean with no non-default settings during installation process made. Only software additionaly installed are adobe flash player and VLC media player.

The crash can be reproduced every time.
Comment 34 Ronny Standtke 2011-01-27 13:41:05 UTC
I can *no* longer reproduce this issue with KDE 4.6 on Kubuntu-10.10 when
switching the language in "Country/Region & Language".

Thanks.
Comment 35 David Faure 2011-02-10 13:16:43 UTC
*** Bug 265978 has been marked as a duplicate of this bug. ***
Comment 36 Michael 2011-02-28 01:48:33 UTC
I'm using Kubuntu 10.10 and so far, I haven't had any problem with this, (except on my new Linux converts' computers, lol). Then I decided to try out some other media players, besides VLC, which I had been using. I installed KMPlayer and SMPlayer, without any extra codecs. I set KMPlayer to use Phonon Xine, then later SMPlayer. I then tried to use the menu editor to add SMPlayer to Kickoff, but I encountered this bug. Then I removed KMPlayer, SMPlayer, and all packages it had to install in order to install the two media players. After uninstalling, I'm no longer running into this bug. It works like it should. I don't remember the order of events when it comes to changing KMPlayer's audio backend. I'm using Kubuntu-ppa for KDE updates and Maverick Bleed, which caused SMPlayer and possibly MPlayer to be a different version than it otherwise would have been. I hope this might help find a way to make this reproducible.
Comment 37 Christoph Feck 2011-06-08 11:54:00 UTC
*** Bug 275186 has been marked as a duplicate of this bug. ***
Comment 38 Christoph Feck 2011-07-11 22:29:12 UTC
*** Bug 274420 has been marked as a duplicate of this bug. ***
Comment 39 seleko 2011-10-20 09:50:06 UTC
Recently appeared on 4.7.1 (4.7.1) "release 8".
Helps to update with manual kbuildsycoca4 run.
Comment 40 Ken Fallon 2011-11-22 10:03:20 UTC
Seen on Fedora 16 Platform Version 4.7.3 (4.7.3)

Running "kbuildsycoca4" and pressing cancel on the looping dialogue preserved the change.
Comment 41 Christoph Feck 2011-11-30 09:14:10 UTC
*** Bug 287891 has been marked as a duplicate of this bug. ***
Comment 42 BillR 2012-03-10 04:33:47 UTC
Linux version 3.0.0-16-generic (buildd@roseapple) (gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3) ) #29-Ubuntu SMP Tue Feb 14 12:48:51 UTC 2012

Started doing the same thing tonight. Try to same, the update keeps looping. Cancel the update and close the menu editor. Then open the menu editor again, and it is completely unresponsive. Have to force the window closed.
Comment 43 Benjamin M 2012-03-10 09:29:31 UTC
Yep, still around in 4.8.1.
Comment 44 Solerman Kaplon 2012-03-28 19:05:22 UTC
Is there anyway we can run something (eg: the kde menu editor) on command line with some trace options to see what's going on? Right now it doesn't print anything that could give a clue
Comment 45 Christoph Feck 2012-04-11 16:25:35 UTC
*** Bug 297891 has been marked as a duplicate of this bug. ***
Comment 46 Gregg Leichtman 2012-06-15 11:40:01 UTC
Still exists in 4.8.4. Running kbuildsycoca4 while looping does preserve changes. Tried rebuilding sycoca 4 cache with kbuildsycoca4 --noincremental, but still loops infiinitely.
Comment 47 Gregg Leichtman 2012-06-15 11:48:40 UTC
(In reply to comment #44)
> Is there anyway we can run something (eg: the kde menu editor) on command
> line with some trace options to see what's going on? Right now it doesn't
> print anything that could give a clue

It looks like you can run kmenuedit --sync to connect with a debugger. There is also a testability framework. See: kmenuedit --help-all
Comment 48 Gregg Leichtman 2012-06-23 18:08:53 UTC
I just installed the following update:

[Update]             kdebase4-workspace             | The KDE Workspace Components             | 4.8.4-764.1 (4.8.4-764.2) |   40.8 MiB

along with the following potentially relevant updates:

[Update]             kactivities4                   | KDE Plasma Activities support            | 4.8.4-22.2 (4.8.4-22.3)   |  340.0 KiB
[Update]             kde4-kgreeter-plugins          | The KDE Greeter Plugin Components        | 4.8.4-764.1 (4.8.4-764.2) |   94.0 KiB
[Update]             kdebase4-runtime               | The KDE Runtime Components               | 4.8.4-379.2 (4.8.4-379.3) |   18.0 MiB
[Update]             kdebase4-workspace             | The KDE Workspace Components             | 4.8.4-764.1 (4.8.4-764.2) |   40.8 MiB
[Update]             kdebase4-workspace-ksysguardd  | KDE base package: ksysguard daemon       | 4.8.4-764.1 (4.8.4-764.2) |  806.0 KiB
[Update]             kdebase4-workspace-liboxygenstyle | The Libraries of the oxygen-style        | 4.8.4-764.1 (4.8.4-764.2) |  856.0 KiB
[Update]             kdelibs4                       | KDE Base Libraries                       | 4.8.4-511.3 (4.8.4-513.2) |    9.0 MiB
[Update]             kdelibs4-core                  | KDE Base Libraries                       | 4.8.4-511.3 (4.8.4-513.2) |  322.0 KiB
[Update]             kdelibs4-doc                   | Documentation for KDE Base Libraries     | 4.8.4-511.3 (4.8.4-513.2) |    1.0 MiB
[Update]             kdepimlibs4                    | KDE PIM Libraries                        | 4.8.4-289.2 (4.8.4-289.3) |    1.7 MiB
[Update]             kdm                            | KDE login and display manager            | 4.8.4-764.1 (4.8.4-764.2) |    2.5 MiB
[Update]             kdm-branding-upstream          | KDE login and display manager - upstr... | 4.8.4-764.1 (4.8.4-764.2) |   65.0 KiB
[Update]             kwin                           | KDE Window Manager                       | 4.8.4-764.1 (4.8.4-764.2) |    8.8 MiB
[Update]             libblkid1                      | Filesystem detection library             | 2.20.1-1.11.1 (2.20.1-1.14.1) |  163.0 KiB
[Update]             libgcr-3-1                     | Library for Crypto UI related task       | 3.2.1-2.3.1 (3.2.1-2.6.1) |  508.0 KiB
[Update]             libkactivities6                | Development files and headers for kac... | 4.8.4-22.2 (4.8.4-22.3)   |   82.0 KiB
[Update]             libkde4                        | KDE Base Libraries                       | 4.8.4-511.3 (4.8.4-513.2) |   26.2 MiB
[Update]             libkde4-devel                  | KDE Base Libraries: Build Environment    | 4.8.4-511.3 (4.8.4-513.2) |    6.4 MiB
[Update]             libkdecore4                    | KDE Core Libraries                       | 4.8.4-511.3 (4.8.4-513.2) |    3.0 MiB
[Update]             libkdecore4-devel              | KDE Core Libraries: Build Environment    | 4.8.4-511.3 (4.8.4-513.2) |    1.6 MiB
[Update]             libqt4                         | C++ Program Library, Core Components     | 4.8.2-257.1 (4.8.2-258.1) |   14.9 MiB
[Update]             libqt4-devel                   | Qt Development Kit                       | 4.8.2-257.1 (4.8.2-258.1) |   35.2 MiB
[Update]             libqt4-qt3support              | C++ Program Library, Core Components     | 4.8.2-257.1 (4.8.2-258.1) |    3.1 MiB
[Update]             libqt4-x11                     | Qt 4 GUI related libraries               | 4.8.2-257.1 (4.8.2-258.1) |   30.1 MiB

as well as some other updates that I don't believe are relevant and I no longer experience the infinite looping issue while trying to save the menu. More importantly, changes I have made to the menu are now saved. Since this defect is not indicated as solved, I thought this might be helpful to others.
Comment 49 Gregg Leichtman 2012-06-23 18:12:59 UTC
Forgot to mention that I'm running OpenSuse 12.1.

gsl@aragorn:~> uname -a
Linux aragorn 3.1.10-1.9-default #1 SMP Thu Apr 5 18:48:38 UTC 2012 (4a97ec8) i686 i686 i386 GNU/Linux
Comment 50 vcgamesii 2012-06-24 01:28:53 UTC
I'm on Kubuntu12.04 and this issue has been fixed for at least a couple of weeks with the latest updates from the Kubuntu/Ubuntu repositories.
Comment 51 Christoph Feck 2012-11-20 23:50:01 UTC
*** Bug 310423 has been marked as a duplicate of this bug. ***
Comment 52 Mikael 2012-12-11 11:03:24 UTC
I still have the infinite loop in KDE 4.9.3 (Fedora 17). 
Also, kbuildsycoca4 as alluded to above gives:

kbuildsycoca4 running...
kbuildsycoca4(7354) parseLayoutNode: The menu spec file contains a Layout or DefaultLayout tag without the mandatory Merge tag inside. Please fix your file. 

(Which file, by the way?)
Comment 53 dolgener 2013-01-16 14:56:37 UTC
And for another year.
The same applies to current debian/testing (KDE 4.8.4).

You can manually start kbuildsycoca4 from a command line, resolve everything it complains about manually - until it complains no more. However, this does NOT fix the endless looping of "Updating system configuration".

If you start "strace -f systemsettings", you'll se lots of lines like
"recvfrom(7, 0x256f8c4, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable"
while "Updating system configuration" runs permanently.
Comment 54 David Faure 2013-01-17 17:01:24 UTC
It looks like some people here compile their own kdelibs, so the first thing to do would be to confirm if my suspicion from long ago is correct... apply this patch to kdelibs/kded, and check if indeed the callback is never called.

http://www.davidfaure.fr/2013/166792.debug.diff

If that's the issue, then I wonder how it could ever happen. Maybe a DBus error, such as kded taking too much time to answer...
Comment 55 Christoph Feck 2013-02-15 12:41:38 UTC
*** Bug 315179 has been marked as a duplicate of this bug. ***
Comment 56 Christoph Feck 2013-04-06 10:42:59 UTC
*** Bug 317906 has been marked as a duplicate of this bug. ***
Comment 57 Beybalaev Murad Felixovich 2013-04-18 13:01:28 UTC
Still there. How am I supposed to change language preferences or filetype icons now?
Comment 58 David Faure 2013-04-18 14:05:08 UTC
You can cancel the dialog. The changes are probably taken into account already, it's just the callback to close the dialog, that doesn't work.
Comment 59 Wolfgang Bauer 2013-08-21 22:08:10 UTC
(In reply to comment #54)
> It looks like some people here compile their own kdelibs, so the first thing
> to do would be to confirm if my suspicion from long ago is correct... apply
> this patch to kdelibs/kded, and check if indeed the callback is never called.
> 
> http://www.davidfaure.fr/2013/166792.debug.diff
> 
> If that's the issue, then I wonder how it could ever happen. Maybe a DBus
> error, such as kded taking too much time to answer...
I tried that now. (KDE 4.11.0)

There is absolutely no output from the patch in .xsession-errors (I did enable "7020 kded" and "kded4" in kdebugdialog, that should be enough I hope?) in the case of an endless "updating system configuration".

The settings do get saved, but I have to run "kbuildsycoca4" manually for them to take effect.

I want to add that I have this problem for years now, even in KDE3.
But sometimes it does even work...
Comment 60 klangga 2013-09-27 03:18:32 UTC
Still happens on Debian Sid, KDE 4.10.5. Running kbuildsycoca4 and clicking Cancel does apply the changes, as stated above.
Comment 61 Christoph Feck 2013-10-28 14:38:59 UTC
*** Bug 326784 has been marked as a duplicate of this bug. ***
Comment 62 Christoph Feck 2014-01-10 02:28:57 UTC
*** Bug 329764 has been marked as a duplicate of this bug. ***
Comment 63 Christoph Feck 2014-02-10 22:44:57 UTC
*** Bug 330993 has been marked as a duplicate of this bug. ***
Comment 64 David Faure 2014-03-22 15:47:28 UTC
Git commit 7d55b69394af1ecd46f41084ca807e6a1a28e765 by David Faure.
Committed on 22/03/2014 at 15:36.
Pushed by dfaure into branch 'KDE/4.13'.

Add error handling for dbus errors in dbus-call-with-callback.

This was the reason why m_recreateBusy could be stuck to 'true' forever,
the normal callback wasn't called because the DBus call ended in error
(my guess is a timeout due to extra-busy system, or kbuildsycoca crashing).

Old bug, first reported in 2008...
FIXED-IN: 4.13

M  +19   -4    kded/kded.cpp
M  +4    -1    kded/kded.h

http://commits.kde.org/kdelibs/7d55b69394af1ecd46f41084ca807e6a1a28e765
Comment 65 Joe Biden 2014-04-22 02:11:50 UTC
Sorry, not fixed.

Now it's nearly time. Updating loop....
Comment 66 Ferdinand Gassauer 2014-04-22 14:53:37 UTC
seems to be an endless story
Comment 67 Wolfgang Bauer 2014-04-30 20:57:52 UTC
(In reply to comment #65)
> Sorry, not fixed.
> 
> Now it's nearly time. Updating loop....
(In reply to comment #66)
> seems to be an endless story

I cannot completely agree here.
For me this is (mostly) fixed.

I was testing the patch from comment#64 on 4.12.x already, and have now upgraded to 4.13 which includes that patch.

For me it works now most of the time (since one month ago), and it was not working before at all for ten years (except for a few times).

I can confirm I still had the problem 3 or 4 times (in one month), but now the cache got updated correctly, and I could see the change in the underlying "file associations" window f.e.

So now even clicking "Cancel" is ok for me.
Before this patch, I had to run "kbuildsycoca4" manually (see comment#59), now it's not necessary anymore.
So it's definitely an improvement.

The only remaining problem seems to be that the dialog is not getting the callback that the updating of the cache is finished under certain circumstances.
I have to say that when I encountered this problem, more than 512MB of swap was in use or the system was loaded heavy, so it might be related to that.
Comment 68 Leon 2014-05-01 02:27:11 UTC
For information, and maybe it will help: This loop occurred for me always and ONLY when adding a shell executable type file, or a wine file. If I recall correctly (as it has been a while), leaving out "wine" in front of the .exe application you wished to add, caused this specific loop. from around FC19, when adding that specific item, the endless loop never occurred again.
Comment 69 Christoph Feck 2014-06-08 11:15:22 UTC
*** Bug 335936 has been marked as a duplicate of this bug. ***
Comment 70 emilio.recio@jefferson.edu 2014-08-05 19:03:40 UTC
I am having this issue with 4.13.3 (note I don't know when it came back, because it *was* working before). Now all of the sudden it sits there going from 0% to 100% then back to 0 -> 100 etc. It doesn't matter what filetype is updated.
Comment 71 Christoph Feck 2014-08-25 14:40:22 UTC
*** Bug 338539 has been marked as a duplicate of this bug. ***
Comment 72 Maciej Kacper Jagiełło 2014-09-16 20:37:30 UTC
Same happened here when editing some icons and order in kickoff's "edit applications" dialog.
I'm on Kubuntu with KDE 4.13.3.
Comment 73 David Faure 2015-09-20 17:36:48 UTC
Git commit 3a468067c23e7d4fdfcd185883db4ba9ab5c2a0a by David Faure.
Committed on 20/09/2015 at 17:36.
Pushed by dfaure into branch 'master'.

KBuildSycocaProgressDialog: run kbuildsycoca5 with QProcess.

The dbus-callback stuff from kded is unreliable and unnecessary.

And meanwhile I made kbuildsycoca5 work well when called more
than once, the second instance will wait for the first one
and then check if there's anything else to do, otherwise quit early.

Change-Id: I24f62cf1015bdbab1778245f4221f03f40a9bd0f
Related: bug 235486
REVIEW: 125314
FIXED-IN: 5.15

M  +4    -10   src/widgets/kbuildsycocaprogressdialog.cpp
M  +0    -1    src/widgets/kbuildsycocaprogressdialog.h

http://commits.kde.org/kio/3a468067c23e7d4fdfcd185883db4ba9ab5c2a0a