Bug 135639 - [testcase][regression]http://ju-ni.org/ not rendered correctly
Summary: [testcase][regression]http://ju-ni.org/ not rendered correctly
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: khtml renderer (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 135720 135807 135914 136167 137321 137990 144024 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-10-14 15:27 UTC by Alejandro Cámara Iglesias
Modified: 2007-04-10 08:31 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
testcase (301 bytes, text/html)
2006-10-15 19:40 UTC, Maksim Orlovich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alejandro Cámara Iglesias 2006-10-14 15:27:05 UTC
Version:           3.5.5 (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages

Reproduce:
Go to http://ju-ni.net/ and try to see any post. Nothing to read there.

Expected Behaviour:
There it should show some posts and an AJAX shouthbox, as it's a wordpress-like page.

History:
I was used to go there at least once a week and it worked fine for the last year or so. But when I upgraded to 3.5.5 it broke. We have tried with other versions of konqueror (3.3.2) and it works for them. I've talked to the web admins of the page and "The site has been tested for proper operation within Mozilla Firefox 1.5.0.x / Seamonkey 1.0.x, Internet Explorer 6.0SP2, Internet Explorer 7.0 Beta / RC and Opera 9.0x" textually. I'm trying to get someone using 3.5.4 try the page. Just to know where to find the error.

I don't know how to do a backtrace, or even if it's possible to do so when you haven't crashed anything. I hope it helps.
Comment 1 Alejandro Cámara Iglesias 2006-10-14 18:40:38 UTC
Kubuntu Forums:
http://kubuntuforums.net/forums/index.php?topic=9863.msg39386#msg39386

http://ju-ni.net Forums:
http://ju-ni.net/forum/viewtopic.php?t=242

"Konqueror 3.5.3 (using KDE 3.5.4) displays the page without noticeable difficulties." reported by penguin.ch in the kubuntu forums.
Comment 2 Maksim Orlovich 2006-10-15 19:38:18 UTC
Nothing to do with AJAX. The JavaScript on the page is so broken it doesn't even do anything. Likely testcase upcoming


Comment 3 Maksim Orlovich 2006-10-15 19:40:13 UTC
Created attachment 18130 [details]
testcase

Testcase. Note that this is a very recent regression -- my previous build here
worked. Unfortunately I didn't notice it before I svn up'd, so no r number.

Testcase inline:
<style>
#top_shelf {
width: 780px;
overflow: auto;
border: 2px solid red;
}

#top_shelf_center {
float: left;
width: 236px;
border: 2px solid green;
}

</style>
<body>

    <div id="top_shelf">
      <div id="top_shelf_center">
	  <h3>Latest Releases</h3>
      </div>
  </div>
</body>
</html>
Comment 4 Allan Sandfeld 2006-10-15 22:35:46 UTC
SVN commit 595832 by carewolf:

We still need to include floats in the height.
BUG: 135639


 M  +3 -3      render_block.cpp  


--- branches/KDE/3.5/kdelibs/khtml/rendering/render_block.cpp #595831:595832
@@ -224,7 +224,7 @@
         if(oldText->l >= 1) {
             oldText->ref();
             // begin: we need skip leading whitespace so that RenderBlock::findNextLineBreak
-            // won't think we're continuing from a previous run 
+            // won't think we're continuing from a previous run
             unsigned int begin = 0; // the position that first-letter begins
             unsigned int length = 0; // the position that "the rest" begins
             while ( length < oldText->l && (oldText->s+length)->isSpace() )
@@ -711,7 +711,7 @@
     int toAdd = borderBottom() + paddingBottom();
     if (m_layer && style()->scrollsOverflow() && style()->height().isVariable())
         toAdd += m_layer->horizontalScrollbarHeight();
-    if ( hasOverhangingFloats() && !style()->scrollsOverflow() && (isFloatingOrPositioned() || flowAroundFloats()) )
+    if ( hasOverhangingFloats() && (isFloatingOrPositioned() || flowAroundFloats()) )
         m_overflowHeight = m_height = floatBottom() + toAdd;
 
     int oldHeight = m_height;
@@ -930,7 +930,7 @@
         RenderObject* compactChild = compactInfo.compact();
         if (compactChild->height() > child->height())
             m_height += compactChild->height() - child->height();
-    } 
+    }
 }
 
 void RenderBlock::insertCompactIfNeeded(RenderObject* child, CompactInfo& compactInfo)
Comment 5 Germain Garand 2006-10-16 02:00:23 UTC
*** Bug 135720 has been marked as a duplicate of this bug. ***
Comment 6 Maksim Orlovich 2006-10-17 15:44:17 UTC
*** Bug 135807 has been marked as a duplicate of this bug. ***
Comment 7 Maksim Orlovich 2006-10-17 22:24:42 UTC
SVN commit 596539 by orlovich:

Regression test for #135639 that Carewolf fixed.
CCBUG:135639


 A             baseline/floats/135639.html-dom  
 AM            baseline/floats/135639.html-dump.png  
 A             baseline/floats/135639.html-render  
 A             tests/floats/135639.html  


** trunk/tests/khtmltests/regression/baseline/floats/135639.html-dump.png #property svn:mime-type
   + image/png
Comment 8 Maksim Orlovich 2006-10-19 00:03:06 UTC
*** Bug 135914 has been marked as a duplicate of this bug. ***
Comment 9 Tommi Tervo 2006-10-23 08:36:00 UTC
*** Bug 136167 has been marked as a duplicate of this bug. ***
Comment 10 Tommi Tervo 2006-11-14 14:53:56 UTC
*** Bug 137321 has been marked as a duplicate of this bug. ***
Comment 11 Tommi Tervo 2006-11-28 10:09:45 UTC
*** Bug 137990 has been marked as a duplicate of this bug. ***
Comment 12 Tommi Tervo 2007-04-10 08:31:40 UTC
*** Bug 144024 has been marked as a duplicate of this bug. ***