Bug 404518

Summary: System Settings crashed when added another preferred language in Regional Settings
Product: systemsettings Reporter: hung0966609285
Component: kcm_languageAssignee: Eike Hein <hein>
Status: RESOLVED DUPLICATE    
Severity: crash CC: ampp.4me, BSanek1972, bugseforuns, dentist.muhammad.ali, dutchgigalo, halftough29a, john.b.little, kde, lacyc3, null, opensuse.lietuviu.kalba, stasyik, stefmz, vadimmaret, wingtong711, xt1zer
Priority: NOR Keywords: drkonqi
Version: 5.15.0   
Target Milestone: ---   
Platform: Neon Packages   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: New crash information added by DrKonqi
New crash information added by DrKonqi
New crash information added by DrKonqi

Description hung0966609285 2019-02-18 12:44:32 UTC
Application: systemsettings5 (5.15.0)

Qt Version: 5.12.0
Frameworks Version: 5.55.0
Operating System: Linux 4.15.0-45-generic x86_64
Distribution: KDE neon User Edition 5.15

-- Information about the crash:
- What I was doing when the application crashed:
Add Vietnamese to the list of Preferred Languages.
I did it plenty of times, with another language as well (Japanese) to test and still receiving the same crash. But after like 4 or 5 tries, it works with JPese, but Vietnamese not worked.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc109e8f840 (LWP 1628))]

Thread 6 (Thread 0x7fc0cd8bb700 (LWP 1636)):
#0  0x00007fc1054040b4 in __GI___libc_read (fd=31, buf=0x7fc0cd8bab30, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007fc0fe6bccd0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc0fe678027 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc0fe6784e0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc0fe67864c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fc105d4b15b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fc105cec64a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fc105b1441a in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007fc103ad32e5 in QQmlThreadPrivate::run (this=0x55673b6f6a80) at qml/ftw/qqmlthread.cpp:148
#9  0x00007fc105b15bc2 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007fc100a366db in start_thread (arg=0x7fc0cd8bb700) at pthread_create.c:463
#11 0x00007fc10541588f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7fc0d5e05700 (LWP 1635)):
#0  0x00007fc1054040b4 in __GI___libc_read (fd=24, buf=0x7fc0d5e04b30, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007fc0fe6bccd0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc0fe678027 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc0fe6784e0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc0fe67864c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fc105d4b15b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fc105cec64a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fc105b1441a in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007fc103ad32e5 in QQmlThreadPrivate::run (this=0x55673ad293d0) at qml/ftw/qqmlthread.cpp:148
#9  0x00007fc105b15bc2 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007fc100a366db in start_thread (arg=0x7fc0d5e05700) at pthread_create.c:463
#11 0x00007fc10541588f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7fc0deb19700 (LWP 1633)):
#0  0x00007fc105408bf9 in __GI___poll (fds=0x7fc0d8004a00, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fc0fe678539 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc0fe67864c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc105d4b15b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fc105cec64a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fc105b1441a in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fc103ad32e5 in QQmlThreadPrivate::run (this=0x55673a79fe30) at qml/ftw/qqmlthread.cpp:148
#7  0x00007fc105b15bc2 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007fc100a366db in start_thread (arg=0x7fc0deb19700) at pthread_create.c:463
#9  0x00007fc10541588f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fc0ee8d4700 (LWP 1631)):
#0  0x00007fc1054040b4 in __GI___libc_read (fd=7, buf=0x7fc0ee8d3b20, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007fc0fe6bccd0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc0fe678027 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc0fe6784e0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc0fe67864c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fc105d4b15b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fc105cec64a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fc105b1441a in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007fc1061b9015 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#9  0x00007fc105b15bc2 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007fc100a366db in start_thread (arg=0x7fc0ee8d4700) at pthread_create.c:463
#11 0x00007fc10541588f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fc0f6904700 (LWP 1630)):
#0  0x00007fc105408bf9 in __GI___poll (fds=0x7fc0f6903c78, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fc1005fa747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fc1005fc36a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fc0f8e9cd4a in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007fc105b15bc2 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fc100a366db in start_thread (arg=0x7fc0f6904700) at pthread_create.c:463
#6  0x00007fc10541588f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fc109e8f840 (LWP 1628)):
[KCrash Handler]
#6  0x00007fc1039576fe in QQmlData::wasDeleted (object=0x55673cf3ad60) at ../../include/QtQml/5.12.0/QtQml/private/../../../../../src/qml/qml/qqmldata_p.h:337
#7  QV4::QObjectWrapper::wrap (engine=engine@entry=0x55673bf16ff0, object=0x55673cf3ad60) at ../../include/QtQml/5.12.0/QtQml/private/../../../../../src/qml/jsruntime/qv4qobjectwrapper_p.h:209
#8  0x00007fc1039f162b in QV4::ExecutionEngine::fromVariant (this=this@entry=0x55673bf16ff0, variant=...) at jsruntime/qv4engine.cpp:1495
#9  0x00007fc103956b1f in QV4::QQmlContextWrapper::virtualGet (m=<optimized out>, id=..., receiver=<optimized out>, hasProperty=<optimized out>) at jsruntime/qv4qmlcontext.cpp:223
#10 0x00007fc1038fda0e in QV4::Object::get (hasProperty=0x7ffe4014b277, receiver=0x7fc0ccc7c678, id=..., this=<optimized out>) at jsruntime/qv4object_p.h:314
#11 QV4::ExecutionContext::getProperty (this=0x7fc0ccc7c5f8, name=0x7fc0ccc7c670) at jsruntime/qv4context.cpp:360
#12 0x00007fc1039fa400 in QV4::Runtime::method_loadName (engine=0x55673bf16ff0, nameIndex=<optimized out>) at jsruntime/qv4runtime.cpp:985
#13 0x00007fc0d403a9d8 in ?? ()
#14 0x0000000000000000 in ?? ()

Reported using DrKonqi
Comment 1 Patrick Silva 2019-02-23 14:55:22 UTC
I can reproduce. System settings also crashes when I add turkish and polish languages.

Operating System: Arch Linux 
KDE Plasma Version: 5.15.1
KDE Frameworks Version: 5.55.0
Qt Version: 5.12.1
Comment 2 André Verwijs 2019-02-28 20:49:20 UTC
Created attachment 118444 [details]
New crash information added by DrKonqi

systemsettings5 (5.15.0) using Qt 5.12.0

- What I was doing when the application crashed:
 
when adding aditiona language, System Settings crashes...
identical to #403491 and #404518 ...

-- Backtrace (Reduced):
#6  0x00007f0ee907bfbe in QV4::QObjectWrapper::wrap(QV4::ExecutionEngine*, QObject*) () at /usr/lib64/libQt5Qml.so.5
#7  0x00007f0ee90ecfac in QV4::ExecutionEngine::fromVariant(QVariant const&) () at /usr/lib64/libQt5Qml.so.5
#8  0x00007f0ee904f105 in QV4::QQmlContextWrapper::virtualGet(QV4::Managed const*, QV4::PropertyKey, QV4::Value const*, bool*) () at /usr/lib64/libQt5Qml.so.5
#9  0x00007f0ee8ff5c4d in QV4::ExecutionContext::getProperty(QV4::String*) () at /usr/lib64/libQt5Qml.so.5
#10 0x00007f0ee90f4c9d in QV4::Runtime::method_loadName(QV4::ExecutionEngine*, int) () at /usr/lib64/libQt5Qml.so.5
Comment 3 Patrick Silva 2019-03-11 11:49:10 UTC
still crasing in plasma 5.12.2
Comment 4 hung0966609285 2019-03-12 06:40:29 UTC
I'm switching to Manjaro KDE 18.0.3 and still encounter this issue.
But I found out what happened, it doesn't apply to any specific languages, it just that it automatically crashes when you add the third language, no matter what is that.
I tried multiple language and got the same problem when adding the third one. You can only add 2 languages there.
Comment 5 Texstar 2019-03-22 06:18:54 UTC
Regional Settings cause systemsettings to freeze do to a bad kcm_translations.so in /usr/lib64/qt5/plugins/kcms
Comment 6 Christoph Feck 2019-04-16 20:27:55 UTC
This ticket is about a crash. For the freeze, please see bug 405001.
Comment 7 Patrick Silva 2019-05-18 13:41:11 UTC
Crash reproducible on Plasma 5.16 beta.

Operating System: Arch Linux 
KDE Plasma Version: 5.15.90
KDE Frameworks Version: 5.58.0
Qt Version: 5.13.0 beta3
Comment 8 John Little 2019-05-25 03:39:48 UTC
I get this attempting to delete the second language, always.

systemsettings5 4:5.15.4-0ubuntu1
Operating System: Kubuntu 19.04
KDE Plasma Version: 5.15.4
KDE Frameworks Version: 5.56.0
Qt Version: 5.12.2
Kernel Version: 5.0.0-15-generic
Comment 9 Christoph Feck 2019-07-03 14:38:50 UTC
*** Bug 408747 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Feck 2019-07-16 12:41:51 UTC
*** Bug 409008 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2019-08-05 20:34:52 UTC
*** Bug 409745 has been marked as a duplicate of this bug. ***
Comment 12 Christoph Feck 2019-08-20 20:11:05 UTC
*** Bug 410756 has been marked as a duplicate of this bug. ***
Comment 13 Karl Ove Hufthammer 2019-09-15 13:10:15 UTC
*** Bug 411910 has been marked as a duplicate of this bug. ***
Comment 14 David Edmundson 2019-09-19 23:58:59 UTC
*** Bug 411837 has been marked as a duplicate of this bug. ***
Comment 15 David Edmundson 2019-09-20 00:02:51 UTC
*** Bug 403491 has been marked as a duplicate of this bug. ***
Comment 16 David Edmundson 2019-09-20 00:09:29 UTC
I can reproduce in a Neon VM, but on my dev machine (which has Qt5.14) everything seems to work fine.
Comment 17 joris 2019-11-12 19:41:12 UTC
Created attachment 123871 [details]
New crash information added by DrKonqi

systemsettings5 (5.17.2) using Qt 5.13.1

- What I was doing when the application crashed:

When I want to add one or more languages, I have crash.
I have the same thing under kubuntu or kde neon.

-- Backtrace (Reduced):
#7  0x00007f438b347d60 in QQmlPropertyCache::callJSFactoryMethod (args=0x7ffcba812bf0, object=0x7f4378012540, this=0x7f43780001a0) at ../../include/QtQml/5.13.1/QtQml/private/../../../../../src/qml/qml/qqmlpropertycache_p.h:875
#8  QV4::QObjectWrapper::create (engine=<optimized out>, engine@entry=0x557be67e56c0, object=object@entry=0x7f4378012540) at jsruntime/qv4qobjectwrapper.cpp:691
#9  0x00007f438b34a0b9 in QV4::QObjectWrapper::wrap_slowPath (engine=0x557be67e56c0, object=0x7f4378012540) at jsruntime/qv4qobjectwrapper.cpp:623
#10 0x00007f438b32843b in QV4::QObjectWrapper::wrap (engine=engine@entry=0x557be67e56c0, object=<optimized out>) at ../../include/QtQml/5.13.1/QtQml/private/../../../../../src/qml/jsruntime/qv4qobjectwrapper_p.h:224
#11 0x00007f438b3c462c in QV4::ExecutionEngine::fromVariant (this=this@entry=0x557be67e56c0, variant=...) at jsruntime/qv4engine.cpp:1524
Comment 18 Christoph Feck 2019-12-01 13:06:26 UTC
*** Bug 413792 has been marked as a duplicate of this bug. ***
Comment 19 opensuse.lietuviu.kalba 2019-12-07 09:27:45 UTC
Created attachment 124352 [details]
New crash information added by DrKonqi

systemsettings5 (5.17.3) using Qt 5.13.1

- What I was doing when the application crashed:

I used Lithuanian language as primary. I added American English as secondary in KDE System Settings. KDE System Settings crashed.

-- Backtrace (Reduced):
#6  0x00007f6341b865ae in QQmlData::wasDeleted (object=0x55619c919570) at /usr/src/debug/libqt5-qtdeclarative-5.13.1-1.2.x86_64/include/QtQml/5.13.1/QtQml/private/../../../../../src/qml/qml/qqmldata_p.h:338
#7  QV4::QObjectWrapper::wrap (engine=engine@entry=0x55619c6dfe00, object=0x55619c919570) at /usr/src/debug/libqt5-qtdeclarative-5.13.1-1.2.x86_64/include/QtQml/5.13.1/QtQml/private/../../../../../src/qml/jsruntime/qv4qobjectwrapper_p.h:215
#8  0x00007f6341c2df3c in QV4::ExecutionEngine::fromVariant (this=this@entry=0x55619c6dfe00, variant=...) at /usr/src/debug/libqt5-qtdeclarative-5.13.1-1.2.x86_64/src/qml/jsruntime/qv4engine.cpp:1524
#9  0x00007f6341b83d3d in searchContextProperties (v4=v4@entry=0x55619c6dfe00, context=context@entry=0x55619ca8c770, name=<optimized out>, hasProperty=hasProperty@entry=0x7ffd431ce837, base=base@entry=0x0, lookup=lookup@entry=0x0, originalLookup=<optimized out>, ep=<optimized out>) at /usr/include/qt5/QtCore/qlist.h:116
#10 0x00007f6341b84bd0 in QV4::QQmlContextWrapper::getPropertyAndBase (resource=<optimized out>, id=..., receiver=<optimized out>, hasProperty=0x7ffd431ce837, base=0x0, lookup=0x0) at /usr/src/debug/libqt5-qtdeclarative-5.13.1-1.2.x86_64/include/QtQml/5.13.1/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:301
Comment 20 Patrick Silva 2019-12-13 14:16:19 UTC
(In reply to David Edmundson from comment #16)
> I can reproduce in a Neon VM, but on my dev machine (which has Qt5.14)
> everything seems to work fine.

yeah, I can't reproduce the crash after upgrade to Qt 5.14.

Operating System: Arch Linux 
KDE Plasma Version: 5.17.4
KDE Frameworks Version: 5.64.0
Qt Version: 5.14.0
Comment 21 Christoph Feck 2020-01-10 11:08:39 UTC
Let's assume it was a Qt bug; changing status.

If you see this again, please add a comment or reopen this ticket.
Comment 22 Patrick Silva 2020-01-10 12:39:05 UTC
weirdly the crash is happening again when I add a CJK language at the bottom of the list. :(

Operating System: Arch Linux 
KDE Plasma Version: 5.17.5
KDE Frameworks Version: 5.65.0
Qt Version: 5.14.0
Comment 23 opensuse.lietuviu.kalba 2020-01-10 12:56:52 UTC
(In reply to Christoph Feck from comment #21)
> Let's assume it was a Qt bug;

Can someone write here URL of upstream Qt bug?
Comment 24 Christoph Feck 2020-01-21 23:30:20 UTC
> Can someone write here URL of upstream Qt bug?

My conclusion came from the statement in comment 20. I don't know if there is an upstream ticket.
Comment 25 Patrick Silva 2020-02-09 21:39:49 UTC
*** Bug 416708 has been marked as a duplicate of this bug. ***
Comment 26 David Edmundson 2020-04-06 11:42:50 UTC

*** This bug has been marked as a duplicate of bug 419008 ***