Bug 410756 - System Settings crash when adding Russian as one of the prefered languages
Summary: System Settings crash when adding Russian as one of the prefered languages
Status: RESOLVED DUPLICATE of bug 404518
Alias: None
Product: systemsettings
Classification: Unclassified
Component: general (show other bugs)
Version: 5.16.4
Platform: Neon Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-08-09 09:08 UTC by vadimmaret
Modified: 2019-08-20 20:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vadimmaret 2019-08-09 09:08:40 UTC
Application: systemsettings5 (5.16.4)

Qt Version: 5.12.3
Frameworks Version: 5.60.0
Operating System: Linux 5.0.0-23-generic x86_64
Distribution: KDE neon User Edition 5.16

-- Information about the crash:
- What I was doing when the application crashed: I opened System Settings then went to Regional Settings then Language, I added American English then British English then set British English as default by moving it on top of the language list then I tried to add Rusian 
but after I selected it in the list and clicked Add System Settings crashes.

tried multiple times on Kubuntu and KDE Neon

also happen with Chinese and Japanese

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f58db3b5680 (LWP 1946))]

Thread 7 (Thread 0x7f5895dd9700 (LWP 1954)):
#0  0x00007f58d6917bf9 in __GI___poll (fds=0x7f5890004e00, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f58cf9775c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f58cf9776dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f58d725adcb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f58d71fc03a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f58d70234ca in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f58d4dd9115 in QQmlThreadPrivate::run (this=0x55c67af8afe0) at qml/ftw/qqmlthread.cpp:148
#7  0x00007f58d7024c72 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f58d1d366db in start_thread (arg=0x7f5895dd9700) at pthread_create.c:463
#9  0x00007f58d692488f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f589dfc8700 (LWP 1953)):
#0  0x00007f58d6917bf9 in __GI___poll (fds=0x7f5898003ce0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f58cf9775c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f58cf9776dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f58d725adcb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f58d71fc03a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f58d70234ca in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f58d4dd9115 in QQmlThreadPrivate::run (this=0x55c67a391770) at qml/ftw/qqmlthread.cpp:148
#7  0x00007f58d7024c72 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f58d1d366db in start_thread (arg=0x7f589dfc8700) at pthread_create.c:463
#9  0x00007f58d692488f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f58a68c6700 (LWP 1952)):
#0  0x00007f58d6917bf9 in __GI___poll (fds=0x7f58a0004a00, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f58cf9775c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f58cf9776dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f58d725adcb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f58d71fc03a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f58d70234ca in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f58d4dd9115 in QQmlThreadPrivate::run (this=0x55c67a040350) at qml/ftw/qqmlthread.cpp:148
#7  0x00007f58d7024c72 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f58d1d366db in start_thread (arg=0x7f58a68c6700) at pthread_create.c:463
#9  0x00007f58d692488f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f58b2cc9700 (LWP 1950)):
#0  0x00007f58d1d3c9f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55c679d54ddc) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x55c679d54d88, cond=0x55c679d54db0) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x55c679d54db0, mutex=0x55c679d54d88) at pthread_cond_wait.c:655
#3  0x00007f58bc99c0aa in ?? () from /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so
#4  0x00007f58bc99bdd7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so
#5  0x00007f58d1d366db in start_thread (arg=0x7f58b2cc9700) at pthread_create.c:463
#6  0x00007f58d692488f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f58bfdf5700 (LWP 1949)):
#0  0x00007f58d6917bf9 in __GI___poll (fds=0x7f58b8004db0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f58cf9775c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f58cf9776dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f58d725adcb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f58d71fc03a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f58d70234ca in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f58d76c9015 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f58d7024c72 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f58d1d366db in start_thread (arg=0x7f58bfdf5700) at pthread_create.c:463
#9  0x00007f58d692488f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f58c7e17700 (LWP 1948)):
#0  0x00007f58d6917bf9 in __GI___poll (fds=0x7f58c7e16c68, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f58d18fa747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f58d18fc36a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f58ca5d4578 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f58d7024c72 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f58d1d366db in start_thread (arg=0x7f58c7e17700) at pthread_create.c:463
#6  0x00007f58d692488f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f58db3b5680 (LWP 1946)):
[KCrash Handler]
#6  0x00007f58d4c5ee8e in QQmlData::wasDeleted (object=0x55c67de25410) at ../../include/QtQml/5.12.3/QtQml/private/../../../../../src/qml/qml/qqmldata_p.h:337
#7  QV4::QObjectWrapper::wrap (engine=engine@entry=0x55c67af5b7e0, object=0x55c67de25410) at ../../include/QtQml/5.12.3/QtQml/private/../../../../../src/qml/jsruntime/qv4qobjectwrapper_p.h:215
#8  0x00007f58d4cfc2bc in QV4::ExecutionEngine::fromVariant (this=this@entry=0x55c67af5b7e0, variant=...) at jsruntime/qv4engine.cpp:1514
#9  0x00007f58d4c5c726 in searchContextProperties (v4=v4@entry=0x55c67af5b7e0, context=context@entry=0x55c67d7a1bf0, name=<optimized out>, hasProperty=hasProperty@entry=0x7ffde8037547, base=base@entry=0x0, lookup=lookup@entry=0x0, originalLookup=<optimized out>, ep=<optimized out>) at jsruntime/qv4qmlcontext.cpp:126
#10 0x00007f58d4c5d5b5 in QV4::QQmlContextWrapper::getPropertyAndBase (resource=<optimized out>, id=..., receiver=receiver@entry=0x0, hasProperty=hasProperty@entry=0x7ffde8037547, base=base@entry=0x0, lookup=0x0, lookup@entry=0x55c67d4f9040) at jsruntime/qv4qmlcontext.cpp:274
#11 0x00007f58d4c5de30 in QV4::QQmlContextWrapper::resolveQmlContextPropertyLookupGetter (l=0x55c67d4f9040, engine=0x55c67af5b7e0, base=0x0) at jsruntime/qv4qmlcontext.cpp:474
#12 0x00007f588f771bac in ?? ()
#13 0x0000000000000000 in ?? ()

The reporter indicates this bug may be a duplicate of or related to bug 404518.

Possible duplicates by query: bug 409008, bug 404518.

Reported using DrKonqi
Comment 1 Christoph Feck 2019-08-20 20:11:05 UTC

*** This bug has been marked as a duplicate of bug 404518 ***