Bug 409008 - crash during deinstalltion from a second installesdlanguage ( polski )
Summary: crash during deinstalltion from a second installesdlanguage ( polski )
Status: RESOLVED DUPLICATE of bug 404518
Alias: None
Product: systemsettings
Classification: Unclassified
Component: general (show other bugs)
Version: 5.16.1
Platform: Neon Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-06-21 18:36 UTC by Stefan Becker
Modified: 2019-07-16 12:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Becker 2019-06-21 18:36:25 UTC
Application: systemsettings5 (5.16.1)

Qt Version: 5.12.3
Frameworks Version: 5.59.0
Operating System: Linux 5.1.12-050112-generic x86_64
Distribution: KDE neon User Edition 5.16

-- Information about the crash:
- i select the second installed language ( polski ) the first installaed language is german

The crash can be reproduced every time.

-- Backtrace:
Application: Systemeinstellungen (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f5cf9b76680 (LWP 28309))]

Thread 7 (Thread 0x7f5cba0ed700 (LWP 28317)):
#0  0x00007f5cee185379 in g_mutex_lock () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f5cee13ea33 in g_main_context_prepare () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5cee13f3fb in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5cee13f5dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5cf5a21dcb in QEventDispatcherGlib::processEvents (this=0x7f5cb4000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f5cf59c303a in QEventLoop::exec (this=this@entry=0x7f5cba0ecd40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#6  0x00007f5cf57ea4ca in QThread::exec (this=this@entry=0x5572b5ee43a0) at thread/qthread.cpp:531
#7  0x00007f5cf35a0115 in QQmlThreadPrivate::run (this=0x5572b5ee43a0) at qml/ftw/qqmlthread.cpp:148
#8  0x00007f5cf57ebc72 in QThreadPrivate::start (arg=0x5572b5ee43a0) at thread/qthread_unix.cpp:361
#9  0x00007f5cf04fd6db in start_thread (arg=0x7f5cba0ed700) at pthread_create.c:463
#10 0x00007f5cf50eb88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f5cc0c17700 (LWP 28316)):
#0  0x00007f5cee13ea18 in g_main_context_prepare () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f5cee13f3fb in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5cee13f5dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5cf5a21dcb in QEventDispatcherGlib::processEvents (this=0x7f5cbc000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f5cf59c303a in QEventLoop::exec (this=this@entry=0x7f5cc0c16d40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007f5cf57ea4ca in QThread::exec (this=this@entry=0x5572b3173d90) at thread/qthread.cpp:531
#6  0x00007f5cf35a0115 in QQmlThreadPrivate::run (this=0x5572b3173d90) at qml/ftw/qqmlthread.cpp:148
#7  0x00007f5cf57ebc72 in QThreadPrivate::start (arg=0x5572b3173d90) at thread/qthread_unix.cpp:361
#8  0x00007f5cf04fd6db in start_thread (arg=0x7f5cc0c17700) at pthread_create.c:463
#9  0x00007f5cf50eb88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f5cc958f700 (LWP 28314)):
#0  0x00007f5cf50da0b4 in __GI___libc_read (fd=13, buf=0x7f5cc958eb30, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007f5cee184000 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5cee13efb7 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5cee13f470 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5cee13f5dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f5cf5a21dcb in QEventDispatcherGlib::processEvents (this=0x7f5cc4000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f5cf59c303a in QEventLoop::exec (this=this@entry=0x7f5cc958ed40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#7  0x00007f5cf57ea4ca in QThread::exec (this=this@entry=0x5572b2e0e550) at thread/qthread.cpp:531
#8  0x00007f5cf35a0115 in QQmlThreadPrivate::run (this=0x5572b2e0e550) at qml/ftw/qqmlthread.cpp:148
#9  0x00007f5cf57ebc72 in QThreadPrivate::start (arg=0x5572b2e0e550) at thread/qthread_unix.cpp:361
#10 0x00007f5cf04fd6db in start_thread (arg=0x7f5cc958f700) at pthread_create.c:463
#11 0x00007f5cf50eb88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f5cd5914700 (LWP 28312)):
#0  0x00007f5cf05039f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5572b2ae6958) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x5572b2ae6908, cond=0x5572b2ae6930) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x5572b2ae6930, mutex=0x5572b2ae6908) at pthread_cond_wait.c:655
#3  0x00007f5cd6cb3dcb in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f5cd6cb3af7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f5cf04fd6db in start_thread (arg=0x7f5cd5914700) at pthread_create.c:463
#6  0x00007f5cf50eb88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f5cde279700 (LWP 28311)):
#0  idleTimerSourceCheck (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:221
#1  0x00007f5cee13eee1 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5cee13f470 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5cee13f5dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5cf5a21dcb in QEventDispatcherGlib::processEvents (this=0x7f5cd8000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f5cf59c303a in QEventLoop::exec (this=this@entry=0x7f5cde278d30, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#6  0x00007f5cf57ea4ca in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#7  0x00007f5cf5e90015 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#8  0x00007f5cf57ebc72 in QThreadPrivate::start (arg=0x7f5cf6107d80) at thread/qthread_unix.cpp:361
#9  0x00007f5cf04fd6db in start_thread (arg=0x7f5cde279700) at pthread_create.c:463
#10 0x00007f5cf50eb88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f5ce62c0700 (LWP 28310)):
#0  0x00007f5cf50debf9 in __GI___poll (fds=0x7f5ce62bfc68, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f5cf00c1747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f5cf00c336a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f5ce8a7d578 in QXcbEventQueue::run (this=0x5572b29f10f0) at qxcbeventqueue.cpp:228
#4  0x00007f5cf57ebc72 in QThreadPrivate::start (arg=0x5572b29f10f0) at thread/qthread_unix.cpp:361
#5  0x00007f5cf04fd6db in start_thread (arg=0x7f5ce62c0700) at pthread_create.c:463
#6  0x00007f5cf50eb88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f5cf9b76680 (LWP 28309)):
[KCrash Handler]
#6  0x00007f5cf3425e8e in QQmlData::wasDeleted (object=0x5572ba66f3c0) at ../../include/QtQml/5.12.3/QtQml/private/../../../../../src/qml/qml/qqmldata_p.h:337
#7  QV4::QObjectWrapper::wrap (engine=engine@entry=0x5572b600b2d0, object=0x5572ba66f3c0) at ../../include/QtQml/5.12.3/QtQml/private/../../../../../src/qml/jsruntime/qv4qobjectwrapper_p.h:215
#8  0x00007f5cf34c32bc in QV4::ExecutionEngine::fromVariant (this=this@entry=0x5572b600b2d0, variant=...) at jsruntime/qv4engine.cpp:1514
#9  0x00007f5cf3423726 in searchContextProperties (v4=v4@entry=0x5572b600b2d0, context=context@entry=0x5572ba651c10, name=<optimized out>, hasProperty=hasProperty@entry=0x7ffc8b8e2277, base=base@entry=0x0, lookup=lookup@entry=0x0, originalLookup=<optimized out>, ep=<optimized out>) at jsruntime/qv4qmlcontext.cpp:126
#10 0x00007f5cf34245b5 in QV4::QQmlContextWrapper::getPropertyAndBase (resource=<optimized out>, id=..., receiver=receiver@entry=0x0, hasProperty=hasProperty@entry=0x7ffc8b8e2277, base=base@entry=0x0, lookup=0x0, lookup@entry=0x5572b606e060) at jsruntime/qv4qmlcontext.cpp:274
#11 0x00007f5cf3424e30 in QV4::QQmlContextWrapper::resolveQmlContextPropertyLookupGetter (l=0x5572b606e060, engine=0x5572b600b2d0, base=0x0) at jsruntime/qv4qmlcontext.cpp:474
#12 0x00007f5cb86ec2c8 in ?? ()
#13 0x0000000000000000 in ?? ()

Possible duplicates by query: bug 404518.

Reported using DrKonqi
Comment 1 Christoph Feck 2019-07-16 12:41:51 UTC

*** This bug has been marked as a duplicate of bug 404518 ***