Bug 411837 - settings crash
Summary: settings crash
Status: RESOLVED DUPLICATE of bug 404518
Alias: None
Product: systemsettings
Classification: Unclassified
Component: general (show other bugs)
Version: 5.16.5
Platform: Neon Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-09-12 00:50 UTC by Muhammad ALi
Modified: 2019-09-19 23:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Muhammad ALi 2019-09-12 00:50:35 UTC
Application: systemsettings5 (5.16.5)

Qt Version: 5.12.3
Frameworks Version: 5.61.0
Operating System: Linux 5.0.0-27-generic x86_64
Distribution: KDE neon User Edition 5.16

-- Information about the crash:
- What I was doing when the application crashed: trying to delete the second language in language/regional settings/system settings

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f176f96a680 (LWP 27625))]

Thread 7 (Thread 0x7f172fd4a700 (LWP 20159)):
#0  0x00007f176aed4bf9 in __GI___poll (fds=0x55e7343dd3a0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f1763f345c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1763f34962 in g_main_loop_run () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1730eec0e6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f1763f5c195 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f17662f36db in start_thread (arg=0x7f172fd4a700) at pthread_create.c:463
#6  0x00007f176aee188f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f173054b700 (LWP 20158)):
#0  0x00007f1763f7a649 in g_mutex_lock () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f1763f346c8 in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1763f34721 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1763f5c195 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f17662f36db in start_thread (arg=0x7f173054b700) at pthread_create.c:463
#5  0x00007f176aee188f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f173e2bb700 (LWP 20072)):
#0  0x00007f176aed00b4 in __GI___libc_read (fd=13, buf=0x7f173e2bab30, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007f1763f792d0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1763f340b7 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1763f34570 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1763f346dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f176b817dcb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f176b7b903a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f176b5e04ca in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f1769396115 in QQmlThreadPrivate::run (this=0x55e7308ea150) at qml/ftw/qqmlthread.cpp:148
#9  0x00007f176b5e1c72 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f17662f36db in start_thread (arg=0x7f173e2bb700) at pthread_create.c:463
#11 0x00007f176aee188f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f174b67c700 (LWP 27629)):
#0  0x00007f17662f99f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55e73061b06c) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x55e73061b018, cond=0x55e73061b040) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x55e73061b040, mutex=0x55e73061b018) at pthread_cond_wait.c:655
#3  0x00007f1750bc00aa in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f1750bbfdd7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f17662f36db in start_thread (arg=0x7f174b67c700) at pthread_create.c:463
#6  0x00007f176aee188f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f1753fff700 (LWP 27628)):
#0  0x00007f176aed4bf9 in __GI___poll (fds=0x7f174c016e90, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f1763f345c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1763f346dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f176b817dcb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f176b7b903a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f176b5e04ca in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f176bc86015 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f176b5e1c72 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f17662f36db in start_thread (arg=0x7f1753fff700) at pthread_create.c:463
#9  0x00007f176aee188f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f175c3ec700 (LWP 27627)):
#0  0x00007f176aed4bf9 in __GI___poll (fds=0x7f175c3ebc68, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f1765eb7747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f1765eb936a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f175eba9578 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f176b5e1c72 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f17662f36db in start_thread (arg=0x7f175c3ec700) at pthread_create.c:463
#6  0x00007f176aee188f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f176f96a680 (LWP 27625)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f17692e7c59 in QJSEnginePrivate::cache (minorVersion=-1, obj=0x55e733b207c0, this=0x55e730b93430) at ../../include/QtQml/5.12.3/QtQml/private/../../../../../src/qml/jsapi/qjsengine_p.h:169
#8  QQmlData::createPropertyCache (engine=engine@entry=0x55e730b77d00, object=object@entry=0x55e733b207c0) at qml/qqmlengine.cpp:2020
#9  0x00007f176923b41b in QQmlData::ensurePropertyCache (object=0x55e733b207c0, engine=0x55e730b77d00) at ../../include/QtQml/5.12.3/QtQml/private/../../../../../src/qml/qml/qqmldata_p.h:283
#10 QV4::QObjectWrapper::create (engine=<optimized out>, engine@entry=0x55e730c4d860, object=object@entry=0x55e733b207c0) at jsruntime/qv4qobjectwrapper.cpp:688
#11 0x00007f176923d7eb in QV4::QObjectWrapper::wrap_slowPath (engine=0x55e730c4d860, object=0x55e733b207c0) at jsruntime/qv4qobjectwrapper.cpp:616
#12 0x00007f176921becb in QV4::QObjectWrapper::wrap (engine=engine@entry=0x55e730c4d860, object=<optimized out>) at ../../include/QtQml/5.12.3/QtQml/private/../../../../../src/qml/jsruntime/qv4qobjectwrapper_p.h:224
#13 0x00007f17692b92bc in QV4::ExecutionEngine::fromVariant (this=this@entry=0x55e730c4d860, variant=...) at jsruntime/qv4engine.cpp:1514
#14 0x00007f1769219726 in searchContextProperties (v4=v4@entry=0x55e730c4d860, context=context@entry=0x55e733b24210, name=<optimized out>, hasProperty=hasProperty@entry=0x7ffdd00ddeb7, base=base@entry=0x0, lookup=lookup@entry=0x0, originalLookup=<optimized out>, ep=<optimized out>) at jsruntime/qv4qmlcontext.cpp:126
#15 0x00007f176921a5b5 in QV4::QQmlContextWrapper::getPropertyAndBase (resource=<optimized out>, id=..., receiver=receiver@entry=0x0, hasProperty=hasProperty@entry=0x7ffdd00ddeb7, base=base@entry=0x0, lookup=0x0, lookup@entry=0x55e730deee20) at jsruntime/qv4qmlcontext.cpp:274
#16 0x00007f176921ae30 in QV4::QQmlContextWrapper::resolveQmlContextPropertyLookupGetter (l=0x55e730deee20, engine=0x55e730c4d860, base=0x0) at jsruntime/qv4qmlcontext.cpp:474
#17 0x00007f173c007038 in ?? ()
#18 0x0000000000000000 in ?? ()

Reported using DrKonqi
Comment 1 David Edmundson 2019-09-19 23:58:59 UTC

*** This bug has been marked as a duplicate of bug 404518 ***