Bug 408747 - System Settings crashes when trying to modify language from list
Summary: System Settings crashes when trying to modify language from list
Status: RESOLVED DUPLICATE of bug 404518
Alias: None
Product: systemsettings
Classification: Unclassified
Component: general (show other bugs)
Version: 5.16.0
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-06-15 17:48 UTC by null
Modified: 2019-07-03 14:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description null 2019-06-15 17:48:41 UTC
Application: systemsettings5 (5.16.0)

Qt Version: 5.12.3
Frameworks Version: 5.59.0
Operating System: Linux 4.19.49-1-lts x86_64
Distribution: "Arch Linux"

-- Information about the crash:
- What I was doing when the application crashed:
System settings does not let you chance your settings under System Settings -> Language. I tried removing a language (German and Japanese) and adding a language (American English), it always causes the application to segfault.

- Custom settings of the application:
Current Language list includes: British English, German, Japanese

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fbf53320140 (LWP 10672))]

Thread 6 (Thread 0x7fbf3a7e5700 (LWP 10699)):
#0  0x00007fbf581000d1 in poll () at /usr/lib/libc.so.6
#1  0x00007fbf55dca7c0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007fbf55dcb7f2 in g_main_loop_run () at /usr/lib/libglib-2.0.so.0
#3  0x00007fbf4b397508 in  () at /usr/lib/libgio-2.0.so.0
#4  0x00007fbf55da5f21 in  () at /usr/lib/libglib-2.0.so.0
#5  0x00007fbf56b03a92 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fbf5810acd3 in clone () at /usr/lib/libc.so.6

Thread 5 (Thread 0x7fbf3afe6700 (LWP 10698)):
#0  0x00007fbf581000d1 in poll () at /usr/lib/libc.so.6
#1  0x00007fbf55dca7c0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007fbf55dca8ae in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007fbf55dca902 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007fbf55da5f21 in  () at /usr/lib/libglib-2.0.so.0
#5  0x00007fbf56b03a92 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fbf5810acd3 in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7fbf42f5d700 (LWP 10696)):
#0  0x00007fbf581000d1 in poll () at /usr/lib/libc.so.6
#1  0x00007fbf55dca7c0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007fbf55dca8ae in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007fbf58633984 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007fbf585dd4dc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007fbf58422239 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007fbf577af059 in  () at /usr/lib/libQt5Qml.so.5
#7  0x00007fbf5842363c in  () at /usr/lib/libQt5Core.so.5
#8  0x00007fbf56b03a92 in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007fbf5810acd3 in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7fbf43c91700 (LWP 10675)):
#0  0x00007fbf56b09bac in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fbf482b0304 in  () at /usr/lib/dri/i965_dri.so
#2  0x00007fbf482b0028 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007fbf56b03a92 in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007fbf5810acd3 in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7fbf50d14700 (LWP 10674)):
#0  0x00007fbf581000d1 in poll () at /usr/lib/libc.so.6
#1  0x00007fbf55dca7c0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007fbf55dca8ae in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007fbf58633984 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007fbf585dd4dc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007fbf58422239 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007fbf588abba6 in  () at /usr/lib/libQt5DBus.so.5
#7  0x00007fbf5842363c in  () at /usr/lib/libQt5Core.so.5
#8  0x00007fbf56b03a92 in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007fbf5810acd3 in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7fbf53320140 (LWP 10672)):
[KCrash Handler]
#6  0x00007fbf5762e6ae in QV4::QObjectWrapper::wrap(QV4::ExecutionEngine*, QObject*) () at /usr/lib/libQt5Qml.so.5
#7  0x00007fbf576cee25 in QV4::ExecutionEngine::fromVariant(QVariant const&) () at /usr/lib/libQt5Qml.so.5
#8  0x00007fbf5762bd33 in  () at /usr/lib/libQt5Qml.so.5
#9  0x00007fbf5762cc3a in QV4::QQmlContextWrapper::getPropertyAndBase(QV4::QQmlContextWrapper const*, QV4::PropertyKey, QV4::Value const*, bool*, QV4::Value*, QV4::Lookup*) () at /usr/lib/libQt5Qml.so.5
#10 0x00007fbf5762d4b7 in QV4::QQmlContextWrapper::resolveQmlContextPropertyLookupGetter(QV4::Lookup*, QV4::ExecutionEngine*, QV4::Value*) () at /usr/lib/libQt5Qml.so.5
#11 0x00007fbf401cf598 in  ()
#12 0x0000000000000000 in  ()
[Inferior 1 (process 10672) detached]

Reported using DrKonqi
Comment 1 Christoph Feck 2019-07-03 14:38:50 UTC

*** This bug has been marked as a duplicate of bug 404518 ***