Bug 403491 - kcmshell crashes when adding non-English language to system translations
Summary: kcmshell crashes when adding non-English language to system translations
Status: RESOLVED DUPLICATE of bug 404518
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcmshell (show other bugs)
Version: 5.14.5
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-22 09:46 UTC by Daniel
Modified: 2019-09-20 00:02 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Crash backtrace given by "Report bug" app (3.27 KB, text/plain)
2019-01-22 09:46 UTC, Daniel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2019-01-22 09:46:35 UTC
Created attachment 117611 [details]
Crash backtrace given by "Report bug" app

STEPS TO REPRODUCE
1. Goto System Settings -> Regional Settings -> Language
2. Tap on "Add languages..."
3. Select anything not English and tap "Add"

OBSERVED RESULT
"System Settings closed unexpectedly" notification 

EXPECTED RESULT
New language in the list...

SOFTWARE/OS VERSIONS
Operating System: Arch Linux 
KDE Plasma Version: 5.14.5
Qt Version: 5.12.0
KDE Frameworks Version: 5.54.0
Kernel Version: 4.20.3-arch1-1-ARCH
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-4790 CPU @ 3.60GHz
Memory: 11.7 GiB of RAM

ADDITIONAL INFORMATION
The needed locale was generated previously (UTF-8, primarily, but also tried KOI8-R and ISO-8859-5 (for Russian))
Comment 1 Kai Uwe Broulik 2019-01-22 09:47:55 UTC
Thread 1 (Thread 0x7ffa92ef7cc0 (LWP 1350)):
[KCrash Handler]
#6  0x00007ffa97cab75e in QV4::QObjectWrapper::wrap(QV4::ExecutionEngine*, QObject*) () from /usr/lib/libQt5Qml.so.5
#7  0x00007ffa97d1c9e5 in QV4::ExecutionEngine::fromVariant(QVariant const&) () from /usr/lib/libQt5Qml.so.5
#8  0x00007ffa97c7e027 in QV4::QQmlContextWrapper::virtualGet(QV4::Managed const*, QV4::PropertyKey, QV4::Value const*, bool*) () from /usr/lib/libQt5Qml.so.5
#9  0x00007ffa97c2416d in QV4::ExecutionContext::getProperty(QV4::String*) () from /usr/lib/libQt5Qml.so.5
#10 0x00007ffa97d2408e in QV4::Runtime::method_loadName(QV4::ExecutionEngine*, int) () from /usr/lib/libQt5Qml.so.5
Comment 2 Patrick Silva 2019-02-20 19:24:25 UTC
bug 404518 seems related
Comment 3 David Edmundson 2019-09-20 00:02:51 UTC

*** This bug has been marked as a duplicate of bug 404518 ***