Bug 411910 - System settings crached after adding two languages
Summary: System settings crached after adding two languages
Status: RESOLVED DUPLICATE of bug 404518
Alias: None
Product: systemsettings
Classification: Unclassified
Component: general (show other bugs)
Version: 5.16.5
Platform: Neon Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-09-14 08:46 UTC by Marcin Gurtowski
Modified: 2019-09-15 13:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Gurtowski 2019-09-14 08:46:59 UTC
Application: systemsettings5 (5.16.5)

Qt Version: 5.12.3
Frameworks Version: 5.61.0
Operating System: Linux 5.0.0-27-generic x86_64
Distribution: KDE neon User Edition 5.16

-- Information about the crash:
Steps to reproduce:
(I use polish version of KDE so names may differ)
- Go into system settings -> regional settings -> language
- Add to languages -> polski
- Add to languages -> American English

Expected result:
- Both languages are added

Actual result:
- Application crashes

-- Backtrace:
Application: Ustawienia systemowe (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1593ed3680 (LWP 6346))]

Thread 8 (Thread 0x7f154c9f5700 (LWP 6358)):
#0  0x00007f158f4510b4 in __GI___libc_read (fd=35, buf=0x7f154c9f4c90, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007f15884fa2d0 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f15884b50b7 in g_main_context_check () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f15884b5570 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f15884b5962 in g_main_loop_run () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f154db970e6 in  () at /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#6  0x00007f15884dd195 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f158a8746db in start_thread (arg=0x7f154c9f5700) at pthread_create.c:463
#8  0x00007f158f46288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7f154d1f6700 (LWP 6357)):
#0  0x00007f15884fb649 in g_mutex_lock () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f15884b4e1f in g_main_context_check () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f15884b5570 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f15884b56dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f15884b5721 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f15884dd195 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f158a8746db in start_thread (arg=0x7f154d1f6700) at pthread_create.c:463
#7  0x00007f158f46288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f155564c700 (LWP 6354)):
#0  0x00007f15884b24a0 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f15884b4ef2 in g_main_context_check () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f15884b5570 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f15884b56dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f158fd98dcb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f158fd3a03a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f158fb614ca in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f158d917115 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f158fb62c72 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f158a8746db in start_thread (arg=0x7f155564c700) at pthread_create.c:463
#10 0x00007f158f46288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f155f5ef700 (LWP 6352)):
#0  0x00007f15884fb649 in g_mutex_lock () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f15884b4b33 in g_main_context_prepare () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f15884b54fb in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f15884b56dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f158fd98dcb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f158fd3a03a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f158fb614ca in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f158d917115 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f158fb62c72 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f158a8746db in start_thread (arg=0x7f155f5ef700) at pthread_create.c:463
#10 0x00007f158f46288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f15687e3700 (LWP 6351)):
#0  0x00007f158f455bf9 in __GI___poll (fds=0x7f1560004a00, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f15884b55c9 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f15884b56dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f158fd98dcb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f158fd3a03a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f158fb614ca in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f158d917115 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f158fb62c72 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f158a8746db in start_thread (arg=0x7f15687e3700) at pthread_create.c:463
#9  0x00007f158f46288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f1577fff700 (LWP 6349)):
#0  0x00007f158f455bf9 in __GI___poll (fds=0x7f1570013c70, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f15884b55c9 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f15884b56dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f158fd98dcb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f158fd3a03a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f158fb614ca in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f1590207015 in  () at /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f158fb62c72 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f158a8746db in start_thread (arg=0x7f1577fff700) at pthread_create.c:463
#9  0x00007f158f46288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f158055e700 (LWP 6348)):
#0  0x00007f158f455bf9 in __GI___poll (fds=0x7f158055dc68, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f158a438747 in  () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f158a43a36a in xcb_wait_for_event () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f1582d1b578 in  () at /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f158fb62c72 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f158a8746db in start_thread (arg=0x7f158055e700) at pthread_create.c:463
#6  0x00007f158f46288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f1593ed3680 (LWP 6346)):
[KCrash Handler]
#6  0x00007f158d88ec55 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f158d88ed06 in QQmlMetaType::propertyCache(QMetaObject const*, int) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f158d868c66 in QQmlData::createPropertyCache(QJSEngine*, QObject*) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f158d7bc41b in QV4::QObjectWrapper::create(QV4::ExecutionEngine*, QObject*) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#10 0x00007f158d7be7eb in QV4::QObjectWrapper::wrap_slowPath(QV4::ExecutionEngine*, QObject*) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#11 0x00007f158d83a2bc in QV4::ExecutionEngine::fromVariant(QVariant const&) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#12 0x00007f158d79a726 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#13 0x00007f158d79b5b5 in QV4::QQmlContextWrapper::getPropertyAndBase(QV4::QQmlContextWrapper const*, QV4::PropertyKey, QV4::Value const*, bool*, QV4::Value*, QV4::Lookup*) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#14 0x00007f158d79be30 in QV4::QQmlContextWrapper::resolveQmlContextPropertyLookupGetter(QV4::Lookup*, QV4::ExecutionEngine*, QV4::Value*) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#15 0x00007f15576018ac in  ()
#16 0x0000000000000000 in  ()

Reported using DrKonqi
Comment 1 Karl Ove Hufthammer 2019-09-15 13:06:54 UTC
I can confirm this (tested with two other languages – Norwegian Nynorsk and American English). System information:

Operating System: openSUSE Tumbleweed 20190909
KDE Plasma Version: 5.16.5
KDE Frameworks Version: 5.61.0
Qt Version: 5.13.1
Kernel Version: 5.2.11-1-default
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-2500 CPU @ 3.30GHz
Memory: 15,6 GiB
Comment 2 Karl Ove Hufthammer 2019-09-15 13:10:15 UTC

*** This bug has been marked as a duplicate of bug 404518 ***