Bug 326875 - kpat crash
Summary: kpat crash
Status: RESOLVED DUPLICATE of bug 308099
Alias: None
Product: kpat
Classification: Applications
Component: general (show other bugs)
Version: 3.6
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-10-30 12:58 UTC by Egon Lehmann
Modified: 2013-10-30 13:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Egon Lehmann 2013-10-30 12:58:40 UTC
Application: kpat (3.6)
KDE Platform Version: 4.10.5 "release 1"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.16-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I selected a game after the previous game was finished. The kpat was a lot of time running.

The crash can be reproduced sometimes.

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f8bdf275b0d in lock (this=<optimized out>) at /usr/src/debug/kdelibs-4.10.5/kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7ffffd5ddec0) at /usr/src/debug/kdelibs-4.10.5/kdecore/util/kshareddatacache.cpp:1255
#8  0x00007f8bdf276160 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7ffffd5ddec0, _d=<optimized out>) at /usr/src/debug/kdelibs-4.10.5/kdecore/util/kshareddatacache.cpp:1278
#9  0x00007f8bdf26e1ae in KSharedDataCache::find (this=0x1178140, key=..., destination=0x7ffffd5ddf30) at /usr/src/debug/kdelibs-4.10.5/kdecore/util/kshareddatacache.cpp:1630
#10 0x00007f8bdf7ae052 in KImageCache::findPixmap (this=0x1178140, key=..., destination=0x3c25b58) at /usr/src/debug/kdelibs-4.10.5/kdeui/util/kimagecache.cpp:150
#11 0x00007f8be04e588a in KAbstractCardDeckPrivate::requestPixmap (this=0x10d5400, id=<optimized out>, faceUp=<optimized out>) at /usr/src/debug/kpat-4.10.5/libkcardgame/kabstractcarddeck.cpp:205
#12 0x00007f8be04e5aa0 in KAbstractCardDeck::cardPixmap (this=<optimized out>, id=<optimized out>, faceUp=<optimized out>) at /usr/src/debug/kpat-4.10.5/libkcardgame/kabstractcarddeck.cpp:506
#13 0x00007f8be04e80e7 in KCard::paint (this=0x102ac00, painter=0x7ffffd5de750, option=<optimized out>, widget=<optimized out>) at /usr/src/debug/kpat-4.10.5/libkcardgame/kcard.cpp:319
#14 0x00007f8bde684f05 in QGraphicsScenePrivate::draw (this=this@entry=0x27386a0, item=item@entry=0x102ac10, painter=painter@entry=0x7ffffd5de750, viewTransform=viewTransform@entry=0x7ffffd5de8e0, transformPtr=transformPtr@entry=0x7ffffd5de3f0, exposedRegion=exposedRegion@entry=0xfc83a8, widget=0xffcb30, opacity=opacity@entry=1, effectTransform=effectTransform@entry=0x0, wasDirtyParentSceneTransform=wasDirtyParentSceneTransform@entry=true, drawItem=true) at graphicsview/qgraphicsscene.cpp:4964
#15 0x00007f8bde685c85 in QGraphicsScenePrivate::drawSubtreeRecursive (this=this@entry=0x27386a0, item=0x102ac10, painter=painter@entry=0x7ffffd5de750, viewTransform=viewTransform@entry=0x7ffffd5de8e0, exposedRegion=exposedRegion@entry=0xfc83a8, widget=widget@entry=0xffcb30, parentOpacity=parentOpacity@entry=1, effectTransform=effectTransform@entry=0x0) at graphicsview/qgraphicsscene.cpp:4857
#16 0x00007f8bde68676e in QGraphicsScenePrivate::drawItems (this=0x27386a0, painter=0x7ffffd5de750, viewTransform=0x7ffffd5de8e0, exposedRegion=0xfc83a8, widget=0xffcb30) at graphicsview/qgraphicsscene.cpp:4739
#17 0x00007f8bde6a2a68 in QGraphicsView::paintEvent (this=0xfc7ec0, event=<optimized out>) at graphicsview/qgraphicsview.cpp:3471
#18 0x00007f8bde0e10fe in QWidget::event (this=0xfc7ec0, event=0x7ffffd5df3a0) at kernel/qwidget.cpp:8532
#19 0x00007f8bde48bf26 in QFrame::event (this=0xfc7ec0, e=0x7ffffd5df3a0) at widgets/qframe.cpp:557
#20 0x00007f8bde6a3bbb in QGraphicsView::viewportEvent (this=0xfc7ec0, event=0x7ffffd5df3a0) at graphicsview/qgraphicsview.cpp:2866
#21 0x00007f8bdece7ef6 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0xffcb30, event=0x7ffffd5df3a0) at kernel/qcoreapplication.cpp:1056
#22 0x00007f8bde09183c in QApplicationPrivate::notify_helper (this=this@entry=0xdf48d0, receiver=receiver@entry=0xffcb30, e=e@entry=0x7ffffd5df3a0) at kernel/qapplication.cpp:4558
#23 0x00007f8bde095ceb in QApplication::notify (this=0x7ffffd5e1790, receiver=0xffcb30, e=0x7ffffd5df3a0) at kernel/qapplication.cpp:4423
#24 0x00007f8bdf74c7f6 in KApplication::notify (this=0x7ffffd5e1790, receiver=0xffcb30, event=0x7ffffd5df3a0) at /usr/src/debug/kdelibs-4.10.5/kdeui/kernel/kapplication.cpp:311
#25 0x00007f8bdece7d8e in QCoreApplication::notifyInternal (this=0x7ffffd5e1790, receiver=0xffcb30, event=0x7ffffd5df3a0) at kernel/qcoreapplication.cpp:946
#26 0x00007f8bde0dccc4 in sendSpontaneousEvent (event=0x7ffffd5df3a0, receiver=0xffcb30) at ../../src/corelib/kernel/qcoreapplication.h:234
#27 QWidgetPrivate::drawWidget (this=this@entry=0xffcc40, pdev=pdev@entry=0x10afdd0, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0x1068790) at kernel/qwidget.cpp:5598
#28 0x00007f8bde0dd7bf in QWidgetPrivate::paintSiblingsRecursive (this=0xfc7f20, pdev=0x10afdd0, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1068790) at kernel/qwidget.cpp:5807
#29 0x00007f8bde0dc855 in QWidgetPrivate::drawWidget (this=this@entry=0xfc7f20, pdev=pdev@entry=0x10afdd0, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0x1068790) at kernel/qwidget.cpp:5651
#30 0x00007f8bde0dd7bf in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0xfa9cb0, pdev=pdev@entry=0x10afdd0, siblings=..., index=<optimized out>, index@entry=10, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0x1068790) at kernel/qwidget.cpp:5807
#31 0x00007f8bde0dd604 in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0xfa9cb0, pdev=pdev@entry=0x10afdd0, siblings=..., index=10, index@entry=18, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0x1068790) at kernel/qwidget.cpp:5794
#32 0x00007f8bde0dd604 in QWidgetPrivate::paintSiblingsRecursive (this=0xfa9cb0, pdev=0x10afdd0, siblings=..., index=18, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1068790) at kernel/qwidget.cpp:5794
#33 0x00007f8bde0dc855 in QWidgetPrivate::drawWidget (this=0xfa9cb0, pdev=0x10afdd0, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0x1068790) at kernel/qwidget.cpp:5651
#34 0x00007f8bde2a7168 in QWidgetBackingStore::sync (this=0x1068790) at painting/qbackingstore.cpp:1373
#35 0x00007f8bde0d1960 in QWidgetPrivate::syncBackingStore (this=this@entry=0xfa9cb0) at kernel/qwidget.cpp:1896
#36 0x00007f8bde0e15a4 in QWidget::event (this=0xfb1c40, event=0x200a520) at kernel/qwidget.cpp:8679
#37 0x00007f8bde4a54fb in QMainWindow::event (this=0xfb1c40, event=0x200a520) at widgets/qmainwindow.cpp:1478
#38 0x00007f8bdf83e748 in KXmlGuiWindow::event (this=0xfb1c40, ev=0x200a520) at /usr/src/debug/kdelibs-4.10.5/kdeui/xmlgui/kxmlguiwindow.cpp:126
#39 0x00007f8bde09186c in QApplicationPrivate::notify_helper (this=this@entry=0xdf48d0, receiver=receiver@entry=0xfb1c40, e=e@entry=0x200a520) at kernel/qapplication.cpp:4562
#40 0x00007f8bde095ceb in QApplication::notify (this=0x7ffffd5e1790, receiver=0xfb1c40, e=0x200a520) at kernel/qapplication.cpp:4423
#41 0x00007f8bdf74c7f6 in KApplication::notify (this=0x7ffffd5e1790, receiver=0xfb1c40, event=0x200a520) at /usr/src/debug/kdelibs-4.10.5/kdeui/kernel/kapplication.cpp:311
#42 0x00007f8bdece7d8e in QCoreApplication::notifyInternal (this=0x7ffffd5e1790, receiver=receiver@entry=0xfb1c40, event=event@entry=0x200a520) at kernel/qcoreapplication.cpp:946
#43 0x00007f8bdeceb6f1 in sendEvent (event=0x200a520, receiver=0xfb1c40) at kernel/qcoreapplication.h:231
#44 QCoreApplicationPrivate::sendPostedEvents (receiver=0xfb1c40, event_type=77, data=0xda3780) at kernel/qcoreapplication.cpp:1570
#45 0x00007f8bde675282 in dispatchPendingUpdateRequests (this=0xfc7f20) at ../../src/gui/graphicsview/qgraphicsview_p.h:200
#46 QGraphicsScenePrivate::_q_emitUpdated (this=0x27386a0) at graphicsview/qgraphicsscene.cpp:390
#47 0x00007f8bde67f9b9 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at .moc/release-shared/moc_qgraphicsscene.cpp:105
#48 QGraphicsScene::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qgraphicsscene.cpp:86
#49 0x00007f8bdecfc77e in QObject::event (this=0x3a858f0, e=<optimized out>) at kernel/qobject.cpp:1203
#50 0x00007f8bde68a249 in QGraphicsScene::event (this=0x3a858f0, event=0x3a38780) at graphicsview/qgraphicsscene.cpp:3565
#51 0x00007f8bde09186c in QApplicationPrivate::notify_helper (this=this@entry=0xdf48d0, receiver=receiver@entry=0x3a858f0, e=e@entry=0x3a38780) at kernel/qapplication.cpp:4562
#52 0x00007f8bde095ceb in QApplication::notify (this=0x7ffffd5e1790, receiver=0x3a858f0, e=0x3a38780) at kernel/qapplication.cpp:4423
#53 0x00007f8bdf74c7f6 in KApplication::notify (this=0x7ffffd5e1790, receiver=0x3a858f0, event=0x3a38780) at /usr/src/debug/kdelibs-4.10.5/kdeui/kernel/kapplication.cpp:311
#54 0x00007f8bdece7d8e in QCoreApplication::notifyInternal (this=0x7ffffd5e1790, receiver=receiver@entry=0x3a858f0, event=event@entry=0x3a38780) at kernel/qcoreapplication.cpp:946
#55 0x00007f8bdeceb6f1 in sendEvent (event=0x3a38780, receiver=0x3a858f0) at kernel/qcoreapplication.h:231
#56 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xda3780) at kernel/qcoreapplication.cpp:1570
#57 0x00007f8bded16133 in sendPostedEvents () at kernel/qcoreapplication.h:236
#58 postEventSourceDispatch (s=0xde7400) at kernel/qeventdispatcher_glib.cpp:279
#59 0x00007f8bd918c7d5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#60 0x00007f8bd918cb08 in ?? () from /usr/lib64/libglib-2.0.so.0
#61 0x00007f8bd918cbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#62 0x00007f8bded162c6 in QEventDispatcherGlib::processEvents (this=0xda8c30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#63 0x00007f8bde131c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#64 0x00007f8bdece6adf in QEventLoop::processEvents (this=this@entry=0x7ffffd5e1500, flags=...) at kernel/qeventloop.cpp:149
#65 0x00007f8bdece6d68 in QEventLoop::exec (this=0x7ffffd5e1500, flags=...) at kernel/qeventloop.cpp:204
#66 0x00007f8bdeceba08 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#67 0x000000000041989a in main (argc=3, argv=0x7ffffd5e1948) at /usr/src/debug/kpat-4.10.5/main.cpp:325

Possible duplicates by query: bug 323698, bug 323249, bug 322092, bug 321881, bug 321477.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-10-30 13:09:26 UTC

*** This bug has been marked as a duplicate of bug 308099 ***