Bug 323698 - KPat Crash After Selecting Grandfather's Clock
Summary: KPat Crash After Selecting Grandfather's Clock
Status: RESOLVED DUPLICATE of bug 309824
Alias: None
Product: kpat
Classification: Applications
Component: general (show other bugs)
Version: 3.6
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-08-19 03:12 UTC by KitchM
Modified: 2013-08-19 04:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description KitchM 2013-08-19 03:12:34 UTC
Application: kpat (3.6)
KDE Platform Version: 4.10.5
Qt Version: 4.8.5
Operating System: Linux 3.10.7-200.fc19.x86_64 x86_64
Distribution: "Fedora release 19 (Schrödinger’s Cat)"

-- Information about the crash:
- What I was doing when the application crashed:
The last game had been finished and it was idling in the background.  When I brought the game to the foreground and selected Grandfather's Clock, it flashed on for a split second and then closed.

Fedora 19 with Xfce 4.10.1 and Firefox 23 running a video that was paused.

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
40	  int result = INLINE_SYSCALL (wait4, 4, pid, stat_loc, options, NULL);
[KCrash Handler]
#5  0x0000003a99a2c5d5 in lock (this=0x1944eb0) at /usr/src/debug/kdelibs-4.10.5/kdecore/util/kshareddatacache.cpp:1231
#6  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fffc8a981e0) at /usr/src/debug/kdelibs-4.10.5/kdecore/util/kshareddatacache.cpp:1255
#7  0x0000003a99a2cf90 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fffc8a981e0, _d=<optimized out>) at /usr/src/debug/kdelibs-4.10.5/kdecore/util/kshareddatacache.cpp:1278
#8  0x0000003a99a25e25 in KSharedDataCache::find (this=this@entry=0x1b6d270, key=..., destination=destination@entry=0x7fffc8a98280) at /usr/src/debug/kdelibs-4.10.5/kdecore/util/kshareddatacache.cpp:1630
#9  0x00000030e40a0885 in KImageCache::findPixmap (this=0x1b6d270, key=..., destination=destination@entry=0x7fffc8a982e0) at /usr/src/debug/kdelibs-4.10.5/kdeui/util/kimagecache.cpp:150
#10 0x00000030e741601c in KAbstractCardDeckPrivate::submitRendering (this=0x1c5ed80, elementId=..., image=...) at /usr/src/debug/kpat-4.10.5/libkcardgame/kabstractcarddeck.cpp:247
#11 0x00000030e7416355 in KAbstractCardDeckPrivate::qt_static_metacall (_o=0x1c5ed80, _c=26496688, _id=-928415104, _a=0x1) at /usr/src/debug/kpat-4.10.5/x86_64-redhat-linux-gnu/libkcardgame/kabstractcarddeck_p.moc:136
#12 0x0000003a9819232e in QObject::event (this=0x1c5ed80, e=<optimized out>) at kernel/qobject.cpp:1194
#13 0x00000030e29c84dc in QApplicationPrivate::notify_helper (this=0x1861fb0, receiver=0x1c5ed80, e=0x7fd3e8086780) at kernel/qapplication.cpp:4562
#14 0x00000030e29ceaa0 in QApplication::notify (this=this@entry=0x7fffc8a98b70, receiver=receiver@entry=0x1c5ed80, e=e@entry=0x7fd3e8086780) at kernel/qapplication.cpp:4348
#15 0x00000030e40415ba in KApplication::notify (this=0x7fffc8a98b70, receiver=0x1c5ed80, event=0x7fd3e8086780) at /usr/src/debug/kdelibs-4.10.5/kdeui/kernel/kapplication.cpp:311
#16 0x0000003a9817a26d in QCoreApplication::notifyInternal (this=0x7fffc8a98b70, receiver=receiver@entry=0x1c5ed80, event=event@entry=0x7fd3e8086780) at kernel/qcoreapplication.cpp:949
#17 0x0000003a9817d1df in sendEvent (event=0x7fd3e8086780, receiver=0x1c5ed80) at kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x181a280) at kernel/qcoreapplication.cpp:1573
#19 0x0000003a9817d683 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1466
#20 0x0000003a981a7883 in sendPostedEvents () at kernel/qcoreapplication.h:236
#21 postEventSourceDispatch (s=0x185a6e0) at kernel/qeventdispatcher_glib.cpp:280
#22 0x0000003a93647e06 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#23 0x0000003a93648158 in g_main_context_iterate.isra.22 () from /lib64/libglib-2.0.so.0
#24 0x0000003a936481fc in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#25 0x0000003a981a7145 in QEventDispatcherGlib::processEvents (this=0x181bbe0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#26 0x00000030e2a64fc6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#27 0x0000003a98178ecf in QEventLoop::processEvents (this=this@entry=0x7fffc8a989b0, flags=...) at kernel/qeventloop.cpp:149
#28 0x0000003a981791c5 in QEventLoop::exec (this=this@entry=0x7fffc8a989b0, flags=...) at kernel/qeventloop.cpp:204
#29 0x0000003a9817e45b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#30 0x00000030e29c6c9c in QApplication::exec () at kernel/qapplication.cpp:3823
#31 0x0000000000418a6f in main (argc=3, argv=0x7fffc8a98ce8) at /usr/src/debug/kpat-4.10.5/main.cpp:325

Possible duplicates by query: bug 323249, bug 322092, bug 321881, bug 321477, bug 321383.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-08-19 04:18:25 UTC

*** This bug has been marked as a duplicate of bug 309824 ***