Bug 308099 - KPat crashed after game was completed and graphics (cards to deck) were almost? finished.
Summary: KPat crashed after game was completed and graphics (cards to deck) were almos...
Status: RESOLVED DUPLICATE of bug 309824
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kshareddatacache (show other bugs)
Version: 4.8.5
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 309692 311966 321477 326875 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-08 23:32 UTC by mannis
Modified: 2014-01-26 20:22 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mannis 2012-10-08 23:32:10 UTC
Application: kpat (3.6)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-31-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Had just completed the forty and eight game and the cards were moving to the foundations,
VLC was running, no further key or mouse input was given, waiting to select new deal.

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f626fcdf780 (LWP 26403))]

Thread 3 (Thread 0x7f625a2d5700 (LWP 26406)):
#0  0x00007f626c68b403 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f6268680036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f626868049a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f625a2da98b in ?? () from /usr/lib/x86_64-linux-gnu/gio/modules/libdconfsettings.so
#4  0x00007f62686a19e5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f6268f44e9a in start_thread (arg=0x7f625a2d5700) at pthread_create.c:308
#6  0x00007f626c696dbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f62598ce700 (LWP 26407)):
#0  0x00007f6268655a60 in g_ptr_array_set_size () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f626867f6f6 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f626867ff5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f626868049a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6260bc3406 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#5  0x00007f62686a19e5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f6268f44e9a in start_thread (arg=0x7f62598ce700) at pthread_create.c:308
#7  0x00007f626c696dbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f626fcdf780 (LWP 26403)):
[KCrash Handler]
#6  0x00007f626e339d55 in lock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7ffff61094e0) at ../../kdecore/util/kshareddatacache.cpp:1255
#8  0x00007f626e33a8e0 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7ffff61094e0, _d=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1278
#9  0x00007f626e333ee6 in KSharedDataCache::find (this=0xe15600, key=..., destination=0x7ffff6109550) at ../../kdecore/util/kshareddatacache.cpp:1630
#10 0x00007f626e86f8af in KImageCache::findPixmap (this=0xe15600, key=..., destination=0x26dda68) at ../../kdeui/util/kimagecache.cpp:150
#11 0x00007f626f8e167a in KAbstractCardDeckPrivate::requestPixmap (this=0xf9dd10, id=<optimized out>, faceUp=<optimized out>) at ../../../kpat/libkcardgame/kabstractcarddeck.cpp:205
#12 0x00007f626f8e1870 in KAbstractCardDeck::cardPixmap (this=<optimized out>, id=<optimized out>, faceUp=<optimized out>) at ../../../kpat/libkcardgame/kabstractcarddeck.cpp:506
#13 0x00007f626f8e3ea4 in KCard::paint (this=0x12e18b0, painter=0x7ffff610a330, option=<optimized out>, widget=<optimized out>) at ../../../kpat/libkcardgame/kcard.cpp:319
#14 0x00007f626d7478a9 in QGraphicsScenePrivate::draw (this=0x2391e10, item=0x12e18c0, painter=0x7ffff610a330, viewTransform=0x7ffff610a000, transformPtr=0x7ffff6109ad0, exposedRegion=0xd15628, widget=0xd29000, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4964
#15 0x00007f626d7483d5 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x2391e10, item=0x12e18c0, painter=0x7ffff610a330, viewTransform=0x7ffff610a000, exposedRegion=0xd15628, widget=0xd29000, parentOpacity=<optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4857
#16 0x00007f626d748bf1 in QGraphicsScenePrivate::drawItems (this=0x2391e10, painter=0x7ffff610a330, viewTransform=0x7ffff610a000, exposedRegion=0xd15628, widget=0xd29000) at graphicsview/qgraphicsscene.cpp:4739
#17 0x00007f626d761870 in QGraphicsView::paintEvent (this=<optimized out>, event=<optimized out>) at graphicsview/qgraphicsview.cpp:3471
#18 0x00007f626d1780f6 in QWidget::event (this=0xd15140, event=0x7ffff610acd0) at kernel/qwidget.cpp:8508
#19 0x00007f626d5383b6 in QFrame::event (this=0xd15140, e=0x7ffff610acd0) at widgets/qframe.cpp:557
#20 0x00007f626d762b2b in QGraphicsView::viewportEvent (this=0xd15140, event=0x7ffff610acd0) at graphicsview/qgraphicsview.cpp:2866
#21 0x00007f626dda5028 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0xd29000, event=0x7ffff610acd0) at kernel/qcoreapplication.cpp:986
#22 0x00007f626d12785f in notify_helper (e=0x7ffff610acd0, receiver=0xd29000, this=0xa73af0) at kernel/qapplication.cpp:4555
#23 QApplicationPrivate::notify_helper (this=0xa73af0, receiver=0xd29000, e=0x7ffff610acd0) at kernel/qapplication.cpp:4531
#24 0x00007f626d12c713 in QApplication::notify (this=0x7ffff610cfe0, receiver=0xd29000, e=0x7ffff610acd0) at kernel/qapplication.cpp:4420
#25 0x00007f626e80a3f6 in KApplication::notify (this=0x7ffff610cfe0, receiver=0xd29000, event=0x7ffff610acd0) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007f626dda4e9c in QCoreApplication::notifyInternal (this=0x7ffff610cfe0, receiver=0xd29000, event=0x7ffff610acd0) at kernel/qcoreapplication.cpp:876
#27 0x00007f626d173d96 in sendSpontaneousEvent (event=0x7ffff610acd0, receiver=0xd29000) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#28 QWidgetPrivate::drawWidget (this=0xd29030, pdev=0xe1b0f0, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xddf210) at kernel/qwidget.cpp:5585
#29 0x00007f626d174a0f in QWidgetPrivate::paintSiblingsRecursive (this=0xd151a0, pdev=0xe1b0f0, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xddf210) at kernel/qwidget.cpp:5794
#30 0x00007f626d173acc in QWidgetPrivate::drawWidget (this=0xd151a0, pdev=0xe1b0f0, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0xddf210) at kernel/qwidget.cpp:5638
#31 0x00007f626d174a0f in QWidgetPrivate::paintSiblingsRecursive (this=0xcccfe0, pdev=0xe1b0f0, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xddf210) at kernel/qwidget.cpp:5794
#32 0x00007f626d173acc in QWidgetPrivate::drawWidget (this=0xcccfe0, pdev=0xe1b0f0, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0xddf210) at kernel/qwidget.cpp:5638
#33 0x00007f626d344b58 in QWidgetBackingStore::sync (this=0xddf210) at painting/qbackingstore.cpp:1373
#34 0x00007f626d16aac0 in QWidgetPrivate::syncBackingStore (this=0xcccfe0) at kernel/qwidget.cpp:1891
#35 0x00007f626d17860c in QWidget::event (this=0xccce90, event=0x2552990) at kernel/qwidget.cpp:8655
#36 0x00007f626d551c4b in QMainWindow::event (this=0xccce90, event=0x2552990) at widgets/qmainwindow.cpp:1478
#37 0x00007f626e906378 in KXmlGuiWindow::event (this=0xccce90, ev=0x2552990) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
#38 0x00007f626d127894 in notify_helper (e=0x2552990, receiver=0xccce90, this=0xa73af0) at kernel/qapplication.cpp:4559
#39 QApplicationPrivate::notify_helper (this=0xa73af0, receiver=0xccce90, e=0x2552990) at kernel/qapplication.cpp:4531
#40 0x00007f626d12c713 in QApplication::notify (this=0x7ffff610cfe0, receiver=0xccce90, e=0x2552990) at kernel/qapplication.cpp:4420
#41 0x00007f626e80a3f6 in KApplication::notify (this=0x7ffff610cfe0, receiver=0xccce90, event=0x2552990) at ../../kdeui/kernel/kapplication.cpp:311
#42 0x00007f626dda4e9c in QCoreApplication::notifyInternal (this=0x7ffff610cfe0, receiver=0xccce90, event=0x2552990) at kernel/qcoreapplication.cpp:876
#43 0x00007f626dda8c6a in sendEvent (event=0x2552990, receiver=0xccce90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#44 QCoreApplicationPrivate::sendPostedEvents (receiver=0xccce90, event_type=77, data=0xa32ff0) at kernel/qcoreapplication.cpp:1500
#45 0x00007f626d73d90a in dispatchPendingUpdateRequests (this=0xd151a0) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:200
#46 QGraphicsScenePrivate::_q_processDirtyItems (this=0x2391e10) at graphicsview/qgraphicsscene.cpp:515
#47 0x00007f626d73da61 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at .moc/release-shared/moc_qgraphicsscene.cpp:107
#48 QGraphicsScene::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qgraphicsscene.cpp:86
#49 0x00007f626ddbe446 in QObject::event (this=0x2333990, e=<optimized out>) at kernel/qobject.cpp:1195
#50 0x00007f626d7445d9 in QGraphicsScene::event (this=0x2333990, event=0x2346100) at graphicsview/qgraphicsscene.cpp:3565
#51 0x00007f626d127894 in notify_helper (e=0x2346100, receiver=0x2333990, this=0xa73af0) at kernel/qapplication.cpp:4559
#52 QApplicationPrivate::notify_helper (this=0xa73af0, receiver=0x2333990, e=0x2346100) at kernel/qapplication.cpp:4531
#53 0x00007f626d12c713 in QApplication::notify (this=0x7ffff610cfe0, receiver=0x2333990, e=0x2346100) at kernel/qapplication.cpp:4420
#54 0x00007f626e80a3f6 in KApplication::notify (this=0x7ffff610cfe0, receiver=0x2333990, event=0x2346100) at ../../kdeui/kernel/kapplication.cpp:311
#55 0x00007f626dda4e9c in QCoreApplication::notifyInternal (this=0x7ffff610cfe0, receiver=0x2333990, event=0x2346100) at kernel/qcoreapplication.cpp:876
#56 0x00007f626dda8c6a in sendEvent (event=0x2346100, receiver=0x2333990) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#57 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xa32ff0) at kernel/qcoreapplication.cpp:1500
#58 0x00007f626ddd3f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#59 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#60 0x00007f626867fd53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#61 0x00007f62686800a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#62 0x00007f6268680164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#63 0x00007f626ddd43bf in QEventDispatcherGlib::processEvents (this=0xa344b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#64 0x00007f626d1cfd5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#65 0x00007f626dda3c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#66 0x00007f626dda3ed7 in QEventLoop::exec (this=0x7ffff610ced0, flags=...) at kernel/qeventloop.cpp:204
#67 0x00007f626dda8f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#68 0x00000000004189ea in main (argc=3, argv=0x7ffff610db68) at ../../kpat/main.cpp:325

Possible duplicates by query: bug 307328, bug 303310, bug 284770.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-11-07 12:30:51 UTC
*** Bug 309692 has been marked as a duplicate of this bug. ***
Comment 2 Jekyll Wu 2012-12-20 06:34:02 UTC
*** Bug 311966 has been marked as a duplicate of this bug. ***
Comment 3 Jekyll Wu 2013-06-22 03:03:18 UTC
*** Bug 321477 has been marked as a duplicate of this bug. ***
Comment 4 Jekyll Wu 2013-10-30 13:09:26 UTC
*** Bug 326875 has been marked as a duplicate of this bug. ***
Comment 5 Jekyll Wu 2014-01-26 04:02:05 UTC

*** This bug has been marked as a duplicate of bug 309824 ***
Comment 6 Egon Lehmann 2014-01-26 20:22:13 UTC
Am 26.01.2014 05:02, schrieb Jekyll Wu:
> https://bugs.kde.org/show_bug.cgi?id=308099
>
> Jekyll Wu <adaptee@gmail.com> changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |RESOLVED
>          Resolution|---                         |DUPLICATE
>
> --- Comment #5 from Jekyll Wu <adaptee@gmail.com> ---
>
>
> *** This bug has been marked as a duplicate of bug 309824 ***
>
Thanks for the Information, now I use opensuse 13.1 and the buck is
never occurred.
regards

Egon Lehmann