Bug 321477 - KPatience crashed when a new Game "Grossvaters Uhr" was clicked to start
Summary: KPatience crashed when a new Game "Grossvaters Uhr" was clicked to start
Status: RESOLVED DUPLICATE of bug 308099
Alias: None
Product: kpat
Classification: Applications
Component: general (show other bugs)
Version: 3.6
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-21 20:42 UTC by ArpadOsvald
Modified: 2013-06-22 03:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ArpadOsvald 2013-06-21 20:42:19 UTC
Application: kpat (3.6)
KDE Platform Version: 4.8.5 (4.8.5) "release 2"
Qt Version: 4.8.1
Operating System: Linux 3.4.42-2.28-desktop i686
Distribution: "openSUSE 12.2 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
just finished successfully "Mod3" and clicked "Neues Spiel" then clicked on "Grossvaters Uhr" to start

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[KCrash Handler]
#7  0xb6d9cded in lock (this=<optimized out>) at /usr/src/debug/kdelibs-4.8.5/kdecore/util/kshareddatacache.cpp:1231
#8  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0xbfca0494) at /usr/src/debug/kdelibs-4.8.5/kdecore/util/kshareddatacache.cpp:1255
#9  0xb6d9d4ea in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0xbfca0494, _d=0x8922ab8) at /usr/src/debug/kdelibs-4.8.5/kdecore/util/kshareddatacache.cpp:1278
#10 0xb6d94a68 in KSharedDataCache::find (this=0x899b0d8, key=..., destination=0xbfca04e8) at /usr/src/debug/kdelibs-4.8.5/kdecore/util/kshareddatacache.cpp:1630
#11 0xb70a0504 in KImageCache::findPixmap (this=0x899b0d8, key=..., destination=0x8bc15d4) at /usr/src/debug/kdelibs-4.8.5/kdeui/util/kimagecache.cpp:150
#12 0xb76fcef8 in KAbstractCardDeckPrivate::requestPixmap (this=0x895e178, id=id@entry=10, faceUp=faceUp@entry=true) at /usr/src/debug/kdegames-4.8.5/kpat/libkcardgame/kabstractcarddeck.cpp:205
#13 0xb76fd18c in KAbstractCardDeck::cardPixmap (this=0x895e0f0, id=10, faceUp=true) at /usr/src/debug/kdegames-4.8.5/kpat/libkcardgame/kabstractcarddeck.cpp:506
#14 0xbfca0624 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

This bug may be a duplicate of or related to bug 308099.

Possible duplicates by query: bug 321383, bug 315929, bug 313924, bug 313545, bug 311966.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-06-22 03:03:18 UTC

*** This bug has been marked as a duplicate of bug 308099 ***