Bug 322092 - Kpatience crash when selecting a game
Summary: Kpatience crash when selecting a game
Status: RESOLVED DUPLICATE of bug 309824
Alias: None
Product: kpat
Classification: Applications
Component: general (show other bugs)
Version: 3.6
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-07 23:08 UTC by kolb.john79
Modified: 2013-07-08 00:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kolb.john79 2013-07-07 23:08:48 UTC
Application: kpat (3.6)
KDE Platform Version: 4.10.90
Qt Version: 4.8.4
Operating System: Linux 3.10.0-2-generic x86_64
Distribution: Ubuntu Saucy Salamander (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

I had just opened Kpatience and directly after I clicked on "Klondike" the program crashed. May be related to other bug reports featuring Kpatience.

The crash can be reproduced sometimes.

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f90e93ee7c0 (LWP 2188))]

Thread 2 (Thread 0x7f90d5477700 (LWP 2189)):
#0  0x00007f90e1cefcda in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f90e1cf0159 in g_private_get () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f90e1cd50c0 in g_thread_self () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f90e1cb048d in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f90e7587d16 in QEventDispatcherGlib::processEvents (this=0x7f90d00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f90e755986f in QEventLoop::processEvents (this=this@entry=0x7f90d5476d70, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f90e7559b65 in QEventLoop::exec (this=this@entry=0x7f90d5476d70, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f90e7458abf in QThread::exec (this=this@entry=0x28cb6b0) at thread/qthread.cpp:542
#8  0x00007f90e753af93 in QInotifyFileSystemWatcherEngine::run (this=0x28cb6b0) at io/qfilesystemwatcher_inotify.cpp:256
#9  0x00007f90e745b15f in QThreadPrivate::start (arg=0x28cb6b0) at thread/qthread_unix.cpp:338
#10 0x00007f90e237ff8e in start_thread (arg=0x7f90d5477700) at pthread_create.c:311
#11 0x00007f90e5e49e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f90e93ee7c0 (LWP 2188)):
[KCrash Handler]
#6  0x00007f90e7ae4b25 in lock (this=0x2a242d0) at ../../kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff01004920) at ../../kdecore/util/kshareddatacache.cpp:1255
#8  0x00007f90e7ae54e0 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff01004920, _d=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1278
#9  0x00007f90e7ade375 in KSharedDataCache::find (this=this@entry=0x275e400, key=..., destination=destination@entry=0x7fff010049c0) at ../../kdecore/util/kshareddatacache.cpp:1630
#10 0x00007f90e8260565 in KImageCache::findPixmap (this=0x275e400, key=..., destination=0x7fff01004a20) at ../../kdeui/util/kimagecache.cpp:150
#11 0x0000000000458d0d in ?? ()
#12 0x000000000045904d in ?? ()
#13 0x00007f90e757306e in QObject::event (this=0x2a24c00, e=<optimized out>) at kernel/qobject.cpp:1194
#14 0x00007f90e68f300c in QApplicationPrivate::notify_helper (this=this@entry=0x2587cc0, receiver=receiver@entry=0x2a24c00, e=e@entry=0x7f90bc0030a0) at kernel/qapplication.cpp:4567
#15 0x00007f90e68f9680 in QApplication::notify (this=this@entry=0x7fff010052a0, receiver=receiver@entry=0x2a24c00, e=e@entry=0x7f90bc0030a0) at kernel/qapplication.cpp:4353
#16 0x00007f90e82019aa in KApplication::notify (this=0x7fff010052a0, receiver=0x2a24c00, event=0x7f90bc0030a0) at ../../kdeui/kernel/kapplication.cpp:311
#17 0x00007f90e755ab3d in QCoreApplication::notifyInternal (this=0x7fff010052a0, receiver=receiver@entry=0x2a24c00, event=event@entry=0x7f90bc0030a0) at kernel/qcoreapplication.cpp:946
#18 0x00007f90e755e09f in sendEvent (event=0x7f90bc0030a0, receiver=0x2a24c00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x254ed90) at kernel/qcoreapplication.cpp:1570
#20 0x00007f90e755e543 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#21 0x00007f90e7588313 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#22 postEventSourceDispatch (s=0x258f4c0) at kernel/qeventdispatcher_glib.cpp:279
#23 0x00007f90e1cb00a6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f90e1cb03f8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f90e1cb049c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f90e7587cf5 in QEventDispatcherGlib::processEvents (this=0x25502d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#27 0x00007f90e6994c66 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f90e755986f in QEventLoop::processEvents (this=this@entry=0x7fff010050e0, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007f90e7559b65 in QEventLoop::exec (this=this@entry=0x7fff010050e0, flags=...) at kernel/qeventloop.cpp:204
#30 0x00007f90e755f0db in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#31 0x000000000041fa3f in ?? ()
#32 0x00007f90e5d71ea5 in __libc_start_main (main=0x41d970, argc=3, ubp_av=0x7fff01005418, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff01005408) at libc-start.c:260
#33 0x0000000000420229 in _start ()

This bug may be a duplicate of or related to bug 321881.

Possible duplicates by query: bug 321881, bug 321477, bug 321383, bug 315929, bug 313924.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-07-08 00:39:59 UTC

*** This bug has been marked as a duplicate of bug 309824 ***