Bug 323249 - Crashed when resizing Yukon window
Summary: Crashed when resizing Yukon window
Status: RESOLVED DUPLICATE of bug 309824
Alias: None
Product: kpat
Classification: Unclassified
Component: general (show other bugs)
Version: 3.6
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-06 22:04 UTC by Simon Reed
Modified: 2013-08-07 02:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Reed 2013-08-06 22:04:55 UTC
Application: kpat (3.6)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-51-generic x86_64
Distribution: Ubuntu 12.04.2 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I have played this game both windowed and full-screen over 1,000 times.

I had played at least one game to its conclusion and had started a new one.  I changed from maximised to unmaximised and tried moving the bottom border.  This made the game crash

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4dc6b25780 (LWP 9182))]

Thread 2 (Thread 0x7f4da8d17700 (LWP 9898)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x00007f4dc4acc43f in wait (time=30000, this=0x236be50) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x236dd78, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f4dc4abf5bf in QThreadPoolThread::run (this=0x207a930) at concurrent/qthreadpool.cpp:141
#4  0x00007f4dc4acbfcb in QThreadPrivate::start (arg=0x207a930) at thread/qthread_unix.cpp:298
#5  0x00007f4dbfd27e9a in start_thread (arg=0x7f4da8d17700) at pthread_create.c:308
#6  0x00007f4dc34b3ccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4dc6b25780 (LWP 9182)):
[KCrash Handler]
#6  0x00007f4dc5165d45 in lock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff52da6070) at ../../kdecore/util/kshareddatacache.cpp:1255
#8  0x00007f4dc51668d0 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff52da6070, _d=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1278
#9  0x00007f4dc515fed6 in KSharedDataCache::find (this=0x237be20, key=..., destination=0x7fff52da60e0) at ../../kdecore/util/kshareddatacache.cpp:1630
#10 0x00007f4dc569c8af in KImageCache::findPixmap (this=0x237be20, key=..., destination=0x7fff52da6170) at ../../kdeui/util/kimagecache.cpp:150
#11 0x00007f4dc671d8fb in ?? () from /usr/lib/libkcardgame.so
#12 0x00007f4dc4be4446 in QObject::event (this=0x2207cc0, e=<optimized out>) at kernel/qobject.cpp:1195
#13 0x00007f4dc3f4b894 in notify_helper (e=0x7f4d9c0115b0, receiver=0x2207cc0, this=0x202c260) at kernel/qapplication.cpp:4559
#14 QApplicationPrivate::notify_helper (this=0x202c260, receiver=0x2207cc0, e=0x7f4d9c0115b0) at kernel/qapplication.cpp:4531
#15 0x00007f4dc3f50713 in QApplication::notify (this=0x7fff52da6c00, receiver=0x2207cc0, e=0x7f4d9c0115b0) at kernel/qapplication.cpp:4420
#16 0x00007f4dc56373f6 in KApplication::notify (this=0x7fff52da6c00, receiver=0x2207cc0, event=0x7f4d9c0115b0) at ../../kdeui/kernel/kapplication.cpp:311
#17 0x00007f4dc4bcae9c in QCoreApplication::notifyInternal (this=0x7fff52da6c00, receiver=0x2207cc0, event=0x7f4d9c0115b0) at kernel/qcoreapplication.cpp:876
#18 0x00007f4dc4bcec6a in sendEvent (event=0x7f4d9c0115b0, receiver=0x2207cc0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1fd7ff0) at kernel/qcoreapplication.cpp:1500
#20 0x00007f4dc4bf9f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#21 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#22 0x00007f4dbf457d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f4dbf4580a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f4dbf458164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f4dc4bfa3bf in QEventDispatcherGlib::processEvents (this=0x1fd94b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#26 0x00007f4dc3ff3d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f4dc4bc9c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x00007f4dc4bc9ed7 in QEventLoop::exec (this=0x7fff52da6af0, flags=...) at kernel/qeventloop.cpp:204
#29 0x00007f4dc4bcef67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#30 0x00000000004189ea in ?? ()
#31 0x00007f4dc33e176d in __libc_start_main (main=0x4168e0, argc=3, ubp_av=0x7fff52da7788, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff52da7778) at libc-start.c:226
#32 0x0000000000419349 in _start ()

This bug may be a duplicate of or related to bug 321383.

Possible duplicates by query: bug 322092, bug 321881, bug 321477, bug 321383, bug 315929.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-08-07 02:41:23 UTC

*** This bug has been marked as a duplicate of bug 309824 ***