Bug 321881 - kpatience crashed whe3n being opened
Summary: kpatience crashed whe3n being opened
Status: RESOLVED DUPLICATE of bug 309824
Alias: None
Product: kpat
Classification: Unclassified
Component: general (show other bugs)
Version: 3.6
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-03 01:15 UTC by Lester Petrie
Modified: 2013-07-08 00:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lester Petrie 2013-07-03 01:15:07 UTC
Application: kpat (3.6)
KDE Platform Version: 4.10.4
Qt Version: 4.8.4
Operating System: Linux 3.9.6-200.fc18.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

I had just tried to open kpatience when it crashed.  It hadn't displayed the game selection screen yet.

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f041e99b880 (LWP 6731))]

Thread 3 (Thread 0x7f040f829700 (LWP 6733)):
[KCrash Handler]
#5  0x0000003a4803341d in KSharedDataCache::Private::CacheLocker::cautiousLock() () from /lib64/libkdecore.so.5
#6  0x0000003a48033a70 in KSharedDataCache::Private::CacheLocker::CacheLocker(KSharedDataCache::Private const*) () from /lib64/libkdecore.so.5
#7  0x0000003a4802bfab in KSharedDataCache::insert(QString const&, QByteArray const&) () from /lib64/libkdecore.so.5
#8  0x0000003a486a849d in KImageCache::insertImage(QString const&, QImage const&) () from /lib64/libkdeui.so.5
#9  0x0000003a4ba16179 in RenderingThread::run() () from /lib64/libkcardgame.so
#10 0x00000030c747b95c in QThreadPrivate::start(void*) () from /lib64/libQtCore.so.4
#11 0x00000030bd807d15 in start_thread () from /lib64/libpthread.so.0
#12 0x00000030bccf248d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f040cef6700 (LWP 6735)):
#0  0x00000030bcce99ad in poll () from /lib64/libc.so.6
#1  0x0000003a4ae31d5f in poll_func () from /lib64/libpulse.so.0
#2  0x0000003a4ae232bc in pa_mainloop_poll () from /lib64/libpulse.so.0
#3  0x0000003a4ae23919 in pa_mainloop_iterate () from /lib64/libpulse.so.0
#4  0x0000003a4ae239d0 in pa_mainloop_run () from /lib64/libpulse.so.0
#5  0x0000003a4ae31d0f in thread () from /lib64/libpulse.so.0
#6  0x0000003a4aa42c63 in internal_thread_func () from /usr/lib64/pulseaudio/libpulsecommon-2.1.so
#7  0x00000030bd807d15 in start_thread () from /lib64/libpthread.so.0
#8  0x00000030bccf248d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f041e99b880 (LWP 6731)):
#0  0x00000030bd80e12d in read () from /lib64/libpthread.so.0
#1  0x00000030bf4840df in g_wakeup_acknowledge () from /lib64/libglib-2.0.so.0
#2  0x00000030bf4478b4 in g_main_context_check () from /lib64/libglib-2.0.so.0
#3  0x00000030bf447cc2 in g_main_context_iterate.isra.24 () from /lib64/libglib-2.0.so.0
#4  0x00000030bf447e44 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#5  0x00000030c75a5f86 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#6  0x000000358106a73e in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtGui.so.4
#7  0x00000030c75765ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#8  0x00000030c7576878 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#9  0x00000030c757b708 in QCoreApplication::exec() () from /lib64/libQtCore.so.4
#10 0x000000000041838a in main ()

Possible duplicates by query: bug 313924, bug 311966, bug 303310.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-07-08 00:39:33 UTC

*** This bug has been marked as a duplicate of bug 309824 ***