Bug 319070 - Digikam crashed when is was creating a new database
Summary: Digikam crashed when is was creating a new database
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: ColorManagement-Backend (show other bugs)
Version: 3.0.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-29 14:35 UTC by Frans Leerink
Modified: 2022-02-01 11:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.2.0


Attachments
New crash information added by DrKonqi (4.44 KB, text/plain)
2013-04-29 14:47 UTC, Frans Leerink
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frans Leerink 2013-04-29 14:35:16 UTC
Application: digikam (3.0.0)
KDE Platform Version: 4.10.2 "release 1"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.1-default i686
Distribution: "openSUSE 12.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

I have updated my openSUSE 12.1/KDE installation to openSUSE 12.3/KDE. I opened digikam for the first time and the system asked me a number of questions to do the initial setup. On the question to create a new database instead of using the old one, I selected create new database and at that moment the crash occurred.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xaf786780 (LWP 3538))]

Thread 3 (Thread 0xae03db40 (LWP 3590)):
#0  0xb440a792 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0xb4a9385c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#2  0xb5841550 in wait (time=4294967295, this=0x9983d10) at thread/qwaitcondition_unix.cpp:86
#3  QWaitCondition::wait (this=0x991134c, mutex=0x9911348, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#4  0x082117c6 in Digikam::ScanController::run (this=0x98e4d00) at /usr/src/debug/digikam-3.0.0/core/digikam/database/scancontroller.cpp:698
#5  0xb5840f78 in QThreadPrivate::start (arg=0x98e4d00) at thread/qthread_unix.cpp:338
#6  0xb4406b5e in start_thread () from /lib/libpthread.so.0
#7  0xb4a8616e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xad83db40 (LWP 3591)):
#0  0xb4a993cd in clock_gettime () from /lib/libc.so.6
#1  0xb589f975 in do_gettime (frac=0xad83cf30, sec=0xad83cf28) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb59862be in QTimerInfoList::updateCurrentTime (this=0xacf02074) at kernel/qeventdispatcher_unix.cpp:354
#4  0x7fffffff in ?? ()
#5  0xb598665a in QTimerInfoList::timerWait (this=0xacf02074, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#6  0x7fffffff in ?? ()

Thread 1 (Thread 0xaf786780 (LWP 3538)):
[KCrash Handler]
#5  0xb4a2a3d7 in strchrnul () from /lib/libc.so.6
#6  0xb49ec1cc in vfprintf () from /lib/libc.so.6
#7  0xb4a9a5b8 in __vsnprintf_chk () from /lib/libc.so.6
#8  0xb378a3b6 in vsnprintf (__ap=0xbf96b1dc "\022\203\034\263 ?\035\263@8}\267\340\237\270\t\377\377\377\377csed", __fmt=0x64657363 <Address 0x64657363 out of bounds>, __fmt@entry=0xb31c7fb0 "Tag '%lx' not found", __n=1023, __s=0xbf96adbc "") at /usr/include/bits/stdio2.h:77
#9  cmsSignalError (ContextID=ContextID@entry=0x3000, ErrorCode=ErrorCode@entry=3004989360, ErrorText=ErrorText@entry=0x64657363 <Address 0x64657363 out of bounds>) at cmserr.c:409
#10 0xb31a83ce in _cmsSearchTag (sig=icSigProfileDescriptionTag, Profile=<optimized out>, lSignalError=<optimized out>) at cmsio0.c:292
#11 _cmsSearchTag (Profile=Profile@entry=0x9b89fe0, sig=sig@entry=icSigProfileDescriptionTag, lSignalError=lSignalError@entry=1) at cmsio0.c:279
#12 0xb31ae62a in cmsReadICCTextEx (hProfile=hProfile@entry=0x9b89fe0, sig=sig@entry=icSigProfileDescriptionTag, Name=Name@entry=0xb31d3f20 <Name.7468> "", size_max=size_max@entry=512) at cmsio1.c:1675
#13 0xb31ae703 in cmsReadICCText (hProfile=hProfile@entry=0x9b89fe0, sig=sig@entry=icSigProfileDescriptionTag, Text=Text@entry=0xb31d3f20 <Name.7468> "") at cmsio1.c:1706
#14 0xb31af83c in cmsTakeProductDesc (hProfile=0x9b89fe0) at cmsio1.c:2218
#15 0xb6939286 in Digikam::IccProfile::description (this=0x99ec138) at /usr/src/debug/digikam-3.0.0/core/libs/dimg/filters/icc/iccprofile.cpp:387
#16 0xb6946f25 in Digikam::IccSettings::loadAllProfilesProperties (this=0x9923bb8) at /usr/src/debug/digikam-3.0.0/core/libs/dimg/filters/icc/iccsettings.cpp:579
#17 0xbf96b380 in ?? ()
#18 0xb5abf4ac in qDetectCPUFeatures()::features () from /usr/lib/libQtCore.so.4
#19 0xb5abf4ac in qDetectCPUFeatures()::features () from /usr/lib/libQtCore.so.4
#20 0xffffffff in ?? ()
#21 0xbf96b600 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Possible duplicates by query: bug 318991, bug 318989, bug 318987, bug 318861, bug 318848.

Reported using DrKonqi
Comment 1 Frans Leerink 2013-04-29 14:47:01 UTC
Created attachment 79550 [details]
New crash information added by DrKonqi

digikam (3.0.0) on KDE Platform 4.10.2 "release 1" using Qt 4.8.4

- What I was doing when the application crashed:

I restarted Digikam, after my initial 319070 error report, and Digikam crashed immediately.

-- Backtrace (Reduced):
#8  0xb36da3b6 in vsnprintf (__ap=0xbfc42c9c "\022\203\021\263 ?\022\263@8r\267\210\213\366\b\377\377\377\377csed", __fmt=0x64657363 <Address 0x64657363 out of bounds>, __fmt@entry=0xb3117fb0 "Tag '%lx' not found", __n=1023, __s=0xbfc4287c "") at /usr/include/bits/stdio2.h:77
#9  cmsSignalError (ContextID=ContextID@entry=0x3000, ErrorCode=ErrorCode@entry=3004268464, ErrorText=ErrorText@entry=0x64657363 <Address 0x64657363 out of bounds>) at cmserr.c:409
#10 0xb30f83ce in _cmsSearchTag (sig=icSigProfileDescriptionTag, Profile=<optimized out>, lSignalError=<optimized out>) at cmsio0.c:292
#11 _cmsSearchTag (Profile=Profile@entry=0x8f68b88, sig=sig@entry=icSigProfileDescriptionTag, lSignalError=lSignalError@entry=1) at cmsio0.c:279
#12 0xb30fe62a in cmsReadICCTextEx (hProfile=hProfile@entry=0x8f68b88, sig=sig@entry=icSigProfileDescriptionTag, Name=Name@entry=0xb3123f20 <Name.7468> "", size_max=size_max@entry=512) at cmsio1.c:1675
Comment 2 caulier.gilles 2013-04-29 14:52:39 UTC

*** This bug has been marked as a duplicate of bug 318721 ***
Comment 3 caulier.gilles 2019-07-28 02:09:54 UTC
Fixed with bug #318721