Bug 318989 - digikam crash
Summary: digikam crash
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: ColorManagement-Backend (show other bugs)
Version: 3.0.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-27 18:41 UTC by rfsrossi
Modified: 2022-02-01 11:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rfsrossi 2013-04-27 18:41:22 UTC
Application: digikam (3.0.0)
KDE Platform Version: 4.10.2 "release 1"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.1-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
abrindo o aplicativo, e depois dando o crash, foi reisntalado e nao resolveu

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f61421b7800 (LWP 5733))]

Thread 3 (Thread 0x7f61230ae700 (LWP 5734)):
#0  0x00007f6139aaa964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f613d5c462b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00000000005d4338 in Digikam::ScanController::run (this=0xd01d00) at /usr/src/debug/digikam-3.0.0/core/digikam/database/scancontroller.cpp:698
#3  0x00007f613d5c40cc in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f6139aa6e0f in start_thread () from /lib64/libpthread.so.0
#5  0x00007f613bb2e7dd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f61228ad700 (LWP 5735)):
#0  0x00007f613bb2587d in poll () from /lib64/libc.so.6
#1  0x00007f613354caa4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f613354cbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f613d6ee1f6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f613d6be9ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f613d6bec78 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f613d5c10f0 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f613d69f1af in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007f613d5c40cc in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f6139aa6e0f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f613bb2e7dd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f61421b7800 (LWP 5733)):
[KCrash Handler]
#5  0x00007f613bad3f6a in strchrnul () from /lib64/libc.so.6
#6  0x00007f613ba8cc6d in vfprintf () from /lib64/libc.so.6
#7  0x00007f613bb419f0 in __vsnprintf_chk () from /lib64/libc.so.6
#8  0x00007f6137b2ba58 in cmsSignalError () from /usr/lib64/liblcms2.so.2
#9  0x00007f61367297ad in _cmsSearchTag (sig=icSigProfileDescriptionTag, Profile=<optimized out>, lSignalError=<optimized out>) at cmsio0.c:292
#10 _cmsSearchTag (Profile=Profile@entry=0xef7db0, sig=sig@entry=icSigProfileDescriptionTag, lSignalError=lSignalError@entry=1) at cmsio0.c:279
#11 0x00007f613672f0d0 in cmsReadICCTextEx (hProfile=hProfile@entry=0xef7db0, sig=sig@entry=icSigProfileDescriptionTag, Name=Name@entry=0x7f6136952320 <Name.7711> "", size_max=size_max@entry=512) at cmsio1.c:1675
#12 0x00007f613672f16a in cmsReadICCText (hProfile=hProfile@entry=0xef7db0, sig=sig@entry=icSigProfileDescriptionTag, Text=Text@entry=0x7f6136952320 <Name.7711> "") at cmsio1.c:1706
#13 0x00007f613672ff36 in cmsTakeProductDesc (hProfile=0xef7db0) at cmsio1.c:2218
#14 0x00007f613f8cd625 in Digikam::IccProfile::description (this=0xce5890) at /usr/src/debug/digikam-3.0.0/core/libs/dimg/filters/icc/iccprofile.cpp:387
#15 0x00007f613f8d9fa3 in Digikam::IccSettings::loadAllProfilesProperties (this=0xf240c0) at /usr/src/debug/digikam-3.0.0/core/libs/dimg/filters/icc/iccsettings.cpp:585
#16 0x0000000000598d52 in Digikam::DigikamApp::DigikamApp (this=0xe4c2e0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/digikam-3.0.0/core/digikam/main/digikamapp.cpp:228
#17 0x00000000004987c1 in main (argc=5, argv=0x7fff71ed6e28) at /usr/src/debug/digikam-3.0.0/core/digikam/main/main.cpp:188

Possible duplicates by query: bug 318987, bug 318861, bug 318848, bug 318842, bug 318762.

Reported using DrKonqi
Comment 1 caulier.gilles 2013-04-27 20:45:49 UTC

*** This bug has been marked as a duplicate of bug 318721 ***
Comment 2 caulier.gilles 2017-07-23 12:55:24 UTC
Since digiKam 5.0.0, we use drop lcms version 1.x in favor of lcms version 2.x. This problem will not reproducible.