Bug 318861 - Digikam crashes on startup
Summary: Digikam crashes on startup
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: ColorManagement-Backend (show other bugs)
Version: 3.0.0
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-25 16:20 UTC by D K Pathak
Modified: 2022-02-01 11:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description D K Pathak 2013-04-25 16:20:46 UTC
Application: digikam (3.0.0)
KDE Platform Version: 4.10.2 "release 1"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.1-desktop i686
Distribution: "openSUSE 12.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

I just booted the system and started the Digikam application, it showed the  startup screen and then the crash message.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xaf734780 (LWP 1680))]

Thread 3 (Thread 0xae8e9b40 (LWP 1681)):
#0  0xb43b8792 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0xb4a4185c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#2  0xb57ef550 in wait (time=4294967295, this=0x948ed08) at thread/qwaitcondition_unix.cpp:86
#3  QWaitCondition::wait (this=0x948ec74, mutex=0x948ec70, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#4  0x082117c6 in Digikam::ScanController::run (this=0x93bfb70) at /usr/src/debug/digikam-3.0.0/core/digikam/database/scancontroller.cpp:698
#5  0xb57eef78 in QThreadPrivate::start (arg=0x93bfb70) at thread/qthread_unix.cpp:338
#6  0xb43b4b5e in start_thread () from /lib/libpthread.so.0
#7  0xb4a3416e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xadeffb40 (LWP 1682)):
#0  0xb4a29401 in poll () from /lib/libc.so.6
#1  0xb2d8a64b in g_poll () from /usr/lib/libglib-2.0.so.0
#2  0xb2d7bbd0 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb2d7bd31 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0xb59337bf in QEventDispatcherGlib::processEvents (this=0xad500468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0xb59002ac in QEventLoop::processEvents (this=this@entry=0xadeff1e8, flags=...) at kernel/qeventloop.cpp:149
#6  0xb59005a1 in QEventLoop::exec (this=0xadeff1e8, flags=...) at kernel/qeventloop.cpp:204
#7  0xb57ebb6c in QThread::exec (this=0x948ee28) at thread/qthread.cpp:542
#8  0xb58de8ad in QInotifyFileSystemWatcherEngine::run (this=0x948ee28) at io/qfilesystemwatcher_inotify.cpp:256
#9  0xb57eef78 in QThreadPrivate::start (arg=0x948ee28) at thread/qthread_unix.cpp:338
#10 0xb43b4b5e in start_thread () from /lib/libpthread.so.0
#11 0xb4a3416e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xaf734780 (LWP 1680)):
[KCrash Handler]
#5  0xb49d83d7 in strchrnul () from /lib/libc.so.6
#6  0xb499a1cc in vfprintf () from /lib/libc.so.6
#7  0xb4a485b8 in __vsnprintf_chk () from /lib/libc.so.6
#8  0xb37383b6 in vsnprintf (__ap=0xbff66e8c "\022c\027\263 \037\030\263@8x\267x\026^\t\377\377\377\377csed", __fmt=0x64657363 <Address 0x64657363 out of bounds>, __fmt@entry=0xb3175fb0 "Tag '%lx' not found", __n=1023, __s=0xbff66a6c "") at /usr/include/bits/stdio2.h:77
#9  cmsSignalError (ContextID=ContextID@entry=0x3000, ErrorCode=ErrorCode@entry=3004653488, ErrorText=ErrorText@entry=0x64657363 <Address 0x64657363 out of bounds>) at cmserr.c:409
#10 0xb31563ce in _cmsSearchTag (sig=icSigProfileDescriptionTag, Profile=<optimized out>, lSignalError=<optimized out>) at cmsio0.c:292
#11 _cmsSearchTag (Profile=Profile@entry=0x95e1678, sig=sig@entry=icSigProfileDescriptionTag, lSignalError=lSignalError@entry=1) at cmsio0.c:279
#12 0xb315c62a in cmsReadICCTextEx (hProfile=hProfile@entry=0x95e1678, sig=sig@entry=icSigProfileDescriptionTag, Name=Name@entry=0xb3181f20 <Name.7468> "", size_max=size_max@entry=512) at cmsio1.c:1675
#13 0xb315c703 in cmsReadICCText (hProfile=hProfile@entry=0x95e1678, sig=sig@entry=icSigProfileDescriptionTag, Text=Text@entry=0xb3181f20 <Name.7468> "") at cmsio1.c:1706
#14 0xb315d83c in cmsTakeProductDesc (hProfile=0x95e1678) at cmsio1.c:2218
#15 0xb68e7286 in Digikam::IccProfile::description (this=0x94ec1d8) at /usr/src/debug/digikam-3.0.0/core/libs/dimg/filters/icc/iccprofile.cpp:387
#16 0xb68f4f9d in Digikam::IccSettings::loadAllProfilesProperties (this=0x94e03c8) at /usr/src/debug/digikam-3.0.0/core/libs/dimg/filters/icc/iccsettings.cpp:585
#17 0xbff67030 in ?? ()
#18 0xb5a6d4ac in qDetectCPUFeatures()::features () from /usr/lib/libQtCore.so.4
#19 0xb5a6d4ac in qDetectCPUFeatures()::features () from /usr/lib/libQtCore.so.4
#20 0xffffffff in ?? ()
#21 0xbff67300 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Possible duplicates by query: bug 318848, bug 318842, bug 318762, bug 318744, bug 318730.

Reported using DrKonqi
Comment 1 caulier.gilles 2013-04-25 16:37:57 UTC

*** This bug has been marked as a duplicate of bug 318721 ***
Comment 2 caulier.gilles 2017-07-23 12:50:53 UTC
Since digiKam 5.0.0, we use drop lcms version 1.x in favor of lcms version 2.x. This problem will not reproducible.