Bug 318987 - Digikam crashes at startup
Summary: Digikam crashes at startup
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: ColorManagement-Backend (show other bugs)
Version: 3.0.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-27 17:44 UTC by jotapequental
Modified: 2022-02-01 11:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jotapequental 2013-04-27 17:44:48 UTC
Application: digikam (3.0.0)
KDE Platform Version: 4.10.2 "release 1"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.1-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
Digikam crashes at startup everytime, after I defined the initial settings

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2883952800 (LWP 2630))]

Thread 3 (Thread 0x7f2864a6e700 (LWP 2631)):
#0  0x00007f287b240964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f287ed5a62b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00000000005d4338 in Digikam::ScanController::run (this=0x2c0fb00) at /usr/src/debug/digikam-3.0.0/core/digikam/database/scancontroller.cpp:698
#3  0x00007f287ed5a0cc in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f287b23ce0f in start_thread () from /lib64/libpthread.so.0
#5  0x00007f287d2c47dd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f285ffff700 (LWP 2632)):
#0  0x00007fff6df2c660 in clock_gettime ()
#1  0x00007f287d2d653d in clock_gettime () from /lib64/libc.so.6
#2  0x00007f287edafd94 in ?? () from /usr/lib64/libQtCore.so.4
#3  0x00007f287ee84afd in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f287ee84e43 in ?? () from /usr/lib64/libQtCore.so.4
#5  0x00007f287ee838ac in ?? () from /usr/lib64/libQtCore.so.4
#6  0x00007f287ee83955 in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007f2874d09338 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#8  0x00007f2874d099cb in ?? () from /usr/lib64/libglib-2.0.so.0
#9  0x00007f2874d09bc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#10 0x00007f287ee841f6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#11 0x00007f287ee549ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#12 0x00007f287ee54c78 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#13 0x00007f287ed570f0 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#14 0x00007f287ee351af in ?? () from /usr/lib64/libQtCore.so.4
#15 0x00007f287ed5a0cc in ?? () from /usr/lib64/libQtCore.so.4
#16 0x00007f287b23ce0f in start_thread () from /lib64/libpthread.so.0
#17 0x00007f287d2c47dd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f2883952800 (LWP 2630)):
[KCrash Handler]
#5  0x00007f287d269f6a in strchrnul () from /lib64/libc.so.6
#6  0x00007f287d222c6d in vfprintf () from /lib64/libc.so.6
#7  0x00007f287d2d79f0 in __vsnprintf_chk () from /lib64/libc.so.6
#8  0x00007f28792e8a58 in vsnprintf (__ap=0x7fff6de11478, __fmt=0x7f2877f03cb0 "Tag '%lx' not found", __n=1023, __s=0x7fff6de11490 "") at /usr/include/bits/stdio2.h:77
#9  cmsSignalError (ContextID=ContextID@entry=0x3000, ErrorCode=ErrorCode@entry=2012232880, ErrorText=ErrorText@entry=0x64657363 <Address 0x64657363 out of bounds>) at cmserr.c:409
#10 0x00007f2877ee67ad in _cmsSearchTag (sig=icSigProfileDescriptionTag, Profile=<optimized out>, lSignalError=<optimized out>) at cmsio0.c:292
#11 _cmsSearchTag (Profile=Profile@entry=0x2e07ac0, sig=sig@entry=icSigProfileDescriptionTag, lSignalError=lSignalError@entry=1) at cmsio0.c:279
#12 0x00007f2877eec0d0 in cmsReadICCTextEx (hProfile=hProfile@entry=0x2e07ac0, sig=sig@entry=icSigProfileDescriptionTag, Name=Name@entry=0x7f287810f320 <Name.7711> "", size_max=size_max@entry=512) at cmsio1.c:1675
#13 0x00007f2877eec16a in cmsReadICCText (hProfile=hProfile@entry=0x2e07ac0, sig=sig@entry=icSigProfileDescriptionTag, Text=Text@entry=0x7f287810f320 <Name.7711> "") at cmsio1.c:1706
#14 0x00007f2877eecf36 in cmsTakeProductDesc (hProfile=0x2e07ac0) at cmsio1.c:2218
#15 0x00007f2881063625 in Digikam::IccProfile::description (this=0x2e04530) at /usr/src/debug/digikam-3.0.0/core/libs/dimg/filters/icc/iccprofile.cpp:387
#16 0x00007f288106ff25 in Digikam::IccSettings::loadAllProfilesProperties (this=0x2ca3100) at /usr/src/debug/digikam-3.0.0/core/libs/dimg/filters/icc/iccsettings.cpp:579
#17 0x0000000000598d52 in Digikam::DigikamApp::DigikamApp (this=0x2c5fd10, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/digikam-3.0.0/core/digikam/main/digikamapp.cpp:228
#18 0x00000000004987c1 in main (argc=5, argv=0x7fff6de124c8) at /usr/src/debug/digikam-3.0.0/core/digikam/main/main.cpp:188

This bug may be a duplicate of or related to bug 318721.

Possible duplicates by query: bug 318861, bug 318848, bug 318842, bug 318762, bug 318744.

Reported using DrKonqi
Comment 1 caulier.gilles 2013-04-27 18:07:02 UTC

*** This bug has been marked as a duplicate of bug 318721 ***
Comment 2 caulier.gilles 2017-07-23 12:58:47 UTC
Since digiKam 5.0.0, we use drop lcms version 1.x in favor of lcms version 2.x. This problem will not reproducible.