Bug 318848 - Crash on startup the application
Summary: Crash on startup the application
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: ColorManagement-Backend (show other bugs)
Version: 3.0.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-25 12:51 UTC by Ronny Wilde
Modified: 2022-02-01 11:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ronny Wilde 2013-04-25 12:51:17 UTC
kde4-config -v
Qt: 4.8.4
KDE: 4.10.2 "release 1"
kde4-config: 1.0

ldd /usr/bin/digikam |grep gst
        libgstreamer-0.10.so.0 => /usr/lib64/libgstreamer-0.10.so.0 (0x00007f930c818000)
        libgstapp-0.10.so.0 => /usr/lib64/libgstapp-0.10.so.0 (0x00007f930c608000)
        libgstvideo-0.10.so.0 => /usr/lib64/libgstvideo-0.10.so.0 (0x00007f930c3e8000)
        libgstbase-0.10.so.0 => /usr/lib64/libgstbase-0.10.so.0 (0x00007f9306400000)
        libgstinterfaces-0.10.so.0 => /usr/lib64/libgstinterfaces-0.10.so.0 (0x00007f9305378000)
        libgstpbutils-0.10.so.0 => /usr/lib64/libgstpbutils-0.10.so.0 (0x00007f9305150000)

Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fbd0a909800 (LWP 7404))]

Thread 3 (Thread 0x7fbceb587700 (LWP 7405)):
#0  0x00007fbd02163964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbd05cc262b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00000000005d4338 in Digikam::ScanController::run (this=0x2697dd0) at /usr/src/debug/digikam-3.0.0/core/digikam/database/scancontroller.cpp:698
#3  0x00007fbd05cc20cc in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007fbd0215fe0f in start_thread () from /lib64/libpthread.so.0
#5  0x00007fbd042207dd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fbcead86700 (LWP 7406)):
#0  0x00007fbd0421787d in poll () from /lib64/libc.so.6
#1  0x00007fbcfbb9aaa4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fbcfbb9abc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fbd05dec1f6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007fbd05dbc9ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007fbd05dbcc78 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007fbd05cbf0f0 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007fbd05d9d1af in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007fbd05cc20cc in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007fbd0215fe0f in start_thread () from /lib64/libpthread.so.0
#10 0x00007fbd042207dd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fbd0a909800 (LWP 7404)):
[KCrash Handler]
#5  0x00007fbd041c5f6a in strchrnul () from /lib64/libc.so.6
#6  0x00007fbd0417ec6d in vfprintf () from /lib64/libc.so.6
#7  0x00007fbd042339f0 in __vsnprintf_chk () from /lib64/libc.so.6
#8  0x00007fbd001eda58 in vsnprintf (__ap=0x7fffffbe5238, __fmt=0x7fbcfedebcb0 "Tag '%lx' not found", __n=1023, __s=0x7fffffbe5250 "") at /usr/include/bits/stdio2.h:77
#9  cmsSignalError (ContextID=ContextID@entry=0x3000, ErrorCode=ErrorCode@entry=4276010160, ErrorText=ErrorText@entry=0x64657363 <Address 0x64657363 out of bounds>) at cmserr.c:409
#10 0x00007fbcfedce7ad in _cmsSearchTag (sig=icSigProfileDescriptionTag, Profile=<optimized out>, lSignalError=<optimized out>) at cmsio0.c:292
#11 _cmsSearchTag (Profile=Profile@entry=0x276e8c0, sig=sig@entry=icSigProfileDescriptionTag, lSignalError=lSignalError@entry=1) at cmsio0.c:279
#12 0x00007fbcfedd40d0 in cmsReadICCTextEx (hProfile=hProfile@entry=0x276e8c0, sig=sig@entry=icSigProfileDescriptionTag, Name=Name@entry=0x7fbcfeff7320 <Name.7711> "", size_max=size_max@entry=512) at cmsio1.c:1675
#13 0x00007fbcfedd416a in cmsReadICCText (hProfile=hProfile@entry=0x276e8c0, sig=sig@entry=icSigProfileDescriptionTag, Text=Text@entry=0x7fbcfeff7320 <Name.7711> "") at cmsio1.c:1706
#14 0x00007fbcfedd4f36 in cmsTakeProductDesc (hProfile=0x276e8c0) at cmsio1.c:2218
#15 0x00007fbd07fec625 in Digikam::IccProfile::description (this=0x27470b0) at /usr/src/debug/digikam-3.0.0/core/libs/dimg/filters/icc/iccprofile.cpp:387
#16 0x00007fbd07ff8fa3 in Digikam::IccSettings::loadAllProfilesProperties (this=0x27cf840) at /usr/src/debug/digikam-3.0.0/core/libs/dimg/filters/icc/iccsettings.cpp:585
#17 0x0000000000598d52 in Digikam::DigikamApp::DigikamApp (this=0x26eebd0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/digikam-3.0.0/core/digikam/main/digikamapp.cpp:228
#18 0x00000000004987c1 in main (argc=5, argv=0x7fffffbe6288) at /usr/src/debug/digikam-3.0.0/core/digikam/main/main.cpp:188





Reproducible: Always

Steps to Reproduce:
1. Install fresh opensuse12.3 from CD
2. Start digikam - application works fine
3. zypper up
4. Start digikam - application crashed
Comment 1 caulier.gilles 2013-04-25 12:58:34 UTC

*** This bug has been marked as a duplicate of bug 318721 ***
Comment 2 Ronny Wilde 2013-04-25 13:14:07 UTC
Resolving:

https://bugzilla.novell.com/show_bug.cgi?id=816693#add_comment

Bug #816693 Overview 

Marcus Meissner 2013-04-23 13:35:23 UTC

Raymond ... for you

[reply] [-] Comment 2 Raymond Wooninck 2013-04-24 12:37:45 UTC

I have submitted an update of Digikam, that also resolves another bug regarding
camera detection to the 12.3:Update repo (Maintenance request). 

This would resolve the issue as that digikam would be build against an updated
library that came with the 4.10.2 update.

This is maintenance request #173170

[reply] [-] Comment 3 Bernhard Wiedemann 2013-04-24 13:00:23 UTC

This is an autogenerated message for OBS integration:
This bug (816693) was mentioned in
https://build.opensuse.org/request/show/173170 Maintenance /

[reply] [-] Comment 4 Marcus Meissner 2013-04-24 13:54:24 UTC

This also contains a 3.0.0 -> 3.1.0 version update with 400.000 lines diff?

[reply] [-] Comment 5 Benjamin Brunner 2013-04-24 14:06:50 UTC

I added it for testing to openSUSE:Maintenance:1627 for the moment. 

I also edited the .changes-file, added the missing bugid to your entry and
submitted it back to KDE:Release:410 (sr#173179).

[reply] [-] Comment 6 Benjamin Brunner 2013-04-25 12:04:45 UTC

Thanks to Marcus for testing the update. I'll let it in the testchannel until
beginning next week and release it if nothing else comes up.

[reply] [-] Comment 7 Mariusz Fik 2013-04-25 12:41:15 UTC

I tested digikam-3.1.0-1.7.1 from update-test and it seems working again.
Thanks!


I tested  and it seems working again.
zypper ar http://download.opensuse.org/update/12.3-test update-test
zypper up -r update-test digikam

Good Work !
Comment 3 caulier.gilles 2017-07-23 12:53:22 UTC
Since digiKam 5.0.0, we use drop lcms version 1.x in favor of lcms version 2.x. This problem will not reproducible.