Bug 318991 - Digikam crash at startup
Summary: Digikam crash at startup
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: ColorManagement-Backend (show other bugs)
Version: 3.0.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-27 18:57 UTC by werner.ittner
Modified: 2022-02-01 11:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description werner.ittner 2013-04-27 18:57:26 UTC
Application: digikam (3.0.0)
KDE Platform Version: 4.10.2 "release 1"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.1-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
Started Digikam; tested multiple - 100% same results.

openSUSE 12.3 latest patchset (as of Apr 27). OpenSUSE's digikam - no sourcecode no other version

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f56679a0800 (LWP 3514))]

Thread 3 (Thread 0x7f5646b41700 (LWP 3515)):
#0  0x00007f565f28c964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f5662da662b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00000000005d4338 in Digikam::ScanController::run (this=0x1e41f90) at /usr/src/debug/digikam-3.0.0/core/digikam/database/scancontroller.cpp:698
#3  0x00007f5662da60cc in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f5655da83b4 in ?? () from /usr/X11R6/lib64/libGL.so.1
#5  0x00007f565f288e0f in start_thread () from /lib64/libpthread.so.0
#6  0x00007f56613107dd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f5646335700 (LWP 3516)):
#0  0x00007f566130787d in poll () from /lib64/libc.so.6
#1  0x00007f5658d55aa4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f5658d55bc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f5662ed01f6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f5662ea09ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f5662ea0c78 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f5662da30f0 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f5662e811af in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007f5662da60cc in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f5655da83b4 in ?? () from /usr/X11R6/lib64/libGL.so.1
#10 0x00007f565f288e0f in start_thread () from /lib64/libpthread.so.0
#11 0x00007f56613107dd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f56679a0800 (LWP 3514)):
[KCrash Handler]
#5  0x00007f56612b5f6a in strchrnul () from /lib64/libc.so.6
#6  0x00007f566126ec6d in vfprintf () from /lib64/libc.so.6
#7  0x00007f56613239f0 in __vsnprintf_chk () from /lib64/libc.so.6
#8  0x00007f565d334a58 in vsnprintf (__ap=0x7fffaf784c88, __fmt=0x7f565bf4fcb0 "Tag '%lx' not found", __n=1023, __s=0x7fffaf784ca0 "") at /usr/include/bits/stdio2.h:77
#9  cmsSignalError (ContextID=ContextID@entry=0x3000, ErrorCode=ErrorCode@entry=1542782128, ErrorText=ErrorText@entry=0x64657363 <Address 0x64657363 out of bounds>) at cmserr.c:409
#10 0x00007f565bf327ad in _cmsSearchTag (sig=icSigProfileDescriptionTag, Profile=<optimized out>, lSignalError=<optimized out>) at cmsio0.c:292
#11 _cmsSearchTag (Profile=Profile@entry=0x1fa1b80, sig=sig@entry=icSigProfileDescriptionTag, lSignalError=lSignalError@entry=1) at cmsio0.c:279
#12 0x00007f565bf380d0 in cmsReadICCTextEx (hProfile=hProfile@entry=0x1fa1b80, sig=sig@entry=icSigProfileDescriptionTag, Name=Name@entry=0x7f565c15b320 <Name.7711> "", size_max=size_max@entry=512) at cmsio1.c:1675
#13 0x00007f565bf3816a in cmsReadICCText (hProfile=hProfile@entry=0x1fa1b80, sig=sig@entry=icSigProfileDescriptionTag, Text=Text@entry=0x7f565c15b320 <Name.7711> "") at cmsio1.c:1706
#14 0x00007f565bf38f36 in cmsTakeProductDesc (hProfile=0x1fa1b80) at cmsio1.c:2218
#15 0x00007f56650af625 in Digikam::IccProfile::description (this=0x1f703a0) at /usr/src/debug/digikam-3.0.0/core/libs/dimg/filters/icc/iccprofile.cpp:387
#16 0x00007f56650bbfa3 in Digikam::IccSettings::loadAllProfilesProperties (this=0x1fb9c20) at /usr/src/debug/digikam-3.0.0/core/libs/dimg/filters/icc/iccsettings.cpp:585
#17 0x0000000000598d52 in Digikam::DigikamApp::DigikamApp (this=0x1f545e0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/digikam-3.0.0/core/digikam/main/digikamapp.cpp:228
#18 0x00000000004987c1 in main (argc=1, argv=0x7fffaf785cd8) at /usr/src/debug/digikam-3.0.0/core/digikam/main/main.cpp:188

Possible duplicates by query: bug 318989, bug 318987, bug 318861, bug 318848, bug 318842.

Reported using DrKonqi
Comment 1 caulier.gilles 2013-04-27 20:46:17 UTC

*** This bug has been marked as a duplicate of bug 318721 ***
Comment 2 caulier.gilles 2017-07-23 12:48:56 UTC
Since digiKam 5.0.0, we use drop lcms version 1.x in favor of lcms version 2.x. This problem will not reproducible.