Bug 296452 - Moun Programmverwaltung stürzt beim Start ab
Summary: Moun Programmverwaltung stürzt beim Start ab
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-20 19:13 UTC by Olaf
Modified: 2012-03-20 19:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf 2012-03-20 19:13:27 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Nichts, außer Moun Programmverwaltung starten
Moun Paketverwaltung funktioniert aber

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7715930 (LWP 1678))]

Thread 2 (Thread 0xb5520b70 (LWP 1682)):
#0  0x00443d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x009ec7d5 in do_gettime (frac=0xb5520020, sec=0xb5520018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00abf4b6 in QTimerInfoList::updateCurrentTime (this=0xb4c01abc) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00abf80a in QTimerInfoList::timerWait (this=0xb4c01abc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00abe053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb552012c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00abe0ed in timerSourcePrepare (source=0xb4c01a88, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x05e0188c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x05e02637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x05e02c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00abeb37 in QEventDispatcherGlib::processEvents (this=0xb4c00468, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00a8f1dd in QEventLoop::processEvents (this=0xb55202b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00a8f421 in QEventLoop::exec (this=0xb55202b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0099290b in QThread::exec (this=0x94be0b0) at thread/qthread.cpp:498
#14 0x00a6fe2d in QInotifyFileSystemWatcherEngine::run (this=0x94be0b0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x009957b3 in QThreadPrivate::start (arg=0x94be0b0) at thread/qthread_unix.cpp:331
#16 0x008f4d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0064946e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7715930 (LWP 1678)):
[KCrash Handler]
#7  0x009e9e11 in QtPrivate::QStringList_contains (that=0xbfe3a604, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe3a604) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x94247d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x94247d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe3a824) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00a96b7d in metacall (argv=0xbfe3a824, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x94247d0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x94247d0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe3a824) at kernel/qmetaobject.cpp:232
#13 0x00aa5a6a in QMetaObject::activate (sender=0x931cdc0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x931cdc0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x931cdc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe3a968) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00a96b7d in metacall (argv=0xbfe3a968, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x931cdc0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x931cdc0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe3a968) at kernel/qmetaobject.cpp:232
#18 0x00aa5a6a in QMetaObject::activate (sender=0x94247d0, m=0x80950c0, local_signal_index=0, argv=0xbfe3a968) at kernel/qobject.cpp:3278
#19 0x0075e7c5 in MuonMainWindow::backendReady (this=0x94247d0, _t1=0x9414388) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0075e933 in MuonMainWindow::initObject (this=0x94247d0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x94247d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x94247d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe3aa94) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00a96b7d in metacall (argv=0xbfe3aa94, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x94247d0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x94247d0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe3aa94) at kernel/qmetaobject.cpp:232
#25 0x00aa5a6a in QMetaObject::activate (sender=0x9491bb0, m=0xbc6238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00aad375 in QSingleShotTimer::timeout (this=0x9491bb0) at .moc/release-shared/qtimer.moc:82
#27 0x00aad42c in QSingleShotTimer::timerEvent (this=0x9491bb0) at kernel/qtimer.cpp:308
#28 0x00aa8994 in QObject::event (this=0x9491bb0, e=0xbfe3ae8c) at kernel/qobject.cpp:1181
#29 0x029f2d84 in notify_helper (e=0xbfe3ae8c, receiver=0x9491bb0, this=0x93261f8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x93261f8, receiver=0x9491bb0, e=0xbfe3ae8c) at kernel/qapplication.cpp:4458
#31 0x029f8133 in QApplication::notify (this=0xbfe3ae8c, receiver=0x9491bb0, e=0xbfe3ae8c) at kernel/qapplication.cpp:3886
#32 0x01186971 in KApplication::notify (this=0xbfe3b1a0, receiver=0x9491bb0, event=0xbfe3ae8c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00a9019e in QCoreApplication::notifyInternal (this=0xbfe3b1a0, receiver=0x9491bb0, event=0xbfe3ae8c) at kernel/qcoreapplication.cpp:787
#34 0x00ac0c10 in sendEvent (event=0xbfe3ae8c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9327e34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00abe122 in timerSourceDispatch (source=0x9327e00) at kernel/qeventdispatcher_glib.cpp:184
#37 0x05e0225f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x05e02990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x05e02c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00abeada in QEventDispatcherGlib::processEvents (this=0x9309238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x02aaae7a in QGuiEventDispatcherGlib::processEvents (this=0x9309238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00a8f1dd in QEventLoop::processEvents (this=0xbfe3b104, flags=...) at kernel/qeventloop.cpp:149
#43 0x00a8f421 in QEventLoop::exec (this=0xbfe3b104, flags=...) at kernel/qeventloop.cpp:201
#44 0x00a9419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x029f0924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 296121.

Possible duplicates by query: bug 296441, bug 296357, bug 296351, bug 296323, bug 296298.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-20 19:32:43 UTC

*** This bug has been marked as a duplicate of bug 291262 ***