Bug 296441 - Muon Package Manager crash
Summary: Muon Package Manager crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-20 16:48 UTC by dmcd2356
Modified: 2012-03-20 17:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dmcd2356 2012-03-20 16:48:55 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I simply attempted to open Muon to search for updates & it immediately crashed.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4768930 (LWP 2969))]

Thread 2 (Thread 0xb23e3b70 (LWP 2970)):
#0  0xb52e4d8f in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb5d3f2b4 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb51fc723 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb51fcc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb7266b37 in QEventDispatcherGlib::processEvents (this=0x858fc60, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0xb72371dd in QEventLoop::processEvents (this=0xb23e32b0, flags=...) at kernel/qeventloop.cpp:149
#6  0xb7237421 in QEventLoop::exec (this=0xb23e32b0, flags=...) at kernel/qeventloop.cpp:201
#7  0xb713a90b in QThread::exec (this=0x8537840) at thread/qthread.cpp:498
#8  0xb7217e2d in QInotifyFileSystemWatcherEngine::run (this=0x8537840) at io/qfilesystemwatcher_inotify.cpp:248
#9  0xb713d7b3 in QThreadPrivate::start (arg=0x8537840) at thread/qthread_unix.cpp:331
#10 0xb52e2d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0xb5d3146e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb4768930 (LWP 2969)):
[KCrash Handler]
#7  0xb7191e11 in QtPrivate::QStringList_contains (that=0xbfd72824, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd72824) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x850c448) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x850c448, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd72a44) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb723eb7d in metacall (argv=0xbfd72a44, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x850c448) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x850c448, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfd72a44) at kernel/qmetaobject.cpp:232
#13 0xb724da6a in QMetaObject::activate (sender=0x8523e38, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8523e38) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8523e38, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd72b88) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb723eb7d in metacall (argv=0xbfd72b88, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8523e38) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8523e38, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfd72b88) at kernel/qmetaobject.cpp:232
#18 0xb724da6a in QMetaObject::activate (sender=0x850c448, m=0x80950c0, local_signal_index=0, argv=0xbfd72b88) at kernel/qobject.cpp:3278
#19 0xb76ae7c5 in MuonMainWindow::backendReady (this=0x850c448, _t1=0x8501698) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb76ae933 in MuonMainWindow::initObject (this=0x850c448) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x850c448) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x850c448, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd72cb4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb723eb7d in metacall (argv=0xbfd72cb4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x850c448) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x850c448, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfd72cb4) at kernel/qmetaobject.cpp:232
#25 0xb724da6a in QMetaObject::activate (sender=0x85902e0, m=0xb736e238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb7255375 in QSingleShotTimer::timeout (this=0x85902e0) at .moc/release-shared/qtimer.moc:82
#27 0xb725542c in QSingleShotTimer::timerEvent (this=0x85902e0) at kernel/qtimer.cpp:308
#28 0xb7250994 in QObject::event (this=0x85902e0, e=0xbfd730ac) at kernel/qobject.cpp:1181
#29 0xb601ed84 in notify_helper (e=0xbfd730ac, receiver=0x85902e0, this=0x843d130) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x843d130, receiver=0x85902e0, e=0xbfd730ac) at kernel/qapplication.cpp:4458
#31 0xb6024133 in QApplication::notify (this=0xbfd730ac, receiver=0x85902e0, e=0xbfd730ac) at kernel/qapplication.cpp:3886
#32 0xb6e3d971 in KApplication::notify (this=0xbfd733c0, receiver=0x85902e0, event=0xbfd730ac) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb723819e in QCoreApplication::notifyInternal (this=0xbfd733c0, receiver=0x85902e0, event=0xbfd730ac) at kernel/qcoreapplication.cpp:787
#34 0xb7268c10 in sendEvent (event=0xbfd730ac, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x84400b4) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb7266122 in timerSourceDispatch (source=0x8440080) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb51fc25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb51fc990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb51fcc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb7266ada in QEventDispatcherGlib::processEvents (this=0x8420238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb60d6e7a in QGuiEventDispatcherGlib::processEvents (this=0x8420238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb72371dd in QEventLoop::processEvents (this=0xbfd73324, flags=...) at kernel/qeventloop.cpp:149
#43 0xb7237421 in QEventLoop::exec (this=0xbfd73324, flags=...) at kernel/qeventloop.cpp:201
#44 0xb723c19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb601c924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 296357, bug 296351, bug 296323, bug 296298, bug 296283.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-20 17:03:59 UTC

*** This bug has been marked as a duplicate of bug 291262 ***