Bug 296323 - Muon Crash
Summary: Muon Crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-19 06:34 UTC by Cesar
Modified: 2012-03-19 07:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cesar 2012-03-19 06:34:38 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Gestor de Software Muon Crashes after start Error Segmentation 11

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7780930 (LWP 2236))]

Thread 2 (Thread 0xb5497b70 (LWP 2240)):
#0  0x00e07416 in __kernel_vsyscall ()
#1  0x00c897ae in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x050d634b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x050c7896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x050c7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00942b37 in QEventDispatcherGlib::processEvents (this=0x81dafc8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x009131dd in QEventLoop::processEvents (this=0xb54972b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00913421 in QEventLoop::exec (this=0xb54972b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0081690b in QThread::exec (this=0x822ddf0) at thread/qthread.cpp:498
#9  0x008f3e2d in QInotifyFileSystemWatcherEngine::run (this=0x822ddf0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x008197b3 in QThreadPrivate::start (arg=0x822ddf0) at thread/qthread_unix.cpp:331
#11 0x00b2cd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00c9846e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7780930 (LWP 2236)):
[KCrash Handler]
#7  0x0086de11 in QtPrivate::QStringList_contains (that=0xbfe22084, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe22084) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x81dc188) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x81dc188, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe222a4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0091ab7d in metacall (argv=0xbfe222a4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x81dc188) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x81dc188, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe222a4) at kernel/qmetaobject.cpp:232
#13 0x00929a6a in QMetaObject::activate (sender=0x80bedc0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x80bedc0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x80bedc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe223e8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0091ab7d in metacall (argv=0xbfe223e8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x80bedc0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x80bedc0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe223e8) at kernel/qmetaobject.cpp:232
#18 0x00929a6a in QMetaObject::activate (sender=0x81dc188, m=0x80950c0, local_signal_index=0, argv=0xbfe223e8) at kernel/qobject.cpp:3278
#19 0x00b917c5 in MuonMainWindow::backendReady (this=0x81dc188, _t1=0x81deb20) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00b91933 in MuonMainWindow::initObject (this=0x81dc188) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x81dc188) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x81dc188, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe22514) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0091ab7d in metacall (argv=0xbfe22514, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x81dc188) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x81dc188, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe22514) at kernel/qmetaobject.cpp:232
#25 0x00929a6a in QMetaObject::activate (sender=0x8212788, m=0xa4a238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00931375 in QSingleShotTimer::timeout (this=0x8212788) at .moc/release-shared/qtimer.moc:82
#27 0x0093142c in QSingleShotTimer::timerEvent (this=0x8212788) at kernel/qtimer.cpp:308
#28 0x0092c994 in QObject::event (this=0x8212788, e=0xbfe2290c) at kernel/qobject.cpp:1181
#29 0x0222cd84 in notify_helper (e=0xbfe2290c, receiver=0x8212788, this=0x80c77d8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x80c77d8, receiver=0x8212788, e=0xbfe2290c) at kernel/qapplication.cpp:4458
#31 0x02232133 in QApplication::notify (this=0xbfe2290c, receiver=0x8212788, e=0xbfe2290c) at kernel/qapplication.cpp:3886
#32 0x00fef971 in KApplication::notify (this=0xbfe22c20, receiver=0x8212788, event=0xbfe2290c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0091419e in QCoreApplication::notifyInternal (this=0xbfe22c20, receiver=0x8212788, event=0xbfe2290c) at kernel/qcoreapplication.cpp:787
#34 0x00944c10 in sendEvent (event=0xbfe2290c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x80c9674) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00942122 in timerSourceDispatch (source=0x80c9640) at kernel/qeventdispatcher_glib.cpp:184
#37 0x050c725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x050c7990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x050c7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00942ada in QEventDispatcherGlib::processEvents (this=0x80ab238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x022e4e7a in QGuiEventDispatcherGlib::processEvents (this=0x80ab238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x009131dd in QEventLoop::processEvents (this=0xbfe22b84, flags=...) at kernel/qeventloop.cpp:149
#43 0x00913421 in QEventLoop::exec (this=0xbfe22b84, flags=...) at kernel/qeventloop.cpp:201
#44 0x0091819d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0222a924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296298, bug 296283, bug 296230, bug 296195, bug 296189.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-19 07:20:56 UTC

*** This bug has been marked as a duplicate of bug 291262 ***