Bug 296121 - Ejecutable: muon-installer PID: 4647 Señal: Segmentation fault (11
Summary: Ejecutable: muon-installer PID: 4647 Señal: Segmentation fault (11
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-16 05:59 UTC by elgurca
Modified: 2012-03-16 13:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description elgurca 2012-03-16 05:59:20 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:Ejecutable: muon-installer PID: 4647 Señal: Segmentation fault (11

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77d2930 (LWP 4647))]

Thread 2 (Thread 0xb5804b70 (LWP 4651)):
#0  0x00416416 in __kernel_vsyscall ()
#1  0x00cfb7ae in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0161934b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0160a896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0160ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00964ada in QEventDispatcherGlib::processEvents (this=0x8618320, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#6  0x009351dd in QEventLoop::processEvents (this=0xb58042b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00935421 in QEventLoop::exec (this=0xb58042b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0083890b in QThread::exec (this=0x85c4190) at thread/qthread.cpp:498
#9  0x00915e2d in QInotifyFileSystemWatcherEngine::run (this=0x85c4190) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0083b7b3 in QThreadPrivate::start (arg=0x85c4190) at thread/qthread_unix.cpp:331
#11 0x006fad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00d0a46e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77d2930 (LWP 4647)):
[KCrash Handler]
#7  0x0088fe11 in QtPrivate::QStringList_contains (that=0xbf8e5df4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf8e5df4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8587f48) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8587f48, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8e6014) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0093cb7d in metacall (argv=0xbf8e6014, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8587f48) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8587f48, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf8e6014) at kernel/qmetaobject.cpp:232
#13 0x0094ba6a in QMetaObject::activate (sender=0x85cab20, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x85cab20) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x85cab20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8e6158) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0093cb7d in metacall (argv=0xbf8e6158, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x85cab20) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x85cab20, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf8e6158) at kernel/qmetaobject.cpp:232
#18 0x0094ba6a in QMetaObject::activate (sender=0x8587f48, m=0x80950c0, local_signal_index=0, argv=0xbf8e6158) at kernel/qobject.cpp:3278
#19 0x0072a7c5 in MuonMainWindow::backendReady (this=0x8587f48, _t1=0x85ddd00) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0072a933 in MuonMainWindow::initObject (this=0x8587f48) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8587f48) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8587f48, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8e6284) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0093cb7d in metacall (argv=0xbf8e6284, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8587f48) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8587f48, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf8e6284) at kernel/qmetaobject.cpp:232
#25 0x0094ba6a in QMetaObject::activate (sender=0x85e8180, m=0xa6c238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00953375 in QSingleShotTimer::timeout (this=0x85e8180) at .moc/release-shared/qtimer.moc:82
#27 0x0095342c in QSingleShotTimer::timerEvent (this=0x85e8180) at kernel/qtimer.cpp:308
#28 0x0094e994 in QObject::event (this=0x85e8180, e=0xbf8e667c) at kernel/qobject.cpp:1181
#29 0x04886d84 in notify_helper (e=0xbf8e667c, receiver=0x85e8180, this=0x8484628) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8484628, receiver=0x85e8180, e=0xbf8e667c) at kernel/qapplication.cpp:4458
#31 0x0488c133 in QApplication::notify (this=0xbf8e667c, receiver=0x85e8180, e=0xbf8e667c) at kernel/qapplication.cpp:3886
#32 0x01182971 in KApplication::notify (this=0xbf8e6990, receiver=0x85e8180, event=0xbf8e667c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0093619e in QCoreApplication::notifyInternal (this=0xbf8e6990, receiver=0x85e8180, event=0xbf8e667c) at kernel/qcoreapplication.cpp:787
#34 0x00966c10 in sendEvent (event=0xbf8e667c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8485f34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00964122 in timerSourceDispatch (source=0x8485f00) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0160a25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x0160a990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x0160ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00964ada in QEventDispatcherGlib::processEvents (this=0x8467238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0493ee7a in QGuiEventDispatcherGlib::processEvents (this=0x8467238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x009351dd in QEventLoop::processEvents (this=0xbf8e68f4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00935421 in QEventLoop::exec (this=0xbf8e68f4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0093a19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x04884924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296099, bug 296044, bug 296017, bug 296004, bug 295960.

Reported using DrKonqi
Comment 1 Jonathan Thomas 2012-03-16 13:45:56 UTC

*** This bug has been marked as a duplicate of bug 291262 ***