Bug 296298 - it crashed sudenly
Summary: it crashed sudenly
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-18 18:53 UTC by Antonio
Modified: 2012-03-18 23:51 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.15 KB, text/plain)
2012-03-18 22:34 UTC, chaosstare
Details
New crash information added by DrKonqi (6.62 KB, text/plain)
2012-03-18 23:13 UTC, daniel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio 2012-03-18 18:53:04 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

updating installed programs and looking for some new programs to install

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de Aplicações do Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7708930 (LWP 2906))]

Thread 2 (Thread 0xb5815b70 (LWP 2907)):
#0  0x00b1cd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00cea7d5 in do_gettime (frac=0xb5815020, sec=0xb5815018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00dbd4b6 in QTimerInfoList::updateCurrentTime (this=0xb4f0197c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00dbd80a in QTimerInfoList::timerWait (this=0xb4f0197c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00dbc053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb581512c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00dbc0ed in timerSourcePrepare (source=0xb4f01948, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0299288c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x02993637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x02993c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00dbcb37 in QEventDispatcherGlib::processEvents (this=0x9033e58, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00d8d1dd in QEventLoop::processEvents (this=0xb58152b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00d8d421 in QEventLoop::exec (this=0xb58152b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00c9090b in QThread::exec (this=0x9125688) at thread/qthread.cpp:498
#14 0x00d6de2d in QInotifyFileSystemWatcherEngine::run (this=0x9125688) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00c937b3 in QThreadPrivate::start (arg=0x9125688) at thread/qthread_unix.cpp:331
#16 0x07977d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0361f46e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7708930 (LWP 2906)):
[KCrash Handler]
#7  0x00ce7e11 in QtPrivate::QStringList_contains (that=0xbf9e55a4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf9e55a4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x90df930) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x90df930, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9e57c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00d94b7d in metacall (argv=0xbf9e57c4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x90df930) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x90df930, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf9e57c4) at kernel/qmetaobject.cpp:232
#13 0x00da3a6a in QMetaObject::activate (sender=0x9226f00, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9226f00) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9226f00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9e5908) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00d94b7d in metacall (argv=0xbf9e5908, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9226f00) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9226f00, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf9e5908) at kernel/qmetaobject.cpp:232
#18 0x00da3a6a in QMetaObject::activate (sender=0x90df930, m=0x80950c0, local_signal_index=0, argv=0xbf9e5908) at kernel/qobject.cpp:3278
#19 0x003db7c5 in MuonMainWindow::backendReady (this=0x90df930, _t1=0x9041a50) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x003db933 in MuonMainWindow::initObject (this=0x90df930) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x90df930) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x90df930, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9e5a34) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00d94b7d in metacall (argv=0xbf9e5a34, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x90df930) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x90df930, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf9e5a34) at kernel/qmetaobject.cpp:232
#25 0x00da3a6a in QMetaObject::activate (sender=0x913bdd8, m=0xec4238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00dab375 in QSingleShotTimer::timeout (this=0x913bdd8) at .moc/release-shared/qtimer.moc:82
#27 0x00dab42c in QSingleShotTimer::timerEvent (this=0x913bdd8) at kernel/qtimer.cpp:308
#28 0x00da6994 in QObject::event (this=0x913bdd8, e=0xbf9e5e2c) at kernel/qobject.cpp:1181
#29 0x05862d84 in notify_helper (e=0xbf9e5e2c, receiver=0x913bdd8, this=0x8fba948) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8fba948, receiver=0x913bdd8, e=0xbf9e5e2c) at kernel/qapplication.cpp:4458
#31 0x05868133 in QApplication::notify (this=0xbf9e5e2c, receiver=0x913bdd8, e=0xbf9e5e2c) at kernel/qapplication.cpp:3886
#32 0x0089c971 in KApplication::notify (this=0xbf9e6140, receiver=0x913bdd8, event=0xbf9e5e2c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00d8e19e in QCoreApplication::notifyInternal (this=0xbf9e6140, receiver=0x913bdd8, event=0xbf9e5e2c) at kernel/qcoreapplication.cpp:787
#34 0x00dbec10 in sendEvent (event=0xbf9e5e2c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8fb6c34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00dbc122 in timerSourceDispatch (source=0x8fb6c00) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0299325f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x02993990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x02993c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00dbcada in QEventDispatcherGlib::processEvents (this=0x8f98238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0591ae7a in QGuiEventDispatcherGlib::processEvents (this=0x8f98238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00d8d1dd in QEventLoop::processEvents (this=0xbf9e60a4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00d8d421 in QEventLoop::exec (this=0xbf9e60a4, flags=...) at kernel/qeventloop.cpp:201
#44 0x00d9219d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x05860924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 296283, bug 296230, bug 296195, bug 296189, bug 296172.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-03-18 20:29:41 UTC
Thank your for the bug report. The KDE team wants to improve the crash reporting tools for the end users. To help improving, please answer the following questions:

1. Did the Bug Reporting tool suggest this crash has already been reported?
[ ] no, I did not see any mention of the crash already been reported
[ ] unsure, I did not trust or understand the suggested duplicate reports
[ ] yes, the tool suggested this crash has already been reported

2. If "yes" in answer 1, how many duplicates did it display?
[ ] more than 10 duplicates
[ ] at least two duplicates
[ ] only a single duplicate

3. If "yes" or "unsure" in answer 1, what could be improved to help building trust in the suggested duplicate reports? (Please add any comment)

Thanks for taking part in this survey,
KDE Quality Team
Comment 2 chaosstare 2012-03-18 22:34:26 UTC
Created attachment 69722 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

Just crash after starting, does it all the time

-- Backtrace (Reduced):
#6  0x00007fe751191a5e in QtPrivate::QStringList_contains (that=0x7fff034d2170, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff034d2170) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x255e940) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x255e940, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff034d2740) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x25dccb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff034d28a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 3 daniel 2012-03-18 23:13:28 UTC
Created attachment 69723 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

opened it and crash crashes everytime i try to open

-- Backtrace (Reduced):
#7  0x00fc3e11 in QtPrivate::QStringList_contains (that=0xbfe5c854, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe5c854) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9a0d4b0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9a0d4b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe5ca74) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x01070b7d in metacall (argv=0xbfe5ca74, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9a0d4b0) at kernel/qmetaobject.cpp:237
Comment 4 Lamarque V. Souza 2012-03-18 23:51:07 UTC

*** This bug has been marked as a duplicate of bug 291262 ***