Bug 296351 - Muon non funziona e mi da messaggio di errore
Summary: Muon non funziona e mi da messaggio di errore
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-19 12:36 UTC by wamoo_
Modified: 2012-03-19 12:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wamoo_ 2012-03-19 12:36:40 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: se cerco di aprire Muon per aggiornare il sistema non funziona e mi da un messaggio di errore dell'applicazione. Non so come risolvere.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb771a930 (LWP 1805))]

Thread 2 (Thread 0xb5804b70 (LWP 1809)):
#0  0x00850d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x002147d5 in do_gettime (frac=0xb5804020, sec=0xb5804018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x002e74b6 in QTimerInfoList::updateCurrentTime (this=0x8fc87a4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x002e780a in QTimerInfoList::timerWait (this=0x8fc87a4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x002e6053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb580412c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x002e60ed in timerSourcePrepare (source=0x8fc8770, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x05feb88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x05fec637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x05fecc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x002e6b37 in QEventDispatcherGlib::processEvents (this=0x8edd270, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x002b71dd in QEventLoop::processEvents (this=0xb58042b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x002b7421 in QEventLoop::exec (this=0xb58042b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x001ba90b in QThread::exec (this=0x8fc7a20) at thread/qthread.cpp:498
#14 0x00297e2d in QInotifyFileSystemWatcherEngine::run (this=0x8fc7a20) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x001bd7b3 in QThreadPrivate::start (arg=0x8fc7a20) at thread/qthread_unix.cpp:331
#16 0x00832d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0092d46e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb771a930 (LWP 1805)):
[KCrash Handler]
#7  0x00211e11 in QtPrivate::QStringList_contains (that=0xbf99c394, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf99c394) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8e78558) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8e78558, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf99c5b4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x002beb7d in metacall (argv=0xbf99c5b4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8e78558) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8e78558, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf99c5b4) at kernel/qmetaobject.cpp:232
#13 0x002cda6a in QMetaObject::activate (sender=0x8e276d8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8e276d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8e276d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf99c6f8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x002beb7d in metacall (argv=0xbf99c6f8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8e276d8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8e276d8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf99c6f8) at kernel/qmetaobject.cpp:232
#18 0x002cda6a in QMetaObject::activate (sender=0x8e78558, m=0x80950c0, local_signal_index=0, argv=0xbf99c6f8) at kernel/qobject.cpp:3278
#19 0x00a677c5 in MuonMainWindow::backendReady (this=0x8e78558, _t1=0x8e657b8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00a67933 in MuonMainWindow::initObject (this=0x8e78558) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8e78558) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8e78558, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf99c824) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x002beb7d in metacall (argv=0xbf99c824, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8e78558) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8e78558, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf99c824) at kernel/qmetaobject.cpp:232
#25 0x002cda6a in QMetaObject::activate (sender=0x8ee1780, m=0x3ee238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x002d5375 in QSingleShotTimer::timeout (this=0x8ee1780) at .moc/release-shared/qtimer.moc:82
#27 0x002d542c in QSingleShotTimer::timerEvent (this=0x8ee1780) at kernel/qtimer.cpp:308
#28 0x002d0994 in QObject::event (this=0x8ee1780, e=0xbf99cc1c) at kernel/qobject.cpp:1181
#29 0x013b2d84 in notify_helper (e=0xbf99cc1c, receiver=0x8ee1780, this=0x8d78218) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8d78218, receiver=0x8ee1780, e=0xbf99cc1c) at kernel/qapplication.cpp:4458
#31 0x013b8133 in QApplication::notify (this=0xbf99cc1c, receiver=0x8ee1780, e=0xbf99cc1c) at kernel/qapplication.cpp:3886
#32 0x01008971 in KApplication::notify (this=0xbf99cf30, receiver=0x8ee1780, event=0xbf99cc1c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x002b819e in QCoreApplication::notifyInternal (this=0xbf99cf30, receiver=0x8ee1780, event=0xbf99cc1c) at kernel/qcoreapplication.cpp:787
#34 0x002e8c10 in sendEvent (event=0xbf99cc1c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8d7ec34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x002e6155 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#37 idleTimerSourceDispatch (source=0x8d7ec68) at kernel/qeventdispatcher_glib.cpp:231
#38 0x05fec25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x05fec990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x05fecc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0x002e6ada in QEventDispatcherGlib::processEvents (this=0x8d5a238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#42 0x0146ae7a in QGuiEventDispatcherGlib::processEvents (this=0x8d5a238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x002b71dd in QEventLoop::processEvents (this=0xbf99ce94, flags=...) at kernel/qeventloop.cpp:149
#44 0x002b7421 in QEventLoop::exec (this=0xbf99ce94, flags=...) at kernel/qeventloop.cpp:201
#45 0x002bc19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#46 0x013b0924 in QApplication::exec () at kernel/qapplication.cpp:3760
#47 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296323, bug 296298, bug 296283, bug 296230, bug 296195.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-19 12:43:49 UTC

*** This bug has been marked as a duplicate of bug 291262 ***