Bug 296357 - muon dont works
Summary: muon dont works
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-19 13:23 UTC by jonny amrques
Modified: 2012-03-29 20:49 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.75 KB, text/plain)
2012-03-22 23:20 UTC, jangothehutt
Details
New crash information added by DrKonqi (6.62 KB, text/plain)
2012-03-22 23:22 UTC, jangothehutt
Details
New crash information added by DrKonqi (7.26 KB, text/plain)
2012-03-23 17:28 UTC, jangothehutt
Details
New crash information added by DrKonqi (6.69 KB, text/plain)
2012-03-26 16:02 UTC, Timka890
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jonny amrques 2012-03-19 13:23:48 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
app manager muon never works

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77c3930 (LWP 4418))]

Thread 2 (Thread 0xb58a6b70 (LWP 4419)):
#0  0x00423416 in __kernel_vsyscall ()
#1  0x003117ae in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0252134b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x02512896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x02512c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00b0eb37 in QEventDispatcherGlib::processEvents (this=0x9cc6118, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00adf1dd in QEventLoop::processEvents (this=0xb58a62b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00adf421 in QEventLoop::exec (this=0xb58a62b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x009e290b in QThread::exec (this=0x9ce3a90) at thread/qthread.cpp:498
#9  0x00abfe2d in QInotifyFileSystemWatcherEngine::run (this=0x9ce3a90) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x009e57b3 in QThreadPrivate::start (arg=0x9ce3a90) at thread/qthread_unix.cpp:331
#11 0x00669d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x0032046e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77c3930 (LWP 4418)):
[KCrash Handler]
#7  0x00a39e11 in QtPrivate::QStringList_contains (that=0xbffb4154, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbffb4154) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9cbffa0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9cbffa0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffb4374) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00ae6b7d in metacall (argv=0xbffb4374, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9cbffa0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9cbffa0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbffb4374) at kernel/qmetaobject.cpp:232
#13 0x00af5a6a in QMetaObject::activate (sender=0x9d16468, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9d16468) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9d16468, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffb44b8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00ae6b7d in metacall (argv=0xbffb44b8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9d16468) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9d16468, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbffb44b8) at kernel/qmetaobject.cpp:232
#18 0x00af5a6a in QMetaObject::activate (sender=0x9cbffa0, m=0x80950c0, local_signal_index=0, argv=0xbffb44b8) at kernel/qobject.cpp:3278
#19 0x002197c5 in MuonMainWindow::backendReady (this=0x9cbffa0, _t1=0x9d18598) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00219933 in MuonMainWindow::initObject (this=0x9cbffa0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9cbffa0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9cbffa0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffb45e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00ae6b7d in metacall (argv=0xbffb45e4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9cbffa0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9cbffa0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbffb45e4) at kernel/qmetaobject.cpp:232
#25 0x00af5a6a in QMetaObject::activate (sender=0x9d23a48, m=0xc16238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00afd375 in QSingleShotTimer::timeout (this=0x9d23a48) at .moc/release-shared/qtimer.moc:82
#27 0x00afd42c in QSingleShotTimer::timerEvent (this=0x9d23a48) at kernel/qtimer.cpp:308
#28 0x00af8994 in QObject::event (this=0x9d23a48, e=0xbffb49dc) at kernel/qobject.cpp:1181
#29 0x05967d84 in notify_helper (e=0xbffb49dc, receiver=0x9d23a48, this=0x9be8d60) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9be8d60, receiver=0x9d23a48, e=0xbffb49dc) at kernel/qapplication.cpp:4458
#31 0x0596d133 in QApplication::notify (this=0xbffb49dc, receiver=0x9d23a48, e=0xbffb49dc) at kernel/qapplication.cpp:3886
#32 0x0116f971 in KApplication::notify (this=0xbffb4cf0, receiver=0x9d23a48, event=0xbffb49dc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00ae019e in QCoreApplication::notifyInternal (this=0xbffb4cf0, receiver=0x9d23a48, event=0xbffb49dc) at kernel/qcoreapplication.cpp:787
#34 0x00b10c10 in sendEvent (event=0xbffb49dc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9be38ac) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00b0e122 in timerSourceDispatch (source=0x9be3878) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0251225f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x02512990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x02512c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00b0eada in QEventDispatcherGlib::processEvents (this=0x9bc4238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x05a1fe7a in QGuiEventDispatcherGlib::processEvents (this=0x9bc4238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00adf1dd in QEventLoop::processEvents (this=0xbffb4c54, flags=...) at kernel/qeventloop.cpp:149
#43 0x00adf421 in QEventLoop::exec (this=0xbffb4c54, flags=...) at kernel/qeventloop.cpp:201
#44 0x00ae419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x05965924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296351, bug 296323, bug 296298, bug 296283, bug 296230.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-03-19 14:54:25 UTC
Thank your for the bug report. The KDE team wants to improve the crash reporting tools for the end users. To help improving, please answer the following questions:

1. Did the Bug Reporting tool suggest this crash has already been reported?
[ ] no, I did not see any mention of the crash already been reported
[ ] unsure, I did not trust or understand the suggested duplicate reports
[ ] yes, the tool suggested this crash has already been reported

2. If "yes" in answer 1, how many duplicates did it display?
[ ] more than 10 duplicates
[ ] at least two duplicates
[ ] only a single duplicate

3. If "yes" or "unsure" in answer 1, what could be improved to help building trust in the suggested duplicate reports? (Please add any comment)

Thanks for taking part in this survey,
KDE Quality Team
Comment 2 jangothehutt 2012-03-22 23:20:36 UTC
Created attachment 69822 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

This error appears even when my laptop has just booted up. It appears just when i click on "Muon Software Center"

-- Backtrace (Reduced):
#7  0xb71cfe11 in QtPrivate::QStringList_contains (that=0xbf8a8464, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf8a8464) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0xa083b68) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0xa083b68, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8a8684) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb727cb7d in metacall (argv=0xbf8a8684, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0xa083b68) at kernel/qmetaobject.cpp:237
Comment 3 jangothehutt 2012-03-22 23:22:47 UTC
Created attachment 69823 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

The Muon Center doesn't reboot neither after bug reporting

-- Backtrace (Reduced):
#7  0xb7278e11 in QtPrivate::QStringList_contains (that=0xbfd23374, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd23374) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x98ff1a8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x98ff1a8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd23594) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7325b7d in metacall (argv=0xbfd23594, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x98ff1a8) at kernel/qmetaobject.cpp:237
Comment 4 jangothehutt 2012-03-23 17:28:10 UTC
Created attachment 69835 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

The crash appears anytime i start muon software center. Whether I open it at the beginning and the end

-- Backtrace (Reduced):
#7  0xb7256e11 in QtPrivate::QStringList_contains (that=0xbf84bf74, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf84bf74) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x899a400) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x899a400, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf84c194) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7303b7d in metacall (argv=0xbf84c194, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x899a400) at kernel/qmetaobject.cpp:237
Comment 5 Timka890 2012-03-26 16:02:26 UTC
Created attachment 69914 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

after trying to update recomended to update packages. Also tryid dpkg--configure -a. After another update - same things

-- Backtrace (Reduced):
#7  0x00c9ce11 in QtPrivate::QStringList_contains (that=0xbf9a20a4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf9a20a4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8274428) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8274428, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9a22c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00d49b7d in metacall (argv=0xbf9a22c4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8274428) at kernel/qmetaobject.cpp:237
Comment 6 Jekyll Wu 2012-03-29 20:49:04 UTC

*** This bug has been marked as a duplicate of bug 291262 ***