Bug 294383 - Dolphin Crash
Summary: Dolphin Crash
Status: RESOLVED DUPLICATE of bug 288750
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 2.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 21:08 UTC by lijoyx
Modified: 2012-02-20 14:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lijoyx 2012-02-18 21:08:21 UTC
Application: dolphin (2.0)
KDE Platform Version: 4.8.00 (4.8.0
Qt Version: 4.7.4
Operating System: Linux 3.2.6-030206-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
I am using wine. And when I try to drag a file to any of the programs working under wine the Dolphin get crashed.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f11dad97780 (LWP 2567))]

Thread 3 (Thread 0x7f11c8561700 (LWP 2568)):
#0  0x00007f11da66f773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f11d2d59f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f11d2d5a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f11d6a72f3e in QEventDispatcherGlib::processEvents (this=0x7f11c00008b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f11d6a46cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f11d6a46ef7 in QEventLoop::exec (this=0x7f11c8560dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f11d695e27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f11d6a29cbf in QInotifyFileSystemWatcherEngine::run (this=0xc5eb20) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f11d6960d05 in QThreadPrivate::start (arg=0xc5eb20) at thread/qthread_unix.cpp:331
#9  0x00007f11d322befc in start_thread (arg=0x7f11c8561700) at pthread_create.c:304
#10 0x00007f11da67b89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f11c61ab700 (LWP 2569)):
#0  0x00007f11d2d59393 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f11d2d59e6a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f11d2d5a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f11d6a72f3e in QEventDispatcherGlib::processEvents (this=0xd42040, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f11d6a46cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f11d6a46ef7 in QEventLoop::exec (this=0x7f11c61aadd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f11d695e27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f11d6a29cbf in QInotifyFileSystemWatcherEngine::run (this=0xd3b6e0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f11d6960d05 in QThreadPrivate::start (arg=0xd3b6e0) at thread/qthread_unix.cpp:331
#9  0x00007f11d322befc in start_thread (arg=0x7f11c61ab700) at pthread_create.c:304
#10 0x00007f11da67b89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f11dad97780 (LWP 2567)):
[KCrash Handler]
#6  QDragManager::move (this=0x11cbdc0, globalPos=...) at kernel/qdnd_x11.cpp:1608
#7  0x00007f11d74d7f99 in QDragManager::eventFilter (this=0x11cbdc0, o=<optimized out>, e=<optimized out>) at kernel/qdnd_x11.cpp:1306
#8  0x00007f11d6a47bcc in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0xafd100, receiver=0x1297e80, event=0x7fffc9dd3220) at kernel/qcoreapplication.cpp:883
#9  0x00007f11d74493e6 in QApplicationPrivate::notify_helper (this=0xafd100, receiver=0x1297e80, e=0x7fffc9dd3220) at kernel/qapplication.cpp:4461
#10 0x00007f11d744ecbb in QApplication::notify (this=<optimized out>, receiver=0x1297e80, e=0x7fffc9dd3220) at kernel/qapplication.cpp:4047
#11 0x00007f11d815eae6 in KApplication::notify (this=0x7fffc9dd6510, receiver=0x1297e80, event=0x7fffc9dd3220) at ../../kdeui/kernel/kapplication.cpp:311
#12 0x00007f11d6a47afc in QCoreApplication::notifyInternal (this=0x7fffc9dd6510, receiver=0x1297e80, event=0x7fffc9dd3220) at kernel/qcoreapplication.cpp:787
#13 0x00007f11d744a442 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#14 QApplicationPrivate::sendMouseEvent (receiver=0x1297e80, event=0x7fffc9dd3220, alienWidget=0x0, nativeWidget=0x1297e80, buttonDown=0x1228940, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3146
#15 0x00007f11d74c99d5 in QETWidget::translateMouseEvent (this=0x1297e80, event=<optimized out>) at kernel/qapplication_x11.cpp:4571
#16 0x00007f11d74c894e in QApplication::x11ProcessEvent (this=0x7fffc9dd6510, event=0x7fffc9dd3a40) at kernel/qapplication_x11.cpp:3693
#17 0x00007f11d74f14a2 in x11EventSourceDispatch (s=0xb02110, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#18 0x00007f11d2d59a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f11d2d5a258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f11d2d5a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f11d6a72ed6 in QEventDispatcherGlib::processEvents (this=0xadea00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#22 0x00007f11d74f110e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f11d6a46cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f11d6a46ef7 in QEventLoop::exec (this=0x103b3e0, flags=...) at kernel/qeventloop.cpp:201
#25 0x00007f11d74d7c95 in QDragManager::drag (this=0x11cbdc0, o=<optimized out>) at kernel/qdnd_x11.cpp:1981
#26 0x00007f11d745af88 in QDrag::exec (this=0x103fa60, supportedActions=..., defaultDropAction=Qt::CopyAction) at kernel/qdrag.cpp:284
#27 0x00007f11d99cadd7 in KItemListController::startDragging (this=0x1200ac0) at ../../../dolphin/src/kitemviews/kitemlistcontroller.cpp:1009
#28 0x00007f11d99caf6e in KItemListController::mouseMoveEvent (this=0x1200ac0, event=0x7fffc9dd4f80, transform=...) at ../../../dolphin/src/kitemviews/kitemlistcontroller.cpp:579
#29 0x00007f11d99ca780 in KItemListController::processEvent (this=0x1200ac0, event=<optimized out>, transform=<optimized out>) at ../../../dolphin/src/kitemviews/kitemlistcontroller.cpp:848
#30 0x00007f11d99d57e5 in KItemListView::event (this=0x1229960, event=0x7fffc9dd4f80) at ../../../dolphin/src/kitemviews/kitemlistview.cpp:689
#31 0x00007f11d7449474 in notify_helper (e=0x7fffc9dd4f80, receiver=0x1229960, this=0xafd100) at kernel/qapplication.cpp:4486
#32 QApplicationPrivate::notify_helper (this=0xafd100, receiver=0x1229960, e=0x7fffc9dd4f80) at kernel/qapplication.cpp:4458
#33 0x00007f11d744e2e1 in QApplication::notify (this=0x7fffc9dd6510, receiver=0x1229960, e=0x7fffc9dd4f80) at kernel/qapplication.cpp:4365
#34 0x00007f11d815eae6 in KApplication::notify (this=0x7fffc9dd6510, receiver=0x1229960, event=0x7fffc9dd4f80) at ../../kdeui/kernel/kapplication.cpp:311
#35 0x00007f11d6a47afc in QCoreApplication::notifyInternal (this=0x7fffc9dd6510, receiver=0x1229960, event=0x7fffc9dd4f80) at kernel/qcoreapplication.cpp:787
#36 0x00007f11d7a380de in sendEvent (event=0x7fffc9dd4f80, item=0x1229970, this=<optimized out>) at graphicsview/qgraphicsscene.cpp:1213
#37 QGraphicsScenePrivate::sendEvent (this=<optimized out>, item=0x1229970, event=0x7fffc9dd4f80) at graphicsview/qgraphicsscene.cpp:1193
#38 0x00007f11d7a38cea in QGraphicsScenePrivate::sendMouseEvent (this=0x1204690, mouseEvent=0x7fffc9dd4f80) at graphicsview/qgraphicsscene.cpp:1291
#39 0x00007f11d7a397dc in QGraphicsScene::mouseMoveEvent (this=<optimized out>, mouseEvent=0x7fffc9dd4f80) at graphicsview/qgraphicsscene.cpp:4095
#40 0x00007f11d7a4798b in QGraphicsScene::event (this=0x1204670, event=0x7fffc9dd4f80) at graphicsview/qgraphicsscene.cpp:3446
#41 0x00007f11d7449474 in notify_helper (e=0x7fffc9dd4f80, receiver=0x1204670, this=0xafd100) at kernel/qapplication.cpp:4486
#42 QApplicationPrivate::notify_helper (this=0xafd100, receiver=0x1204670, e=0x7fffc9dd4f80) at kernel/qapplication.cpp:4458
#43 0x00007f11d744e2e1 in QApplication::notify (this=0x7fffc9dd6510, receiver=0x1204670, e=0x7fffc9dd4f80) at kernel/qapplication.cpp:4365
#44 0x00007f11d815eae6 in KApplication::notify (this=0x7fffc9dd6510, receiver=0x1204670, event=0x7fffc9dd4f80) at ../../kdeui/kernel/kapplication.cpp:311
#45 0x00007f11d6a47afc in QCoreApplication::notifyInternal (this=0x7fffc9dd6510, receiver=0x1204670, event=0x7fffc9dd4f80) at kernel/qcoreapplication.cpp:787
#46 0x00007f11d7a61999 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x1204de0, event=0x7fffc9dd58b0) at graphicsview/qgraphicsview.cpp:647
#47 0x00007f11d7a61bbe in QGraphicsView::mouseMoveEvent (this=0x1204db0, event=0x7fffc9dd58b0) at graphicsview/qgraphicsview.cpp:3274
#48 0x00007f11d7499d1e in QWidget::event (this=0x1204db0, event=0x7fffc9dd58b0) at kernel/qwidget.cpp:8280
#49 0x00007f11d78425b6 in QFrame::event (this=0x1204db0, e=0x7fffc9dd58b0) at widgets/qframe.cpp:557
#50 0x00007f11d7a65dfb in QGraphicsView::viewportEvent (this=0x1204db0, event=0x7fffc9dd58b0) at graphicsview/qgraphicsview.cpp:2864
#51 0x00007f11d6a47c88 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x1228940, event=0x7fffc9dd58b0) at kernel/qcoreapplication.cpp:902
#52 0x00007f11d744943f in notify_helper (e=0x7fffc9dd58b0, receiver=0x1228940, this=0xafd100) at kernel/qapplication.cpp:4482
#53 QApplicationPrivate::notify_helper (this=0xafd100, receiver=0x1228940, e=0x7fffc9dd58b0) at kernel/qapplication.cpp:4458
#54 0x00007f11d744ecbb in QApplication::notify (this=<optimized out>, receiver=0x1228940, e=0x7fffc9dd58b0) at kernel/qapplication.cpp:4047
#55 0x00007f11d815eae6 in KApplication::notify (this=0x7fffc9dd6510, receiver=0x1228940, event=0x7fffc9dd58b0) at ../../kdeui/kernel/kapplication.cpp:311
#56 0x00007f11d6a47afc in QCoreApplication::notifyInternal (this=0x7fffc9dd6510, receiver=0x1228940, event=0x7fffc9dd58b0) at kernel/qcoreapplication.cpp:787
#57 0x00007f11d744a442 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#58 QApplicationPrivate::sendMouseEvent (receiver=0x1228940, event=0x7fffc9dd58b0, alienWidget=0x1228940, nativeWidget=0xc00bc0, buttonDown=0x1228940, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3146
#59 0x00007f11d74c99d5 in QETWidget::translateMouseEvent (this=0xc00bc0, event=<optimized out>) at kernel/qapplication_x11.cpp:4571
#60 0x00007f11d74c894e in QApplication::x11ProcessEvent (this=0x7fffc9dd6510, event=0x7fffc9dd60d0) at kernel/qapplication_x11.cpp:3693
#61 0x00007f11d74f14a2 in x11EventSourceDispatch (s=0xb02110, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#62 0x00007f11d2d59a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#63 0x00007f11d2d5a258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#64 0x00007f11d2d5a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#65 0x00007f11d6a72ed6 in QEventDispatcherGlib::processEvents (this=0xadea00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#66 0x00007f11d74f110e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#67 0x00007f11d6a46cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#68 0x00007f11d6a46ef7 in QEventLoop::exec (this=0x7fffc9dd64a0, flags=...) at kernel/qeventloop.cpp:201
#69 0x00007f11d6a4b789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#70 0x00007f11da98117d in kdemain (argc=5, argv=0x7fffc9dd6a78) at ../../../dolphin/src/main.cpp:91
#71 0x00007f11da5bb30d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=5, ubp_av=0x7fffc9dd6a78, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffc9dd6a68) at libc-start.c:226
#72 0x0000000000400671 in _start ()

Possible duplicates by query: bug 288750, bug 288321, bug 287693, bug 283129, bug 282788.

Reported using DrKonqi
Comment 1 Peter Penz 2012-02-20 14:36:59 UTC

*** This bug has been marked as a duplicate of bug 288750 ***