Bug 287693 - Dolphin crash: grabbing and moving files
Summary: Dolphin crash: grabbing and moving files
Status: RESOLVED NOT A BUG
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 1.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-27 16:45 UTC by gv
Modified: 2018-03-19 07:07 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gv 2011-11-27 16:45:03 UTC
Application: dolphin (1.7)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-13-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I was grabbing and moving files (cca. 40 pdf files, max. 30 MB each) and then it dolphin closed itself down

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe237c66780 (LWP 8456))]

Thread 3 (Thread 0x7fe224f83700 (LWP 8457)):
#0  0x00007fe230141034 in __pthread_mutex_lock (mutex=0x19faa58) at pthread_mutex_lock.c:61
#1  0x00007fe22fc6c75f in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe22fc6cf82 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe22fc6d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fe233984f3e in QEventDispatcherGlib::processEvents (this=0x1b08180, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fe233958cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fe233958ef7 in QEventLoop::exec (this=0x7fe224f82dd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fe23387027f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007fe23393bcbf in QInotifyFileSystemWatcherEngine::run (this=0x1b06c50) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007fe233872d05 in QThreadPrivate::start (arg=0x1b06c50) at thread/qthread_unix.cpp:331
#10 0x00007fe23013eefc in start_thread (arg=0x7fe224f83700) at pthread_create.c:304
#11 0x00007fe23754789d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fe21de2e700 (LWP 8462)):
#0  0x00007fe23753b773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe22fc6cf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe22fc6d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe233984f3e in QEventDispatcherGlib::processEvents (this=0x1d8c9e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fe233958cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe233958ef7 in QEventLoop::exec (this=0x7fe21de2ddd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fe23387027f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fe23393bcbf in QInotifyFileSystemWatcherEngine::run (this=0x1efd530) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe233872d05 in QThreadPrivate::start (arg=0x1efd530) at thread/qthread_unix.cpp:331
#9  0x00007fe23013eefc in start_thread (arg=0x7fe21de2e700) at pthread_create.c:304
#10 0x00007fe23754789d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe237c66780 (LWP 8456)):
[KCrash Handler]
#6  0x00007fe23435a421 in notify_helper (e=0x7fffb6d02a20, receiver=0x2516060, this=0x183d7b0) at kernel/qapplication.cpp:4486
#7  QApplicationPrivate::notify_helper (this=0x183d7b0, receiver=0x2516060, e=0x7fffb6d02a20) at kernel/qapplication.cpp:4458
#8  0x00007fe23435f80b in QApplication::notify (this=<optimized out>, receiver=<optimized out>, e=0x7fffb6d02a20) at kernel/qapplication.cpp:4290
#9  0x00007fe23506e126 in KApplication::notify (this=0x7fffb6d059d0, receiver=0x25a6070, event=0x7fffb6d02a20) at ../../kdeui/kernel/kapplication.cpp:311
#10 0x00007fe233959afc in QCoreApplication::notifyInternal (this=0x7fffb6d059d0, receiver=0x25a6070, event=0x7fffb6d02a20) at kernel/qcoreapplication.cpp:787
#11 0x00007fe2343e796d in sendEvent (event=0x7fffb6d02a20, receiver=0x25a6070) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#12 handle_xdnd_position (w=0x198e3f0, xe=0x7fffb6d02dc0, passive=false) at kernel/qdnd_x11.cpp:929
#13 0x00007fe2343e86bd in QDragManager::move (this=0x25b18a0, globalPos=...) at kernel/qdnd_x11.cpp:1668
#14 0x00007fe2343e8f09 in QDragManager::eventFilter (this=0x25b18a0, o=<optimized out>, e=<optimized out>) at kernel/qdnd_x11.cpp:1306
#15 0x00007fe233959bcc in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x183d7b0, receiver=0x226fd60, event=0x7fffb6d03300) at kernel/qcoreapplication.cpp:883
#16 0x00007fe23435a396 in QApplicationPrivate::notify_helper (this=0x183d7b0, receiver=0x226fd60, e=0x7fffb6d03300) at kernel/qapplication.cpp:4461
#17 0x00007fe23435fc6b in QApplication::notify (this=<optimized out>, receiver=0x226fd60, e=0x7fffb6d03300) at kernel/qapplication.cpp:4047
#18 0x00007fe23506e126 in KApplication::notify (this=0x7fffb6d059d0, receiver=0x226fd60, event=0x7fffb6d03300) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007fe233959afc in QCoreApplication::notifyInternal (this=0x7fffb6d059d0, receiver=0x226fd60, event=0x7fffb6d03300) at kernel/qcoreapplication.cpp:787
#20 0x00007fe23435b3f2 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#21 QApplicationPrivate::sendMouseEvent (receiver=0x226fd60, event=0x7fffb6d03300, alienWidget=0x0, nativeWidget=0x226fd60, buttonDown=0x25f77f0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3146
#22 0x00007fe2343da945 in QETWidget::translateMouseEvent (this=0x226fd60, event=<optimized out>) at kernel/qapplication_x11.cpp:4568
#23 0x00007fe2343d98be in QApplication::x11ProcessEvent (this=0x7fffb6d059d0, event=0x7fffb6d03b20) at kernel/qapplication_x11.cpp:3690
#24 0x00007fe234402412 in x11EventSourceDispatch (s=0x18432e0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#25 0x00007fe22fc6ca5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fe22fc6d258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fe22fc6d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fe233984ed6 in QEventDispatcherGlib::processEvents (this=0x181fa00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#29 0x00007fe23440207e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00007fe233958cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007fe233958ef7 in QEventLoop::exec (this=0x2884eb0, flags=...) at kernel/qeventloop.cpp:201
#32 0x00007fe2343e8c05 in QDragManager::drag (this=0x25b18a0, o=<optimized out>) at kernel/qdnd_x11.cpp:1981
#33 0x00007fe23436bf38 in QDrag::exec (this=0x1b5b690, supportedActions=..., defaultDropAction=Qt::IgnoreAction) at kernel/qdrag.cpp:284
#34 0x00007fe2368cdd7e in DragAndDropHelper::startDrag(QAbstractItemView*, QFlags<Qt::DropAction>, DolphinViewController*) () from /usr/lib/libdolphinprivate.so.4
#35 0x00007fe2368bdc2f in ?? () from /usr/lib/libdolphinprivate.so.4
#36 0x00007fe23486c9ee in QAbstractItemView::mouseMoveEvent (this=0x29153c0, event=<optimized out>) at itemviews/qabstractitemview.cpp:1709
#37 0x00007fe2368c7685 in DolphinTreeView::mouseMoveEvent(QMouseEvent*) () from /usr/lib/libdolphinprivate.so.4
#38 0x00007fe2343aacce in QWidget::event (this=0x29153c0, event=0x7fffb6d04d70) at kernel/qwidget.cpp:8280
#39 0x00007fe2347534f6 in QFrame::event (this=0x29153c0, e=0x7fffb6d04d70) at widgets/qframe.cpp:557
#40 0x00007fe23486419b in QAbstractItemView::viewportEvent (this=0x29153c0, event=0x7fffb6d04d70) at itemviews/qabstractitemview.cpp:1628
#41 0x00007fe2348a8d35 in QTreeView::viewportEvent (this=0x29153c0, event=0x7fffb6d04d70) at itemviews/qtreeview.cpp:1256
#42 0x00007fe233959c88 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x25f77f0, event=0x7fffb6d04d70) at kernel/qcoreapplication.cpp:902
#43 0x00007fe23435a3ef in notify_helper (e=0x7fffb6d04d70, receiver=0x25f77f0, this=0x183d7b0) at kernel/qapplication.cpp:4482
#44 QApplicationPrivate::notify_helper (this=0x183d7b0, receiver=0x25f77f0, e=0x7fffb6d04d70) at kernel/qapplication.cpp:4458
#45 0x00007fe23435fc6b in QApplication::notify (this=<optimized out>, receiver=0x25f77f0, e=0x7fffb6d04d70) at kernel/qapplication.cpp:4047
#46 0x00007fe23506e126 in KApplication::notify (this=0x7fffb6d059d0, receiver=0x25f77f0, event=0x7fffb6d04d70) at ../../kdeui/kernel/kapplication.cpp:311
#47 0x00007fe233959afc in QCoreApplication::notifyInternal (this=0x7fffb6d059d0, receiver=0x25f77f0, event=0x7fffb6d04d70) at kernel/qcoreapplication.cpp:787
#48 0x00007fe23435b3f2 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#49 QApplicationPrivate::sendMouseEvent (receiver=0x25f77f0, event=0x7fffb6d04d70, alienWidget=0x25f77f0, nativeWidget=0x2151780, buttonDown=0x25f77f0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3146
#50 0x00007fe2343da945 in QETWidget::translateMouseEvent (this=0x2151780, event=<optimized out>) at kernel/qapplication_x11.cpp:4568
#51 0x00007fe2343d98be in QApplication::x11ProcessEvent (this=0x7fffb6d059d0, event=0x7fffb6d05590) at kernel/qapplication_x11.cpp:3690
#52 0x00007fe234402412 in x11EventSourceDispatch (s=0x18432e0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#53 0x00007fe22fc6ca5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#54 0x00007fe22fc6d258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#55 0x00007fe22fc6d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#56 0x00007fe233984ed6 in QEventDispatcherGlib::processEvents (this=0x181fa00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#57 0x00007fe23440207e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#58 0x00007fe233958cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#59 0x00007fe233958ef7 in QEventLoop::exec (this=0x7fffb6d05960, flags=...) at kernel/qeventloop.cpp:201
#60 0x00007fe23395d789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#61 0x00007fe237850269 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_dolphin.so
#62 0x00007fe23748730d in __libc_start_main (main=0x400640, argc=5, ubp_av=0x7fffb6d05eb8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffb6d05ea8) at libc-start.c:226
#63 0x0000000000400671 in _start ()

Possible duplicates by query: bug 287676, bug 287675, bug 287634, bug 287631, bug 287612.

Reported using DrKonqi
Comment 1 Bogdan Udrescu 2011-11-27 18:10:28 UTC
I think it is a duplicate of bug 281972
Comment 2 Myriam Schweingruber 2011-12-01 22:13:36 UTC
Difficult to say without a proper backtrace, the Dolphin debugging symbols are not installed.
GV, please install the dolphin-dbg package and provide a better backtrace. See also http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports
Comment 3 Julian Steinmann 2018-03-01 20:02:41 UTC
Is this still a problem with Dolphin 17.12.2?
Comment 4 Julian Steinmann 2018-03-19 07:07:44 UTC
Closing for missing activity. If you still encounter this crash, please reopen this bug.