Bug 288750 - crash on drag + alt-tab
Summary: crash on drag + alt-tab
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 1.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 294383 300780 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-11 18:46 UTC by Dave Gilbert
Modified: 2012-05-28 19:34 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.1


Attachments
New crash information added by DrKonqi (8.66 KB, text/plain)
2012-05-27 18:05 UTC, underline
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Gilbert 2011-12-11 18:46:56 UTC
Application: dolphin (1.7)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.2.0-3-generic x86_64
Distribution: Ubuntu precise (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

Opened Dolphin on my home directory
Opened Kate
Left clicked on a file in my home directory (just a text file, no extension)
Dragged the file
while still holding the left button, did alt-tab
Selected Kate as the middle app in the alt-tab view
released alt

Dolphin crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f61bf73d780 (LWP 12623))]

Thread 3 (Thread 0x7f61acd48700 (LWP 12624)):
#0  0x00007f61bf022733 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f61b7780bf6 in g_main_context_poll (n_fds=1, fds=0x1f11810, timeout=-1, context=0x1f0a6c0, priority=<optimized out>) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3415
#2  g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x1f0a6c0, self=<optimized out>) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3116
#3  g_main_context_iterate (context=0x1f0a6c0, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3058
#4  0x00007f61b7780d24 in g_main_context_iteration (context=0x1f0a6c0, may_block=1) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3182
#5  0x00007f61bb4b5f0e in QEventDispatcherGlib::processEvents (this=0x1f1de60, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f61bb489e22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f61bb48a027 in QEventLoop::exec (this=0x7f61acd47dd0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007f61bb3a13bf in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#9  0x00007f61bb46cdef in QInotifyFileSystemWatcherEngine::run (this=0x1f3b430) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f61bb3a3e45 in QThreadPrivate::start (arg=0x1f3b430) at thread/qthread_unix.cpp:331
#11 0x00007f61b7c4befc in start_thread (arg=0x7f61acd48700) at pthread_create.c:304
#12 0x00007f61bf02e85d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f61a9958700 (LWP 12627)):
#0  0x00007f61bf022733 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f61b7780bf6 in g_main_context_poll (n_fds=1, fds=0x2301580, timeout=-1, context=0x24b2b00, priority=<optimized out>) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3415
#2  g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x24b2b00, self=<optimized out>) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3116
#3  g_main_context_iterate (context=0x24b2b00, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3058
#4  0x00007f61b7780d24 in g_main_context_iteration (context=0x24b2b00, may_block=1) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3182
#5  0x00007f61bb4b5f0e in QEventDispatcherGlib::processEvents (this=0x2354f10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f61bb489e22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f61bb48a027 in QEventLoop::exec (this=0x7f61a9957dd0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007f61bb3a13bf in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#9  0x00007f61bb46cdef in QInotifyFileSystemWatcherEngine::run (this=0x24b19a0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f61bb3a3e45 in QThreadPrivate::start (arg=0x24b19a0) at thread/qthread_unix.cpp:331
#11 0x00007f61b7c4befc in start_thread (arg=0x7f61a9958700) at pthread_create.c:304
#12 0x00007f61bf02e85d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f61bf73d780 (LWP 12623)):
[KCrash Handler]
#6  QDragManager::move (this=0x2995410, globalPos=...) at kernel/qdnd_x11.cpp:1658
#7  0x00007f61bbed9a49 in QDragManager::eventFilter (this=0x2995410, o=<optimized out>, e=<optimized out>) at kernel/qdnd_x11.cpp:1306
#8  0x00007f61bb48acfc in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x1db5530, receiver=0x29567e0, event=0x7fff7ee0d410) at kernel/qcoreapplication.cpp:883
#9  0x00007f61bbe4aed6 in QApplicationPrivate::notify_helper (this=0x1db5530, receiver=0x29567e0, e=0x7fff7ee0d410) at kernel/qapplication.cpp:4461
#10 0x00007f61bbe507ab in QApplication::notify (this=<optimized out>, receiver=0x29567e0, e=0x7fff7ee0d410) at kernel/qapplication.cpp:4047
#11 0x00007f61bcb53126 in KApplication::notify (this=0x7fff7ee0ff10, receiver=0x29567e0, event=0x7fff7ee0d410) at ../../kdeui/kernel/kapplication.cpp:311
#12 0x00007f61bb48ac2c in QCoreApplication::notifyInternal (this=0x7fff7ee0ff10, receiver=0x29567e0, event=0x7fff7ee0d410) at kernel/qcoreapplication.cpp:787
#13 0x00007f61bbe4bf32 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#14 QApplicationPrivate::sendMouseEvent (receiver=0x29567e0, event=0x7fff7ee0d410, alienWidget=0x0, nativeWidget=0x29567e0, buttonDown=0x2195d40, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3146
#15 0x00007f61bbecb485 in QETWidget::translateMouseEvent (this=0x29567e0, event=<optimized out>) at kernel/qapplication_x11.cpp:4568
#16 0x00007f61bbeca3fe in QApplication::x11ProcessEvent (this=0x7fff7ee0ff10, event=0x7fff7ee0dc30) at kernel/qapplication_x11.cpp:3690
#17 0x00007f61bbef2f52 in x11EventSourceDispatch (s=0x1db5df0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#18 0x00007f61b778089a in g_main_dispatch (context=0x1db1c30) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:2513
#19 g_main_context_dispatch (context=0x1db1c30) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3050
#20 0x00007f61b7780c60 in g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x1db1c30, self=<optimized out>) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3121
#21 g_main_context_iterate (context=0x1db1c30, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3058
#22 0x00007f61b7780d24 in g_main_context_iteration (context=0x1db1c30, may_block=1) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3182
#23 0x00007f61bb4b5ea6 in QEventDispatcherGlib::processEvents (this=0x1d93a00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#24 0x00007f61bbef2bbe in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007f61bb489e22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007f61bb48a027 in QEventLoop::exec (this=0x29b8090, flags=...) at kernel/qeventloop.cpp:201
#27 0x00007f61bbed9745 in QDragManager::drag (this=0x2995410, o=<optimized out>) at kernel/qdnd_x11.cpp:1981
#28 0x00007f61bbe5ca78 in QDrag::exec (this=0x2aafd30, supportedActions=..., defaultDropAction=Qt::IgnoreAction) at kernel/qdrag.cpp:284
#29 0x00007f61be3b4d7e in DragAndDropHelper::startDrag(QAbstractItemView*, QFlags<Qt::DropAction>, DolphinViewController*) () from /usr/lib/libdolphinprivate.so.4
#30 0x00007f61be3a32b0 in DolphinIconsView::startDrag(QFlags<Qt::DropAction>) () from /usr/lib/libdolphinprivate.so.4
#31 0x00007f61bc35d4de in QAbstractItemView::mouseMoveEvent (this=0x21985f0, event=<optimized out>) at itemviews/qabstractitemview.cpp:1709
#32 0x00007f61bc373cc1 in QListView::mouseMoveEvent (this=0x21985f0, e=0x7fff7ee0f2e0) at itemviews/qlistview.cpp:778
#33 0x00007f61bcb274de in KCategorizedView::mouseMoveEvent (this=0x21985f0, event=0x7fff7ee0f2e0) at ../../kdeui/itemviews/kcategorizedview.cpp:947
#34 0x00007f61bbe9b80e in QWidget::event (this=0x21985f0, event=0x7fff7ee0f2e0) at kernel/qwidget.cpp:8280
#35 0x00007f61bc243fe6 in QFrame::event (this=0x21985f0, e=0x7fff7ee0f2e0) at widgets/qframe.cpp:557
#36 0x00007f61bc354c8b in QAbstractItemView::viewportEvent (this=0x21985f0, event=0x7fff7ee0f2e0) at itemviews/qabstractitemview.cpp:1628
#37 0x00007f61bb48adb8 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x2195d40, event=0x7fff7ee0f2e0) at kernel/qcoreapplication.cpp:902
#38 0x00007f61bbe4af2f in notify_helper (e=0x7fff7ee0f2e0, receiver=0x2195d40, this=0x1db5530) at kernel/qapplication.cpp:4482
#39 QApplicationPrivate::notify_helper (this=0x1db5530, receiver=0x2195d40, e=0x7fff7ee0f2e0) at kernel/qapplication.cpp:4458
#40 0x00007f61bbe507ab in QApplication::notify (this=<optimized out>, receiver=0x2195d40, e=0x7fff7ee0f2e0) at kernel/qapplication.cpp:4047
#41 0x00007f61bcb53126 in KApplication::notify (this=0x7fff7ee0ff10, receiver=0x2195d40, event=0x7fff7ee0f2e0) at ../../kdeui/kernel/kapplication.cpp:311
#42 0x00007f61bb48ac2c in QCoreApplication::notifyInternal (this=0x7fff7ee0ff10, receiver=0x2195d40, event=0x7fff7ee0f2e0) at kernel/qcoreapplication.cpp:787
#43 0x00007f61bbe4bf32 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#44 QApplicationPrivate::sendMouseEvent (receiver=0x2195d40, event=0x7fff7ee0f2e0, alienWidget=0x2195d40, nativeWidget=0x2191d70, buttonDown=0x2195d40, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3146
#45 0x00007f61bbecb485 in QETWidget::translateMouseEvent (this=0x2191d70, event=<optimized out>) at kernel/qapplication_x11.cpp:4568
#46 0x00007f61bbeca3fe in QApplication::x11ProcessEvent (this=0x7fff7ee0ff10, event=0x7fff7ee0fb00) at kernel/qapplication_x11.cpp:3690
#47 0x00007f61bbef2f52 in x11EventSourceDispatch (s=0x1db5df0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#48 0x00007f61b778089a in g_main_dispatch (context=0x1db1c30) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:2513
#49 g_main_context_dispatch (context=0x1db1c30) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3050
#50 0x00007f61b7780c60 in g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x1db1c30, self=<optimized out>) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3121
#51 g_main_context_iterate (context=0x1db1c30, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3058
#52 0x00007f61b7780d24 in g_main_context_iteration (context=0x1db1c30, may_block=1) at /build/buildd/glib2.0-2.31.2/./glib/gmain.c:3182
#53 0x00007f61bb4b5ea6 in QEventDispatcherGlib::processEvents (this=0x1d93a00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#54 0x00007f61bbef2bbe in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#55 0x00007f61bb489e22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#56 0x00007f61bb48a027 in QEventLoop::exec (this=0x7fff7ee0fea0, flags=...) at kernel/qeventloop.cpp:201
#57 0x00007f61bb48e759 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#58 0x00007f61bf337269 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_dolphin.so
#59 0x00007f61bef6e30d in __libc_start_main (main=0x400640, argc=1, ubp_av=0x7fff7ee103f8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff7ee103e8) at libc-start.c:226
#60 0x0000000000400671 in _start ()

Possible duplicates by query: bug 288321, bug 287693, bug 283129, bug 282788, bug 282657.

Reported using DrKonqi
Comment 1 Peter Penz 2012-02-20 14:36:59 UTC
*** Bug 294383 has been marked as a duplicate of this bug. ***
Comment 2 underline 2012-05-27 18:05:48 UTC
Created attachment 71398 [details]
New crash information added by DrKonqi

dolphin (1.7) on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
Doing drag & drop from Dolphin to Mozilla Thunderbird. Crash happened when hovering over the window of Thunderbird.

-- Backtrace (Reduced):
#6  QDragManager::move (this=0x137ba30, globalPos=...) at kernel/qdnd_x11.cpp:1658
#7  0x00007f3acc6d6f99 in QDragManager::eventFilter (this=0x137ba30, o=<optimized out>, e=<optimized out>) at kernel/qdnd_x11.cpp:1306
#8  0x00007f3acbc47bcc in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0xadb460, receiver=0x187dbc0, event=0x7fff29ad4690) at kernel/qcoreapplication.cpp:883
#9  0x00007f3acc6483e6 in QApplicationPrivate::notify_helper (this=0xadb460, receiver=0x187dbc0, e=0x7fff29ad4690) at kernel/qapplication.cpp:4461
#10 0x00007f3acc64dcbb in QApplication::notify (this=<optimized out>, receiver=0x187dbc0, e=0x7fff29ad4690) at kernel/qapplication.cpp:4047
Comment 3 Peter Penz 2012-05-28 19:34:12 UTC
*** Bug 300780 has been marked as a duplicate of this bug. ***