Bug 288321 - Crash when copying file from pane to the other
Summary: Crash when copying file from pane to the other
Status: RESOLVED DUPLICATE of bug 233184
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 1.6.1
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-06 10:28 UTC by Henrik Skov Midtiby
Modified: 2011-12-12 08:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henrik Skov Midtiby 2011-12-06 10:28:44 UTC
Application: dolphin (1.6.1)
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-13-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
In "split view" i had opened two different directories (an external harddrive and a folder on my desktop) (both shown in column vide mode). 
After dragging a file from the desktop folder to the external harddrive the program segfaulted.

- Custom settings of the application:
In "split view" i had opened two different directories (an external harddrive and a folder on my desktop) (both shown in column vide mode).

The crash can be reproduced some of the time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7844a20 (LWP 4065))]

Thread 3 (Thread 0xb7468b70 (LWP 4066)):
#0  0x00f65760 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00a65656 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x01e18f24 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01e19e63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01e1a92b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x05ae9304 in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0x01e432df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0x00f61e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x00a5773e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb441bb70 (LWP 4068)):
#0  0x00f86416 in __kernel_vsyscall ()
#1  0x00a48f76 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x01e2a84b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01e1a1af in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01e1a524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x057b5577 in QEventDispatcherGlib::processEvents (this=0x907ad78, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x05787289 in QEventLoop::processEvents (this=0xb441b290, flags=...) at kernel/qeventloop.cpp:149
#7  0x05787522 in QEventLoop::exec (this=0xb441b290, flags=...) at kernel/qeventloop.cpp:201
#8  0x056912a0 in QThread::exec (this=0x90a7dc8) at thread/qthread.cpp:492
#9  0x05768fdb in QInotifyFileSystemWatcherEngine::run (this=0x90a7dc8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x05693da2 in QThreadPrivate::start (arg=0x90a7dc8) at thread/qthread_unix.cpp:320
#11 0x00f61e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00a5773e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb7844a20 (LWP 4065)):
[KCrash Handler]
#7  0x0203fd21 in QApplicationPrivate::notify_helper (this=0x8e8e868, receiver=0x91e1a70, e=0xbf81ef40) at kernel/qapplication.cpp:4462
#8  0x02044d35 in QApplication::notify (this=0xbf8212f0, receiver=0x90fcc68, e=0xbf81ef40) at kernel/qapplication.cpp:4266
#9  0x0116932a in KApplication::notify (this=0xbf8212f0, receiver=0x90fcc68, event=0xbf81ef40) at ../../kdeui/kernel/kapplication.cpp:311
#10 0x057880bb in QCoreApplication::notifyInternal (this=0xbf8212f0, receiver=0x90fcc68, event=0xbf81ef40) at kernel/qcoreapplication.cpp:731
#11 0x020d9cb1 in sendEvent (w=0x90031a8, xe=0x298ec40, passive=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#12 handle_xdnd_position (w=0x90031a8, xe=0x298ec40, passive=false) at kernel/qdnd_x11.cpp:929
#13 0x020dab02 in QDragManager::move (this=0x92f2d78, globalPos=...) at kernel/qdnd_x11.cpp:1668
#14 0x020db4cf in QDragManager::eventFilter (this=0x92f2d78, o=0x93161b0, e=0xbf81f694) at kernel/qdnd_x11.cpp:1306
#15 0x0578818c in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x8e8e868, receiver=0x93161b0, event=0xbf81f694) at kernel/qcoreapplication.cpp:827
#16 0x0203fca3 in QApplicationPrivate::notify_helper (this=0x8e8e868, receiver=0x93161b0, e=0xbf81f694) at kernel/qapplication.cpp:4437
#17 0x02045201 in QApplication::notify (this=0xbf8212f0, receiver=0x93161b0, e=0xbf81f694) at kernel/qapplication.cpp:4023
#18 0x0116932a in KApplication::notify (this=0xbf8212f0, receiver=0x93161b0, event=0xbf81f694) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x057880bb in QCoreApplication::notifyInternal (this=0xbf8212f0, receiver=0x93161b0, event=0xbf81f694) at kernel/qcoreapplication.cpp:731
#20 0x02040c3b in sendSpontaneousEvent (receiver=0x93161b0, event=0xbf81f694, alienWidget=0x0, nativeWidget=0x93161b0, buttonDown=0x298ec60, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#21 QApplicationPrivate::sendMouseEvent (receiver=0x93161b0, event=0xbf81f694, alienWidget=0x0, nativeWidget=0x93161b0, buttonDown=0x298ec60, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3120
#22 0x020cc04c in QETWidget::translateMouseEvent (this=0x93161b0, event=0xbf81fbbc) at kernel/qapplication_x11.cpp:4558
#23 0x020ca9b5 in QApplication::x11ProcessEvent (this=0xbf8212f0, event=0xbf81fbbc) at kernel/qapplication_x11.cpp:3680
#24 0x020f65f4 in x11EventSourceDispatch (s=0x8e91e40, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#25 0x01e19aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#26 0x01e1a270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#27 0x01e1a524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#28 0x057b553c in QEventDispatcherGlib::processEvents (this=0x8e54410, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#29 0x020f61e5 in QGuiEventDispatcherGlib::processEvents (this=0x8e54410, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x05787289 in QEventLoop::processEvents (this=0x9023158, flags=...) at kernel/qeventloop.cpp:149
#31 0x05787522 in QEventLoop::exec (this=0x9023158, flags=...) at kernel/qeventloop.cpp:201
#32 0x020db199 in QDragManager::drag (this=0x92f2d78, o=0x92fc028) at kernel/qdnd_x11.cpp:1981
#33 0x02052d6e in QDrag::exec (this=0x92fc028, supportedActions=..., defaultDropAction=Qt::IgnoreAction) at kernel/qdrag.cpp:284
#34 0x001f19e7 in DragAndDropHelper::startDrag (this=0x90aaa48, itemView=0x92efa30, supportedActions=..., dolphinViewController=0x91aa488) at ../../../dolphin/src/views/draganddrophelper.cpp:78
#35 0x001df18d in DolphinColumnView::startDrag (this=0x92efa30, supportedActions=...) at ../../../dolphin/src/views/dolphincolumnview.cpp:280
#36 0x025c2d32 in QAbstractItemView::mouseMoveEvent (this=0x92efa30, event=0xbf820a54) at itemviews/qabstractitemview.cpp:1709
#37 0x001ea75c in DolphinTreeView::mouseMoveEvent (this=0x92efa30, event=0xbf820a54) at ../../../dolphin/src/views/dolphintreeview.cpp:156
#38 0x02098172 in QWidget::event (this=0x92efa30, event=0xbf820a54) at kernel/qwidget.cpp:8244
#39 0x0248c9f3 in QFrame::event (this=0x92efa30, e=0xbf820a54) at widgets/qframe.cpp:557
#40 0x0251b062 in QAbstractScrollArea::viewportEvent (this=0x92efa30, e=0xbf820a54) at widgets/qabstractscrollarea.cpp:1043
#41 0x025ba227 in QAbstractItemView::viewportEvent (this=0x92efa30, event=0xbf820a54) at itemviews/qabstractitemview.cpp:1628
#42 0x02601e83 in QTreeView::viewportEvent (this=0x92efa30, event=0xbf820a54) at itemviews/qtreeview.cpp:1256
#43 0x0251d965 in viewportEvent (this=0x92f07c8, o=0x91ce3c0, e=0xbf820a54) at widgets/qabstractscrollarea_p.h:100
#44 QAbstractScrollAreaFilter::eventFilter (this=0x92f07c8, o=0x91ce3c0, e=0xbf820a54) at widgets/qabstractscrollarea_p.h:116
#45 0x0578825a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8e8e868, receiver=0x91ce3c0, event=0xbf820a54) at kernel/qcoreapplication.cpp:846
#46 0x0203fd00 in QApplicationPrivate::notify_helper (this=0x8e8e868, receiver=0x91ce3c0, e=0xbf820a54) at kernel/qapplication.cpp:4458
#47 0x02045201 in QApplication::notify (this=0xbf8212f0, receiver=0x91ce3c0, e=0xbf820a54) at kernel/qapplication.cpp:4023
#48 0x0116932a in KApplication::notify (this=0xbf8212f0, receiver=0x91ce3c0, event=0xbf820a54) at ../../kdeui/kernel/kapplication.cpp:311
#49 0x057880bb in QCoreApplication::notifyInternal (this=0xbf8212f0, receiver=0x91ce3c0, event=0xbf820a54) at kernel/qcoreapplication.cpp:731
#50 0x02040c3b in sendSpontaneousEvent (receiver=0x91ce3c0, event=0xbf820a54, alienWidget=0x91ce3c0, nativeWidget=0x90031a8, buttonDown=0x298ec60, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#51 QApplicationPrivate::sendMouseEvent (receiver=0x91ce3c0, event=0xbf820a54, alienWidget=0x91ce3c0, nativeWidget=0x90031a8, buttonDown=0x298ec60, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3120
#52 0x020cc04c in QETWidget::translateMouseEvent (this=0x90031a8, event=0xbf820f7c) at kernel/qapplication_x11.cpp:4558
#53 0x020ca9b5 in QApplication::x11ProcessEvent (this=0xbf8212f0, event=0xbf820f7c) at kernel/qapplication_x11.cpp:3680
#54 0x020f65f4 in x11EventSourceDispatch (s=0x8e91e40, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#55 0x01e19aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#56 0x01e1a270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#57 0x01e1a524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#58 0x057b553c in QEventDispatcherGlib::processEvents (this=0x8e54410, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#59 0x020f61e5 in QGuiEventDispatcherGlib::processEvents (this=0x8e54410, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#60 0x05787289 in QEventLoop::processEvents (this=0xbf821244, flags=...) at kernel/qeventloop.cpp:149
#61 0x05787522 in QEventLoop::exec (this=0xbf821244, flags=...) at kernel/qeventloop.cpp:201
#62 0x0578becc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#63 0x0203d8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#64 0x0087eecd in kdemain (argc=1, argv=0xbf8214e4) at ../../../dolphin/src/main.cpp:98
#65 0x080485bb in main (argc=1, argv=0xbf8214e4) at dolphin_dummy.cpp:3

Possible duplicates by query: bug 288304, bug 288288, bug 288275, bug 288268, bug 288254.

Reported using DrKonqi
Comment 1 Bogdan Udrescu 2011-12-08 15:23:20 UTC
duplicate of bug 238219
Comment 2 Myriam Schweingruber 2011-12-12 08:38:51 UTC

*** This bug has been marked as a duplicate of bug 233184 ***