Bug 283129 - Dolphin crashed when dragging a zip file to skype for sending
Summary: Dolphin crashed when dragging a zip file to skype for sending
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-01 09:22 UTC by tohyf
Modified: 2011-12-17 23:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments
New crash information added by DrKonqi (10.16 KB, text/plain)
2011-10-11 11:48 UTC, bwduncan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tohyf 2011-10-01 09:22:14 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-34-generic i686
Distribution: Ubuntu 10.04.3 LTS

-- Information about the crash:
The situation is very simple, dolphin simply crashed when I dragged the same file, twice, to another skype chat window so that I can send it to another person. The name of the file is "VB 2005 Projects.zip", not sure if the name is causing it to crash....

The crash can be reproduced every time.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  QDragManager::move (this=0x9149538, globalPos=...) at kernel/qdnd_x11.cpp:1657
#7  0x0508532f in QDragManager::eventFilter (this=0x9149538, o=0x914ddc8, e=0xbf9934a0) at kernel/qdnd_x11.cpp:1291
#8  0x0291ad9c in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x8bc4c38, receiver=0x914ddc8, event=0xbf9934a0) at kernel/qcoreapplication.cpp:800
#9  0x04fe2463 in QApplicationPrivate::notify_helper (this=0x8bc4c38, receiver=0x914ddc8, e=0xbf9934a0) at kernel/qapplication.cpp:4275
#10 0x04fe99f7 in QApplication::notify (this=0xbf9951e4, receiver=0x914ddc8, e=0xbf9934a0) at kernel/qapplication.cpp:3865
#11 0x011cb40a in KApplication::notify (this=0xbf9951e4, receiver=0x914ddc8, event=0xbf9934a0) at ../../kdeui/kernel/kapplication.cpp:302
#12 0x0291ba3b in QCoreApplication::notifyInternal (this=0xbf9951e4, receiver=0x914ddc8, event=0xbf9934a0) at kernel/qcoreapplication.cpp:704
#13 0x04fe8952 in QCoreApplication::sendEvent (receiver=0x914ddc8, event=0xbf9934a0, alienWidget=0x0, nativeWidget=0x914ddc8, buttonDown=0x5926058, lastMouseReceiver=..., spontaneous=true)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#14 QApplicationPrivate::sendMouseEvent (receiver=0x914ddc8, event=0xbf9934a0, alienWidget=0x0, nativeWidget=0x914ddc8, buttonDown=0x5926058, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2965
#15 0x05074088 in QETWidget::translateMouseEvent (this=0x914ddc8, event=0xbf9939bc) at kernel/qapplication_x11.cpp:4368
#16 0x05073511 in QApplication::x11ProcessEvent (this=0xbf9951e4, event=0xbf9939bc) at kernel/qapplication_x11.cpp:3379
#17 0x050a260a in x11EventSourceDispatch (s=0x8bc9968, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#18 0x013de5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#19 0x013e22d8 in ?? () from /lib/libglib-2.0.so.0
#20 0x013e24b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#21 0x029475d5 in QEventDispatcherGlib::processEvents (this=0x8ba69c0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#22 0x050a2135 in QGuiEventDispatcherGlib::processEvents (this=0x8ba69c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x0291a059 in QEventLoop::processEvents (this=0x8ff08c0, flags=) at kernel/qeventloop.cpp:149
#24 0x0291a4aa in QEventLoop::exec (this=0x8ff08c0, flags=...) at kernel/qeventloop.cpp:201
#25 0x0508847d in QDragManager::drag (this=0x9149538, o=0x9133b18) at kernel/qdnd_x11.cpp:1984
#26 0x04ffa99e in QDrag::exec (this=0x9133b18, supportedActions=..., defaultDropAction=Qt::IgnoreAction) at kernel/qdrag.cpp:282
#27 0x00241db3 in DragAndDropHelper::startDrag(QAbstractItemView*, QFlags<Qt::DropAction>, DolphinController*) () from /usr/lib/libdolphinprivate.so.4
#28 0x00226b14 in DolphinIconsView::startDrag(QFlags<Qt::DropAction>) () from /usr/lib/libdolphinprivate.so.4
#29 0x055870fa in QAbstractItemView::mouseMoveEvent (this=0x8da30d0, event=0xbf994930) at itemviews/qabstractitemview.cpp:1691
#30 0x055a0a9a in QListView::mouseMoveEvent (this=0x8da30d0, e=0xbf994930) at itemviews/qlistview.cpp:778
#31 0x011a635c in KCategorizedView::mouseMoveEvent (this=0x8da30d0, event=0xbf994930) at ../../kdeui/itemviews/kcategorizedview.cpp:942
#32 0x0504069a in QWidget::event (this=0x8da30d0, event=0xbf994930) at kernel/qwidget.cpp:7983
#33 0x0543cfd3 in QFrame::event (this=0x8da30d0, e=0xbf994930) at widgets/qframe.cpp:557
#34 0x054d7382 in QAbstractScrollArea::viewportEvent (this=0x5926038, e=0x0) at widgets/qabstractscrollarea.cpp:1036
#35 0x0558bbd7 in QAbstractItemView::viewportEvent (this=0x8da30d0, event=0xbf994930) at itemviews/qabstractitemview.cpp:1610
#36 0x054d9c65 in QAbstractScrollAreaPrivate::viewportEvent (this=0x8da40c0, o=0x8da2cf8, e=0xbf994930) at widgets/qabstractscrollarea_p.h:100
#37 QAbstractScrollAreaFilter::eventFilter (this=0x8da40c0, o=0x8da2cf8, e=0xbf994930) at widgets/qabstractscrollarea_p.h:116
#38 0x0291acda in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8bc4c38, receiver=0x8da2cf8, event=0xbf994930) at kernel/qcoreapplication.cpp:819
#39 0x04fe24b9 in QApplicationPrivate::notify_helper (this=0x8bc4c38, receiver=0x8da2cf8, e=0xbf994930) at kernel/qapplication.cpp:4296
#40 0x04fe99f7 in QApplication::notify (this=0xbf9951e4, receiver=0x8da2cf8, e=0xbf994930) at kernel/qapplication.cpp:3865
#41 0x011cb40a in KApplication::notify (this=0xbf9951e4, receiver=0x8da2cf8, event=0xbf994930) at ../../kdeui/kernel/kapplication.cpp:302
#42 0x0291ba3b in QCoreApplication::notifyInternal (this=0xbf9951e4, receiver=0x8da2cf8, event=0xbf994930) at kernel/qcoreapplication.cpp:704
#43 0x04fe8952 in QCoreApplication::sendEvent (receiver=0x8da2cf8, event=0xbf994930, alienWidget=0x8da2cf8, nativeWidget=0x8c540c0, buttonDown=0x5926058, lastMouseReceiver=..., spontaneous=true)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#44 QApplicationPrivate::sendMouseEvent (receiver=0x8da2cf8, event=0xbf994930, alienWidget=0x8da2cf8, nativeWidget=0x8c540c0, buttonDown=0x5926058, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2965
#45 0x05074088 in QETWidget::translateMouseEvent (this=0x8c540c0, event=0xbf994e4c) at kernel/qapplication_x11.cpp:4368
#46 0x05073511 in QApplication::x11ProcessEvent (this=0xbf9951e4, event=0xbf994e4c) at kernel/qapplication_x11.cpp:3379
#47 0x050a260a in x11EventSourceDispatch (s=0x8bc9968, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#48 0x013de5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#49 0x013e22d8 in ?? () from /lib/libglib-2.0.so.0
#50 0x013e24b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#51 0x029475d5 in QEventDispatcherGlib::processEvents (this=0x8ba69c0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#52 0x050a2135 in QGuiEventDispatcherGlib::processEvents (this=0x8ba69c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0x0291a059 in QEventLoop::processEvents (this=0xbf995144, flags=) at kernel/qeventloop.cpp:149
#54 0x0291a4aa in QEventLoop::exec (this=0xbf995144, flags=...) at kernel/qeventloop.cpp:201
#55 0x0291e69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#56 0x04fe2577 in QApplication::exec () at kernel/qapplication.cpp:3579
#57 0x0807bbef in _start ()

This bug may be a duplicate of or related to bug 233184.

Possible duplicates by query: bug 282788, bug 282657, bug 281972, bug 281873, bug 280574.

Reported using DrKonqi
Comment 1 tohyf 2011-10-01 09:39:01 UTC
the dolphin only crashes when i drag the file for too long a time, because I have many skype windows and they are grouped together, so dragging any files will need a longer time.
Comment 2 bwduncan 2011-10-11 11:48:18 UTC
Created attachment 64408 [details]
New crash information added by DrKonqi

dolphin (1.6.1) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.2

- What I was doing when the application crashed:

Dragging a pdf file to an open composer window of kmail. I had the composer window in the background and was using alt-tab to bring it to the foreground while holding the left mouse button. It only crashes sometimes. It might be related to moving the mouse across the screen to where the window will appear. Desktop compositing is enabled.

-- Backtrace (Reduced):
#6  QDragManager::move (this=0x1160480, globalPos=...) at kernel/qdnd_x11.cpp:1658
#7  0x00007f18ccaaf2c9 in QDragManager::eventFilter (this=0x1160480, o=<value optimized out>, e=<value optimized out>) at kernel/qdnd_x11.cpp:1306
#8  0x00007f18cc05f56b in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0xe50d90, receiver=0x1593a70, event=0x7fffeb59ed20) at kernel/qcoreapplication.cpp:827
#9  0x00007f18cca1e966 in QApplicationPrivate::notify_helper (this=0xe50d90, receiver=0x1593a70, e=0x7fffeb59ed20) at kernel/qapplication.cpp:4437
#10 0x00007f18cca23dc3 in QApplication::notify (this=<value optimized out>, receiver=0x1593a70, e=0x7fffeb59ed20) at kernel/qapplication.cpp:4023