Bug 294913 - Shutdown of KDE causes nepomuk to crash
Summary: Shutdown of KDE causes nepomuk to crash
Status: RESOLVED DUPLICATE of bug 292950
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-27 09:42 UTC by celticdiardan
Modified: 2012-07-06 17:18 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description celticdiardan 2012-02-27 09:42:28 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-13-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed: While shutting down the O/S 
nepomuk decided to crash - first time occurance.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1270b87780 (LWP 1559))]

Thread 4 (Thread 0x7f12517fa700 (LWP 1864)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f127067149c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#8  0x00007f127069bda9 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f126d475bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f126d4763a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f126d476639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f127069c3ef in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#13 0x00007f1270670882 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#14 0x00007f1270670abc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#15 0x00007f1270587924 in QThread::exec() () from /usr/lib/libQtCore.so.4
#16 0x00007f125fe8d641 in ?? () from /usr/lib/libsopranoserver.so.1
#17 0x00007f127058a175 in ?? () from /usr/lib/libQtCore.so.4
#18 0x00007f126df51d8c in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#19 0x00007f126e24f04d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#20 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f1250ff9700 (LWP 1866)):
#0  0x00007f126d44ab97 in g_ptr_array_set_size () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f126d474fb0 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f126d475f9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f126d476639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f127069c446 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f1270670882 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f1270670abc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x00007f1270587924 in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0x00007f125fe8d641 in ?? () from /usr/lib/libsopranoserver.so.1
#9  0x00007f127058a175 in ?? () from /usr/lib/libQtCore.so.4
#10 0x00007f126df51d8c in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#11 0x00007f126e24f04d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f12527fc700 (LWP 2153)):
#0  0x00007f126e241f03 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f126d476104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f126d476639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f127069c446 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f1270670882 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f1270670abc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f1270587924 in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f125fe8d641 in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007f127058a175 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f126df51d8c in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f126e24f04d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1270b87780 (LWP 1559)):
#0  0x00007f126df56bac in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007f127058a82b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f1270589910 in QThread::wait(unsigned long) () from /usr/lib/libQtCore.so.4
#3  0x00007f125fe8cc48 in ?? () from /usr/lib/libsopranoserver.so.1
#4  0x00007f125fe92e93 in ?? () from /usr/lib/libsopranoserver.so.1
#5  0x00007f125fe89556 in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#6  0x00007f12600b8ecb in ?? () from /usr/lib/kde4/nepomukstorage.so
#7  0x00007f12600b8f49 in ?? () from /usr/lib/kde4/nepomukstorage.so
#8  0x00007f1270683c14 in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#9  0x00007f12706885f4 in QObject::~QObject() () from /usr/lib/libQtCore.so.4
#10 0x00007f12600b8173 in ?? () from /usr/lib/kde4/nepomukstorage.so
#11 0x00007f1270683c14 in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#12 0x00007f12706885f4 in QObject::~QObject() () from /usr/lib/libQtCore.so.4
#13 0x00000000004043e9 in _start ()

This bug may be a duplicate of or related to bug 294326, bug 294449, bug 292752.

Possible duplicates by query: bug 294912, bug 294894, bug 294893, bug 294877, bug 294869.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-06 17:18:57 UTC

*** This bug has been marked as a duplicate of bug 292950 ***