Bug 294912 - A muon szoftverközpont összeomlott
Summary: A muon szoftverközpont összeomlott
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-27 09:16 UTC by zoltanpadar
Modified: 2012-02-27 09:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zoltanpadar 2012-02-27 09:16:35 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
The muon software center crashing every time i starting it. This is a new install and, all what i done is updated/upgreded the system.
I was instaled it from an usb drive using unetbootin, kubuntu-11.10-dvd-amd64.iso.

-- Backtrace:
Application: Muon szoftverközpont (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9c7fbbf780 (LWP 2265))]

Thread 2 (Thread 0x7f9c6af3e700 (LWP 2269)):
#0  0x00007f9c7c786773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9c78ffbf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9c78ffc429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9c7e944f3e in QEventDispatcherGlib::processEvents (this=0xb93960, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9c7e918cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9c7e918ef7 in QEventLoop::exec (this=0x7f9c6af3ddd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9c7e83027f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f9c7e8fbcbf in QInotifyFileSystemWatcherEngine::run (this=0xa10170) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9c7e832d05 in QThreadPrivate::start (arg=0xa10170) at thread/qthread_unix.cpp:331
#9  0x00007f9c79addefc in start_thread (arg=0x7f9c6af3e700) at pthread_create.c:304
#10 0x00007f9c7c79289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9c7fbbf780 (LWP 2265)):
[KCrash Handler]
#6  0x00007f9c7e880a5e in QtPrivate::QStringList_contains (that=0x7fff80b565f0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff80b565f0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x9c3170) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x9c3170, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff80b56bc0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f9c7e92ceba in QMetaObject::activate (sender=0x9e6f10, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x9e6f10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff80b56d20) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f9c7e92ceba in QMetaObject::activate (sender=0x9c3170, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff80b56d20) at kernel/qobject.cpp:3278
#13 0x00007f9c7f7a2e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x9c0f20) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f9c7f7a2f8e in MuonMainWindow::initObject (this=0x9c3170) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x9c3170) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x9c3170, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff80b56df0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f9c7e92ceba in QMetaObject::activate (sender=0xa4c860, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f9c7e934f7f in QSingleShotTimer::timerEvent (this=0xa4c860) at kernel/qtimer.cpp:308
#19 0x00007f9c7e930789 in QObject::event (this=0xa4c860, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f9c7cf53474 in notify_helper (e=0x7fff80b57360, receiver=0xa4c860, this=0x85fff0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x85fff0, receiver=0xa4c860, e=0x7fff80b57360) at kernel/qapplication.cpp:4458
#22 0x00007f9c7cf582e1 in QApplication::notify (this=0x7fff80b57660, receiver=0xa4c860, e=0x7fff80b57360) at kernel/qapplication.cpp:4365
#23 0x00007f9c7e138466 in KApplication::notify (this=0x7fff80b57660, receiver=0xa4c860, event=0x7fff80b57360) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f9c7e919afc in QCoreApplication::notifyInternal (this=0x7fff80b57660, receiver=0xa4c860, event=0x7fff80b57360) at kernel/qcoreapplication.cpp:787
#25 0x00007f9c7e946d62 in sendEvent (event=0x7fff80b57360, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x863a10) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f9c7e944538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007f9c78ffba5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f9c78ffc258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f9c78ffc429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f9c7e944ed6 in QEventDispatcherGlib::processEvents (this=0x83c6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f9c7cffb10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f9c7e918cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f9c7e918ef7 in QEventLoop::exec (this=0x7fff80b575f0, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f9c7e91d789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=5, argv=0x7fff80b578d8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 293113, bug 294894, bug 294893.

Possible duplicates by query: bug 294894, bug 294893, bug 294862, bug 294848, bug 294844.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-27 09:22:32 UTC

*** This bug has been marked as a duplicate of bug 291262 ***