Bug 294449 - Nepomuk crash on logout
Summary: Nepomuk crash on logout
Status: RESOLVED DUPLICATE of bug 292950
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-19 20:10 UTC by Volker Kuhlmann
Modified: 2012-05-26 02:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volker Kuhlmann 2012-02-19 20:10:53 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.6-0.11-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Logged out of session.
I may have updated packages with kpackagekit during the session.
Session was open overnight.
Happens quite often.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0x2ba0eaf88a20 (LWP 23436))]

Thread 2 (Thread 0x2ba0fcc05700 (LWP 29296)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00002ba0e3151bdc in QCoreApplication::notifyInternal (this=0x7fff57c70520, receiver=0xb34cf0, event=0x2ba0fcc04b50) at kernel/qcoreapplication.cpp:732
#8  0x00002ba0e317c2d9 in sendEvent (source=0x98b400) at kernel/qcoreapplication.h:215
#9  socketNotifierSourceDispatch (source=0x98b400) at kernel/qeventdispatcher_glib.cpp:110
#10 0x00002ba0e624bbd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#11 0x00002ba0e624c3b0 in ?? () from /lib64/libglib-2.0.so.0
#12 0x00002ba0e624c650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#13 0x00002ba0e317c8ff in QEventDispatcherGlib::processEvents (this=0xa092c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#14 0x00002ba0e3151032 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#15 0x00002ba0e3151245 in QEventLoop::exec (this=0x2ba0fcc04d70, flags=...) at kernel/qeventloop.cpp:201
#16 0x00002ba0e30661e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#17 0x00002ba0f367946b in ?? () from /usr/lib64/libsopranoserver.so.1
#18 0x00002ba0e3068a5e in QThreadPrivate::start (arg=0x77ddb0) at thread/qthread_unix.cpp:285
#19 0x00002ba0e348da3f in start_thread () from /lib64/libpthread.so.0
#20 0x00002ba0e574071d in clone () from /lib64/libc.so.6
#21 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x2ba0eaf88a20 (LWP 23436)):
#0  0x00002ba0e349238c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00002ba0e306914b in wait (this=<value optimized out>, mutex=0xb03380, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xb03380, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00002ba0e3068200 in QThread::wait (this=<value optimized out>, time=18446744073709551615) at thread/qthread_unix.cpp:683
#4  0x00002ba0f367919c in ?? () from /usr/lib64/libsopranoserver.so.1
#5  0x00002ba0f3680313 in ?? () from /usr/lib64/libsopranoserver.so.1
#6  0x00002ba0f3673d5e in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib64/libsopranoserver.so.1
#7  0x00002ba0f3424f35 in Nepomuk::Core::~Core (this=0x702df0, __in_chrg=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.6.0/nepomuk/services/storage/nepomukcore.cpp:45
#8  0x00002ba0f3424fb9 in Nepomuk::Core::~Core (this=0x702df0, __in_chrg=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.6.0/nepomuk/services/storage/nepomukcore.cpp:48
#9  0x00002ba0e31641b4 in QObjectPrivate::deleteChildren (this=0x702d10) at kernel/qobject.cpp:1949
#10 0x00002ba0e3168e52 in QObject::~QObject (this=0x702ce0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#11 0x00002ba0f34241f3 in ~Storage (this=0x702ce0, __in_chrg=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.6.0/nepomuk/services/storage/storage.cpp:50
#12 Nepomuk::Storage::~Storage (this=0x702ce0, __in_chrg=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.6.0/nepomuk/services/storage/storage.cpp:52
#13 0x00002ba0e31641b4 in QObjectPrivate::deleteChildren (this=0x6bcbb0) at kernel/qobject.cpp:1949
#14 0x00002ba0e3168e52 in QObject::~QObject (this=0x732370, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#15 0x0000000000404749 in Nepomuk::ServiceControl::~ServiceControl (this=0x732370, __in_chrg=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.6.0/nepomuk/servicestub/servicecontrol.cpp:39
#16 0x00002ba0e31641b4 in QObjectPrivate::deleteChildren (this=0x623290) at kernel/qobject.cpp:1949
#17 0x00002ba0e3168e52 in QObject::~QObject (this=0x7fff57c70520, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#18 0x00002ba0e4898875 in QApplication::~QApplication (this=0x7fff57c70520, __in_chrg=<value optimized out>) at kernel/qapplication.cpp:1071
#19 0x0000000000403f34 in main (argc=2, argv=0x7fff57c70978) at /usr/src/debug/kdebase-runtime-4.6.0/nepomuk/servicestub/main.cpp:101

This bug may be a duplicate of or related to bug 294326.

Possible duplicates by query: bug 294374, bug 294326, bug 294269, bug 293714, bug 293435.

Reported using DrKonqi
Comment 1 Vishesh Handa 2012-05-26 02:09:53 UTC

*** This bug has been marked as a duplicate of bug 292950 ***