Bug 294893 - Just installed Kubuntu and had several problems
Summary: Just installed Kubuntu and had several problems
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-27 00:08 UTC by Adam Lord
Modified: 2012-02-27 01:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Lord 2012-02-27 00:08:47 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Had several issues after first installing Kubuntu such as the muon app thing not wanting to run because the initial updates got hung up on creating workspace.  Solved problem using sudo config and then had the rekong keep shutting down for no apparent reason.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f39484a5780 (LWP 22210))]

Thread 2 (Thread 0x7f3933bef700 (LWP 22211)):
#0  0x00007f39423c81fd in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0xe945d8) at pthread_mutex_unlock.c:290
#2  0x00007f39418e1fe4 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f39418e2dfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f39418e3429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f394722bf3e in QEventDispatcherGlib::processEvents (this=0xdc5680, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f39471ffcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f39471ffef7 in QEventLoop::exec (this=0x7f3933beedd0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007f394711727f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#9  0x00007f39471e2cbf in QInotifyFileSystemWatcherEngine::run (this=0xea7e80) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f3947119d05 in QThreadPrivate::start (arg=0xea7e80) at thread/qthread_unix.cpp:331
#11 0x00007f39423c4efc in start_thread (arg=0x7f3933bef700) at pthread_create.c:304
#12 0x00007f394507989d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f39484a5780 (LWP 22210)):
[KCrash Handler]
#6  0x00007f3947167a5e in QtPrivate::QStringList_contains (that=0x7fff6a3ba690, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff6a3ba690) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xe254c0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xe254c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6a3bac60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f3947213eba in QMetaObject::activate (sender=0xe95190, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xe95190, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6a3badc0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f3947213eba in QMetaObject::activate (sender=0xe254c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6a3badc0) at kernel/qobject.cpp:3278
#13 0x00007f3948089e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xe31b60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f3948089f8e in MuonMainWindow::initObject (this=0xe254c0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xe254c0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xe254c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6a3bae90) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f3947213eba in QMetaObject::activate (sender=0xecbfe0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f394721bf7f in QSingleShotTimer::timerEvent (this=0xecbfe0) at kernel/qtimer.cpp:308
#19 0x00007f3947217789 in QObject::event (this=0xecbfe0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f394583a474 in notify_helper (e=0x7fff6a3bb400, receiver=0xecbfe0, this=0xce0e30) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xce0e30, receiver=0xecbfe0, e=0x7fff6a3bb400) at kernel/qapplication.cpp:4458
#22 0x00007f394583f2e1 in QApplication::notify (this=0x7fff6a3bb700, receiver=0xecbfe0, e=0x7fff6a3bb400) at kernel/qapplication.cpp:4365
#23 0x00007f3946a1f466 in KApplication::notify (this=0x7fff6a3bb700, receiver=0xecbfe0, event=0x7fff6a3bb400) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f3947200afc in QCoreApplication::notifyInternal (this=0x7fff6a3bb700, receiver=0xecbfe0, event=0x7fff6a3bb400) at kernel/qcoreapplication.cpp:787
#25 0x00007f394722dd62 in sendEvent (event=0x7fff6a3bb400, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xcdd2f0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f394722b514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f39418e2a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f39418e3258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f39418e3429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f394722bed6 in QEventDispatcherGlib::processEvents (this=0xcb96f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f39458e210e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f39471ffcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f39471ffef7 in QEventLoop::exec (this=0x7fff6a3bb690, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f3947204789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff6a3bb978) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294862, bug 294848, bug 294844, bug 294843, bug 294842.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-27 01:06:05 UTC

*** This bug has been marked as a duplicate of bug 291262 ***