Bug 294326 - Nepomuk crashed on shutdoan computer
Summary: Nepomuk crashed on shutdoan computer
Status: RESOLVED DUPLICATE of bug 292950
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 00:11 UTC by Lewkow Brigitte
Modified: 2012-07-06 17:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lewkow Brigitte 2012-02-18 00:11:45 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Just shutdown the computer. That's make a while it does not happen!

-- Backtrace:
Application: Jeton du service Nepomuk (nepomukservicestub), signal: Segmentation fault
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
	in ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S
[Current thread is 1 (Thread 0x7fb845155780 (LWP 2276))]

Thread 10 (Thread 0x7fb82b116700 (LWP 2516)):
#0  0x00007fb842799773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb8419ccf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb8419cd429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb844c58f3e in QEventDispatcherGlib::processEvents (this=0x2784710, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fb844c2ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb844c2cef7 in QEventLoop::exec (this=0x7fb82b115dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb844b4427f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fb844c0fcbf in QInotifyFileSystemWatcherEngine::run (this=0x27295c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fb844b46d05 in QThreadPrivate::start (arg=0x27295c0) at thread/qthread_unix.cpp:331
#9  0x00007fb8424aeefc in start_thread (arg=0x7fb82b116700) at pthread_create.c:304
#10 0x00007fb8427a589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7fb829112700 (LWP 2609)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fb844c2dafc in QCoreApplication::notifyInternal (this=0x7fff917a90d0, receiver=0x27a3940, event=0x7fb829111b50) at kernel/qcoreapplication.cpp:787
#8  0x00007fb844c585b7 in sendEvent (event=0x7fb829111b50, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#9  socketNotifierSourceDispatch (source=0x274f7d0) at kernel/qeventdispatcher_glib.cpp:110
#10 0x00007fb8419cca5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fb8419cd258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007fb8419cd429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007fb844c58ed6 in QEventDispatcherGlib::processEvents (this=0x27301c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#14 0x00007fb844c2ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#15 0x00007fb844c2cef7 in QEventLoop::exec (this=0x7fb829111d60, flags=...) at kernel/qeventloop.cpp:201
#16 0x00007fb844b4427f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#17 0x00007fb835b740ae in ?? () from /usr/lib/libsopranoserver.so.1
#18 0x00007fb844b46d05 in QThreadPrivate::start (arg=0x278cef0) at thread/qthread_unix.cpp:331
#19 0x00007fb8424aeefc in start_thread (arg=0x7fb829112700) at pthread_create.c:304
#20 0x00007fb8427a589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#21 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fb828911700 (LWP 2610)):
#0  0x00007fb8419cc096 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fb8419ccdfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb8419cd429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb844c58f3e in QEventDispatcherGlib::processEvents (this=0x2730d10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fb844c2ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb844c2cef7 in QEventLoop::exec (this=0x7fb828910d60, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb844b4427f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fb835b740ae in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007fb844b46d05 in QThreadPrivate::start (arg=0x2754a80) at thread/qthread_unix.cpp:331
#9  0x00007fb8424aeefc in start_thread (arg=0x7fb828911700) at pthread_create.c:304
#10 0x00007fb8427a589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fb828110700 (LWP 2611)):
#0  0x00007fb842799773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb8419ccf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb8419cd429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb844c58f3e in QEventDispatcherGlib::processEvents (this=0x279ce60, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fb844c2ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb844c2cef7 in QEventLoop::exec (this=0x7fb82810fd60, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb844b4427f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fb835b740ae in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007fb844b46d05 in QThreadPrivate::start (arg=0x27a3f40) at thread/qthread_unix.cpp:331
#9  0x00007fb8424aeefc in start_thread (arg=0x7fb828110700) at pthread_create.c:304
#10 0x00007fb8427a589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fb82790f700 (LWP 2614)):
#0  0x00007fb842799773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb8419ccf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb8419cd429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb844c58f3e in QEventDispatcherGlib::processEvents (this=0x2793980, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fb844c2ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb844c2cef7 in QEventLoop::exec (this=0x7fb82790ed60, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb844b4427f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fb835b740ae in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007fb844b46d05 in QThreadPrivate::start (arg=0x2ca5130) at thread/qthread_unix.cpp:331
#9  0x00007fb8424aeefc in start_thread (arg=0x7fb82790f700) at pthread_create.c:304
#10 0x00007fb8427a589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fb82710e700 (LWP 2617)):
#0  __pthread_mutex_lock (mutex=0x279f418) at pthread_mutex_lock.c:127
#1  0x00007fb8419cc023 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb8419ccdfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb8419cd429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fb844c58f3e in QEventDispatcherGlib::processEvents (this=0x2ca81f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fb844c2ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fb844c2cef7 in QEventLoop::exec (this=0x7fb82710dd60, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fb844b4427f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007fb835b740ae in ?? () from /usr/lib/libsopranoserver.so.1
#9  0x00007fb844b46d05 in QThreadPrivate::start (arg=0x7fb82c02fe20) at thread/qthread_unix.cpp:331
#10 0x00007fb8424aeefc in start_thread (arg=0x7fb82710e700) at pthread_create.c:304
#11 0x00007fb8427a589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fb82690d700 (LWP 2618)):
#0  0x00007fb842799773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb8419ccf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb8419cd429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb844c58f3e in QEventDispatcherGlib::processEvents (this=0x2926280, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fb844c2ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb844c2cef7 in QEventLoop::exec (this=0x7fb82690cd60, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb844b4427f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fb835b740ae in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007fb844b46d05 in QThreadPrivate::start (arg=0x7fb820003660) at thread/qthread_unix.cpp:331
#9  0x00007fb8424aeefc in start_thread (arg=0x7fb82690d700) at pthread_create.c:304
#10 0x00007fb8427a589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fb82610c700 (LWP 2619)):
#0  0x00007fb8424b21fd in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x27a0c68) at pthread_mutex_unlock.c:290
#2  0x00007fb8419cbfe4 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb8419ccdfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fb8419cd429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fb844c58f3e in QEventDispatcherGlib::processEvents (this=0x2ce0de0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007fb844c2ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fb844c2cef7 in QEventLoop::exec (this=0x7fb82610bd60, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007fb844b4427f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#9  0x00007fb835b740ae in ?? () from /usr/lib/libsopranoserver.so.1
#10 0x00007fb844b46d05 in QThreadPrivate::start (arg=0x7fb820003c40) at thread/qthread_unix.cpp:331
#11 0x00007fb8424aeefc in start_thread (arg=0x7fb82610c700) at pthread_create.c:304
#12 0x00007fb8427a589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb82510a700 (LWP 2627)):
#0  0x00007fb842799773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb8419ccf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb8419cd429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb844c58f3e in QEventDispatcherGlib::processEvents (this=0x2cac230, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fb844c2ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb844c2cef7 in QEventLoop::exec (this=0x7fb825109d60, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb844b4427f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fb835b740ae in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007fb844b46d05 in QThreadPrivate::start (arg=0x7fb820004da0) at thread/qthread_unix.cpp:331
#9  0x00007fb8424aeefc in start_thread (arg=0x7fb82510a700) at pthread_create.c:304
#10 0x00007fb8427a589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb845155780 (LWP 2276)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb844b471ab in wait (time=18446744073709551615, this=0x2761830) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2720280, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fb844b46a4c in QThread::wait (this=<optimized out>, time=18446744073709551615) at thread/qthread_unix.cpp:745
#4  0x00007fb835b73628 in ?? () from /usr/lib/libsopranoserver.so.1
#5  0x00007fb835b79c43 in ?? () from /usr/lib/libsopranoserver.so.1
#6  0x00007fb835b6fe7e in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#7  0x00007fb835da7c8c in Nepomuk::Core::~Core (this=0x2693430, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:46
#8  0x00007fb835da7d39 in Nepomuk::Core::~Core (this=0x2693430, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:49
#9  0x00007fb844c3fd75 in QObjectPrivate::deleteChildren (this=0x2692da0) at kernel/qobject.cpp:1955
#10 0x00007fb844c45349 in QObject::~QObject (this=0x263b540, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#11 0x00007fb835da6ef3 in ~Storage (this=0x263b540, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:54
#12 Nepomuk::Storage::~Storage (this=0x263b540, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:56
#13 0x00007fb844c3fd75 in QObjectPrivate::deleteChildren (this=0x268df50) at kernel/qobject.cpp:1955
#14 0x00007fb844c45349 in QObject::~QObject (this=0x268c490, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#15 0x0000000000404439 in Nepomuk::ServiceControl::~ServiceControl (this=0x268c490, __in_chrg=<optimized out>) at ../../../nepomuk/servicestub/servicecontrol.cpp:39
#16 0x00007fb844c3fd75 in QObjectPrivate::deleteChildren (this=0x24c4530) at kernel/qobject.cpp:1955
#17 0x00007fb844c45349 in QObject::~QObject (this=0x7fff917a90d0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#18 0x00007fb842f6ffd7 in QApplication::~QApplication (this=0x7fff917a90d0, __in_chrg=<optimized out>) at kernel/qapplication.cpp:1093
#19 0x0000000000403a54 in main (argc=2, argv=0x7fff917a9578) at ../../../nepomuk/servicestub/main.cpp:105

Possible duplicates by query: bug 294269, bug 293714, bug 293435, bug 292782, bug 292421.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-06 17:14:50 UTC

*** This bug has been marked as a duplicate of bug 292950 ***