Bug 292752 - KDE crash during shutdown, but not restart - nepomukservicesstub
Summary: KDE crash during shutdown, but not restart - nepomukservicesstub
Status: RESOLVED DUPLICATE of bug 292950
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: storage (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-29 05:57 UTC by Barnendu Goswami
Modified: 2012-07-06 17:16 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Barnendu Goswami 2012-01-29 05:57:38 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: Closed all apps, and chose to shut down (Dell Latitude D630).  This happens everytime when shutting down, but I've found that a restart seems to avoid the crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5675710 (LWP 3894))]

Thread 7 (Thread 0xb20ffb70 (LWP 3977)):
#0  0xb6014d10 in __GI_clock_gettime (clock_id=1, tp=0xb20ff028) at ../sysdeps/unix/clock_gettime.c:116
#1  0xb769b7d5 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#2  0xb776e4b6 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#3  0xb776e80a in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#4  0xb776d053 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#5  0xb776d0ed in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#6  0xb5f5a88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb5f5b637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb5f5bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb776db37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#10 0xb773e1dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#11 0xb773e421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#12 0xb764190b in QThread::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#13 0xb771ee2d in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#14 0xb76447b3 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#15 0xb6041d31 in start_thread (arg=0xb20ffb70) at pthread_create.c:304
#16 0xb61280ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 6 (Thread 0xaf8fab70 (LWP 3997)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0xb773f19e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#9  0xb776d1d8 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#10 0xb5f5b25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#11 0xb5f5b990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#12 0xb5f5bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#13 0xb776dada in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#14 0xb773e1dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#15 0xb773e421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#16 0xb764190b in QThread::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#17 0xb3d8446c in ?? () from /usr/lib/libsopranoserver.so.1
#18 0xb76447b3 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#19 0xb6041d31 in start_thread (arg=0xaf8fab70) at pthread_create.c:304
#20 0xb61280ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 5 (Thread 0xaf0f9b70 (LWP 4001)):
#0  0xb6040468 in __i686.get_pc_thunk.bx () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb6043d8f in __pthread_mutex_lock (mutex=0x9cf0fac) at pthread_mutex_lock.c:47
#2  0xb6135f14 in pthread_mutex_lock (mutex=0x9cf0fac) at forward.c:182
#3  0xb5f5a8bb in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb5f5b637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb5f5bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb776db37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#7  0xb773e1dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#8  0xb773e421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#9  0xb764190b in QThread::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#10 0xb3d8446c in ?? () from /usr/lib/libsopranoserver.so.1
#11 0xb76447b3 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#12 0xb6041d31 in start_thread (arg=0xaf0f9b70) at pthread_create.c:304
#13 0xb61280ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 4 (Thread 0xae8f8b70 (LWP 4002)):
#0  0xb6043dbd in __pthread_mutex_lock (mutex=0xa0bc884) at pthread_mutex_lock.c:61
#1  0xb6135f14 in pthread_mutex_lock (mutex=0xa0bc884) at forward.c:182
#2  0xb5f5bc13 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb776db37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#4  0xb773e1dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#5  0xb773e421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#6  0xb764190b in QThread::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#7  0xb3d8446c in ?? () from /usr/lib/libsopranoserver.so.1
#8  0xb76447b3 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#9  0xb6041d31 in start_thread (arg=0xae8f8b70) at pthread_create.c:304
#10 0xb61280ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xad8f6b70 (LWP 4050)):
#0  0xb7625810 in pthread_once@plt () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#1  0xb76439f2 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#2  0xb776d2f7 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#3  0xb5f5a88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb5f5b637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb5f5bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb776db37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#7  0xb773e1dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#8  0xb773e421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#9  0xb764190b in QThread::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#10 0xb3d8446c in ?? () from /usr/lib/libsopranoserver.so.1
#11 0xb76447b3 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#12 0xb6041d31 in start_thread (arg=0xad8f6b70) at pthread_create.c:304
#13 0xb61280ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xad0f5b70 (LWP 4081)):
#0  0xb6014d10 in __GI_clock_gettime (clock_id=1, tp=0xad0f5008) at ../sysdeps/unix/clock_gettime.c:116
#1  0xb769b7d5 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#2  0xb776e4b6 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#3  0xb776e80a in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#4  0xb776d053 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#5  0xb776d0ed in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#6  0xb5f5a88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb5f5b637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb5f5bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb776db37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#10 0xb773e1dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#11 0xb773e421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#12 0xb764190b in QThread::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#13 0xb3d8446c in ?? () from /usr/lib/libsopranoserver.so.1
#14 0xb76447b3 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#15 0xb6041d31 in start_thread (arg=0xad0f5b70) at pthread_create.c:304
#16 0xb61280ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb5675710 (LWP 3894)):
#0  0xb7893424 in __kernel_vsyscall ()
#1  0xb6045a5c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0xb6135cfc in __pthread_cond_wait (cond=0x9ce3e70, mutex=0x9ce3e58) at forward.c:139
#3  0xb7644cc0 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#4  0xb7644475 in QThread::wait(unsigned long) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#5  0xb3d8383a in ?? () from /usr/lib/libsopranoserver.so.1
#6  0xb3d8af4a in ?? () from /usr/lib/libsopranoserver.so.1
#7  0xb3d7fa66 in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#8  0xb3dcbb30 in ?? () from /usr/lib/kde4/nepomukstorage.so
#9  0xb3dcbc22 in ?? () from /usr/lib/kde4/nepomukstorage.so
#10 0xb7753841 in QObjectPrivate::deleteChildren() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#11 0xb7758439 in QObject::~QObject() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#12 0xb6ddaf98 in Nepomuk::Service::~Service() () from /usr/lib/libnepomuk.so.4
#13 0xb3dca9ba in ?? () from /usr/lib/kde4/nepomukstorage.so
#14 0xb7753841 in QObjectPrivate::deleteChildren() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#15 0xb7758439 in QObject::~QObject() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#16 0x0804b940 in _start ()

Possible duplicates by query: bug 292748, bug 292734, bug 292671, bug 292662, bug 292655.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-06 17:16:50 UTC

*** This bug has been marked as a duplicate of bug 292950 ***