Bug 290184 - KMail 4.7.2: Crashing when trying to save a mail as template
Summary: KMail 4.7.2: Crashing when trying to save a mail as template
Status: RESOLVED DUPLICATE of bug 283593
Alias: None
Product: kmail2
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-30 14:56 UTC by Michael Lipka
Modified: 2012-01-03 00:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Lipka 2011-12-30 14:56:47 UTC
Application: kmail (4.7.2)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.0-1.2-desktop i686
Distribution: "openSUSE 12.1 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
After editing a mail for further purpose, I've tried to save it as a template. KMail reponds with a segmentation-fault.

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0xb1ad3710 (LWP 4810))]

Thread 3 (Thread 0xb0248b70 (LWP 4821)):
#0  0xb5989782 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0xb5f6040c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#2  0xb3a288fb in ?? () from /usr/lib/libQtWebKit.so.4
#3  0xb3a28a1f in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb5985a7d in start_thread () from /lib/libpthread.so.0
#5  0xb5f528fe in clone () from /lib/libc.so.6

Thread 2 (Thread 0xaf928b70 (LWP 4822)):
#0  0xb5f479f4 in poll () from /lib/libc.so.6
#1  0xb46b6f7b in g_poll () from /usr/lib/libglib-2.0.so.0
#2  0xb46a8466 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb46a87fa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0xb6d31897 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0xb6d0244d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb6d02691 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb6c0575b in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0xb6c0584b in QThread::run() () from /usr/lib/libQtCore.so.4
#9  0xb6c08613 in ?? () from /usr/lib/libQtCore.so.4
#10 0xb5985a7d in start_thread () from /lib/libpthread.so.0
#11 0xb5f528fe in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb1ad3710 (LWP 4810)):
[KCrash Handler]
#6  QSharedDataPointer (o=..., this=0xbfc3ed2c) at /usr/include/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at /usr/src/debug/kdepimlibs-4.7.2/akonadi/entity.cpp:49
#8  0xb54271c7 in Akonadi::Entity::operator= (this=0xbfc3ed98, other=...) at /usr/src/debug/kdepimlibs-4.7.2/akonadi/entity.cpp:116
#9  0xb52b834d in operator= (this=<optimized out>) at /usr/include/akonadi/collection.h:75
#10 Message::ComposerViewBase::slotSaveMessage (this=0x82f37b8, job=0x84b06f0) at /usr/src/debug/kdepim-4.7.2/messagecomposer/composerviewbase.cpp:971
#11 0xb527dd25 in Message::ComposerViewBase::qt_metacall (this=0x82f37b8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc3eed8) at /usr/src/debug/kdepim-4.7.2/build/messagecomposer/moc_composerviewbase.cpp:112
#12 0xb6d097dd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#13 0xb6d18710 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#14 0xb717c1f5 in KJob::result (this=0x84b06f0, _t1=0x84b06f0) at /usr/src/debug/kdelibs-4.7.2/build/kdecore/kjob.moc:194
#15 0xb717c248 in KJob::emitResult (this=0x84b06f0) at /usr/src/debug/kdelibs-4.7.2/kdecore/jobs/kjob.cpp:312
#16 0xb541df0e in Akonadi::JobPrivate::delayedEmitResult (this=0x80d70a8) at /usr/src/debug/kdepimlibs-4.7.2/akonadi/job.cpp:144
#17 0xb5479cdf in Akonadi::Job::qt_metacall (this=0x84b06f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x87757e0) at /usr/src/debug/kdepimlibs-4.7.2/build/akonadi/job.moc:91
#18 0xb547a802 in Akonadi::CollectionFetchJob::qt_metacall (this=0x84b06f0, _c=QMetaObject::InvokeMetaMethod, _id=34, _a=0x87757e0) at /usr/src/debug/kdepimlibs-4.7.2/build/akonadi/collectionfetchjob.moc:75
#19 0xb6d097dd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#20 0xb6d14305 in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/libQtCore.so.4
#21 0xb6d1b82f in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#22 0xb623aee4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#23 0xb6240272 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#24 0xb752c681 in KApplication::notify (this=0xbfc3f7ec, receiver=0x84b06f0, event=0x8252d30) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#25 0xb6d0342e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#26 0xb6d06bf4 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#27 0xb6d06d3c in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#28 0xb6d31404 in ?? () from /usr/lib/libQtCore.so.4
#29 0xb46a7e2f in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#30 0xb46a8560 in ?? () from /usr/lib/libglib-2.0.so.0
#31 0xb46a87fa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#32 0xb6d31837 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#33 0xb62eeaaa in ?? () from /usr/lib/libQtGui.so.4
#34 0xb6d0244d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#35 0xb6d02691 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#36 0xb6d06dea in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#37 0xb6238d64 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#38 0x0804a496 in ?? ()
#39 0xb5e97003 in __libc_start_main () from /lib/libc.so.6
#40 0x0804a939 in _start ()

This bug may be a duplicate of or related to bug 283680.

Possible duplicates by query: bug 283680, bug 283619, bug 283593, bug 283364, bug 283293.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-01-03 00:38:20 UTC

*** This bug has been marked as a duplicate of bug 283593 ***