Bug 283619 - akonadi_maildispatcher_agent multiple crash on KDE login
Summary: akonadi_maildispatcher_agent multiple crash on KDE login
Status: RESOLVED DUPLICATE of bug 283364
Alias: None
Product: Akonadi
Classification: Unclassified
Component: Mail Dispatcher Agent (show other bugs)
Version: 4.7
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-08 18:42 UTC by 7c0.000
Modified: 2011-10-08 22:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 7c0.000 2011-10-08 18:42:09 UTC
Application: akonadi_maildispatcher_agent (4.7)
KDE Platform Version: 4.7.2 (4.7.2) "release 9"
Qt Version: 4.7.4
Operating System: Linux 2.6.37.1-1.2-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
After upgrading KDE from 4.6 to 4.7 akonadi_maildispatcher_agent crash multiply on KDE login (even if Kmail is not started).

The crash can be reproduced every time.

-- Backtrace:
Application: Agent przyjmowania poczty (akonadi_maildispatcher_agent), signal: Segmentation fault
[KCrash Handler]
#6  QSharedDataPointer (one=..., other=...) at /usr/include/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at /usr/src/debug/kdepimlibs-4.7.2/akonadi/entity.cpp:49
#8  0x00002b5efe737e0e in Akonadi::Entity::operator= (this=0x7fff4494dff0, other=<value optimized out>) at /usr/src/debug/kdepimlibs-4.7.2/akonadi/entity.cpp:116
#9  0x0000000000416c50 in operator= (this=0xa78100, job=0x7fbd80) at /usr/include/akonadi/collection.h:76
#10 SendJob::Private::slotSentMailCollectionFetched (this=0xa78100, job=0x7fbd80) at /usr/src/debug/kdepim-runtime-4.7.2/agents/maildispatcher/sendjob.cpp:312
#11 0x0000000000416d45 in SendJob::qt_metacall (this=0xa7b900, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4494e120) at /usr/src/debug/kdepim-runtime-4.7.2/build/agents/maildispatcher/sendjob.moc:92
#12 0x00002b5efee47e8f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#13 0x00002b5eff514f92 in KJob::result (this=<value optimized out>, _t1=0x7fbd80) at /usr/src/debug/kdelibs-4.7.2/build/kdecore/kjob.moc:194
#14 0x00002b5eff514fd0 in KJob::emitResult (this=0x7fbd80) at /usr/src/debug/kdelibs-4.7.2/kdecore/jobs/kjob.cpp:312
#15 0x00002b5efe75a26d in Akonadi::Job::qt_metacall (this=0x7fbd80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xa24180) at /usr/src/debug/kdepimlibs-4.7.2/build/akonadi/job.moc:91
#16 0x00002b5efe76eb35 in Akonadi::CollectionFetchJob::qt_metacall (this=0x7fbd80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xa24180) at /usr/src/debug/kdepimlibs-4.7.2/build/akonadi/collectionfetchjob.moc:75
#17 0x00002b5efee477aa in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#18 0x00002b5f009f9264 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#19 0x00002b5f00a0181a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#20 0x00002b5f003fcae6 in KApplication::notify (this=0x7fff4494ebc0, receiver=0x7fbd80, event=0x92e9d0) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#21 0x00002b5efee337cc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#22 0x00002b5efee36fc5 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#23 0x00002b5efee5e443 in ?? () from /usr/lib64/libQtCore.so.4
#24 0x00002b5f03717b43 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#25 0x00002b5f03718320 in g_main_context_iterate () from /lib64/libglib-2.0.so.0
#26 0x00002b5f037185c0 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#27 0x00002b5efee5e5df in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#28 0x00002b5f00a9f1ae in ?? () from /usr/lib64/libQtGui.so.4
#29 0x00002b5efee32c22 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#30 0x00002b5efee32e35 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#31 0x00002b5efee3727b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#32 0x00002b5efe7278d7 in Akonadi::AgentBase::init (r=0x7e4f00) at /usr/src/debug/kdepimlibs-4.7.2/akonadi/agentbase.cpp:554
#33 0x000000000040b00a in init<MailDispatcherAgent> (argc=<value optimized out>, argv=<value optimized out>) at /usr/include/akonadi/agentbase.h:342
#34 main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdepim-runtime-4.7.2/agents/maildispatcher/maildispatcheragent.cpp:376

Possible duplicates by query: bug 283593, bug 283364, bug 266358.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-10-08 22:17:46 UTC

*** This bug has been marked as a duplicate of bug 283364 ***