Bug 283680 - KMail segfault when saving a template
Summary: KMail segfault when saving a template
Status: RESOLVED DUPLICATE of bug 283593
Alias: None
Product: kmail2
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-10 03:52 UTC by Wyatt Epp
Modified: 2012-01-03 00:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wyatt Epp 2011-10-10 03:52:36 UTC
Application: kmail (4.7.1)
KDE Platform Version: 4.7.1 (4.7.1) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.39-gentoo-r3 x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:
I had finished a canned response I was writing, sent it, and then tried to save it as a template for later use.  KMail consistently segfaults at this point.  I'm going to build with -g and see if I can get a better backtrace (I'll almost certainly forget and try again)

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f00c4341760 (LWP 28325))]

Thread 2 (Thread 0x7f00a88c6700 (LWP 28336)):
#0  0x00007f00bf51b61c in pthread_cond_wait () from /lib64/libpthread.so.0
#1  0x00007f00b65e6a3d in WTF::TCMalloc_PageHeap::scavengerThread() () from /usr/lib64/qt4/libQtWebKit.so.4
#2  0x00007f00b65e6b49 in WTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /usr/lib64/qt4/libQtWebKit.so.4
#3  0x00007f00bf516d4c in start_thread () from /lib64/libpthread.so.0
#4  0x00007f00c16a02ad in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f00c4341760 (LWP 28325)):
[KCrash Handler]
#6  0x00007f00bdf015e6 in assignEntityPrivate(QSharedDataPointer<Akonadi::EntityPrivate>&, QSharedDataPointer<Akonadi::EntityPrivate> const&) () from /usr/lib64/libakonadi-kde.so.4
#7  0x00007f00bdf0169e in Akonadi::Entity::operator=(Akonadi::Entity const&) () from /usr/lib64/libakonadi-kde.so.4
#8  0x00007f00bd789fc9 in Message::ComposerViewBase::slotSaveMessage(KJob*) () from /usr/lib64/libmessagecomposer.so.4
#9  0x00007f00bd752964 in Message::ComposerViewBase::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libmessagecomposer.so.4
#10 0x00007f00c1fdea0f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/qt4/libQtCore.so.4
#11 0x00007f00c3750fa2 in KJob::result(KJob*) () from /usr/lib64/libkdecore.so.5
#12 0x00007f00c3750fe0 in KJob::emitResult() () from /usr/lib64/libkdecore.so.5
#13 0x00007f00bdfbbaed in Akonadi::Job::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libakonadi-kde.so.4
#14 0x00007f00bdf3b595 in Akonadi::CollectionFetchJob::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libakonadi-kde.so.4
#15 0x00007f00c1fd8abe in QObject::event(QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#16 0x00007f00c24c08dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#17 0x00007f00c24c5d7d in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#18 0x00007f00c3d51d56 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#19 0x00007f00c1fc6d2b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#20 0x00007f00c1fc9cb1 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/qt4/libQtCore.so.4
#21 0x00007f00c1ff32d3 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/qt4/libQtCore.so.4
#22 0x00007f00ba0be03e in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f00ba0be828 in g_main_context_iterate.clone.6 () from /usr/lib64/libglib-2.0.so.0
#24 0x00007f00ba0beabd in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#25 0x00007f00c1ff2e13 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#26 0x00007f00c2572cbe in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtGui.so.4
#27 0x00007f00c1fc5a82 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#28 0x00007f00c1fc5e64 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#29 0x00007f00c1fc9edb in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#30 0x00000000004031be in main ()

This bug may be a duplicate of or related to bug 283293.

Possible duplicates by query: bug 283293.

Reported using DrKonqi
Comment 1 Laurent Montel 2011-10-10 08:25:08 UTC
you send => you can't save at template after that.
How do you do it ?
Comment 2 Laurent Montel 2011-10-12 08:05:42 UTC
No news ?
Comment 3 Christophe Giboudeaux 2011-10-12 16:24:21 UTC
maybe a dup of bug 283593
Comment 4 Christophe Giboudeaux 2012-01-03 00:38:46 UTC

*** This bug has been marked as a duplicate of bug 283593 ***