Bug 293938 - Muon Software Center Crashes on startup
Summary: Muon Software Center Crashes on startup
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-12 21:19 UTC by Grady Parks
Modified: 2012-02-23 01:10 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.69 KB, text/plain)
2012-02-13 12:39 UTC, Paul Groskopf
Details
New crash information added by DrKonqi (7.41 KB, text/plain)
2012-02-15 21:13 UTC, Olivier Quinet
Details
New crash information added by DrKonqi (6.04 KB, text/plain)
2012-02-23 01:10 UTC, energy.burst13
Details
New crash information added by DrKonqi (6.04 KB, text/plain)
2012-02-23 01:10 UTC, energy.burst13
Details
New crash information added by DrKonqi (6.04 KB, text/plain)
2012-02-23 01:10 UTC, energy.burst13
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Grady Parks 2012-02-12 21:19:41 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I started Muon Software Center and it never loads anything useful, it just goes
straight to a segmentation fault.

Muon Update Manager also had an issue, when doing a software upgrade it stopped
responding at 50% I had to use dpkg --configure -a to repair the upgrade. 

- Custom settings of the application:
no customizations, just fresh install.

The crash can be reproduced every time.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76e1930 (LWP 1882))]

Thread 2 (Thread 0xb5888b70 (LWP 1886)):
#0  0x00973d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x005137d5 in do_gettime (frac=0xb5888020, sec=0xb5888018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x005e64b6 in QTimerInfoList::updateCurrentTime (this=0x844ce9c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x005e680a in QTimerInfoList::timerWait (this=0x844ce9c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x005e5053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb588812c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x005e50ed in timerSourcePrepare (source=0x844ce68, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0388e88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x0388f637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x0388fc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x005e5b37 in QEventDispatcherGlib::processEvents (this=0x8445500, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x005b61dd in QEventLoop::processEvents (this=0xb58882b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x005b6421 in QEventLoop::exec (this=0xb58882b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x004b990b in QThread::exec (this=0x84430f0) at thread/qthread.cpp:498
#14 0x00596e2d in QInotifyFileSystemWatcherEngine::run (this=0x84430f0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x004bc7b3 in QThreadPrivate::start (arg=0x84430f0) at thread/qthread_unix.cpp:331
#16 0x00b1ad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x007ef0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb76e1930 (LWP 1882)):
[KCrash Handler]
#7  0x00510e11 in QtPrivate::QStringList_contains (that=0xbfba54e4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfba54e4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x82f2e88) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x82f2e88, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfba5704) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x005bdb7d in metacall (argv=0xbfba5704, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x82f2e88) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x82f2e88, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfba5704) at kernel/qmetaobject.cpp:232
#13 0x005cca6a in QMetaObject::activate (sender=0x82e6d38, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x82e6d38) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x82e6d38, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfba5848) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x005bdb7d in metacall (argv=0xbfba5848, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x82e6d38) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x82e6d38, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfba5848) at kernel/qmetaobject.cpp:232
#18 0x005cca6a in QMetaObject::activate (sender=0x82f2e88, m=0x80950c0, local_signal_index=0, argv=0xbfba5848) at kernel/qobject.cpp:3278
#19 0x009927c5 in MuonMainWindow::backendReady (this=0x82f2e88, _t1=0x8365500) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00992933 in MuonMainWindow::initObject (this=0x82f2e88) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x82f2e88) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x82f2e88, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfba5974) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x005bdb7d in metacall (argv=0xbfba5974, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x82f2e88) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x82f2e88, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfba5974) at kernel/qmetaobject.cpp:232
#25 0x005cca6a in QMetaObject::activate (sender=0x8361868, m=0x6ed238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x005d4375 in QSingleShotTimer::timeout (this=0x8361868) at .moc/release-shared/qtimer.moc:82
#27 0x005d442c in QSingleShotTimer::timerEvent (this=0x8361868) at kernel/qtimer.cpp:308
#28 0x005cf994 in QObject::event (this=0x8361868, e=0xbfba5d6c) at kernel/qobject.cpp:1181
#29 0x03bedd84 in notify_helper (e=0xbfba5d6c, receiver=0x8361868, this=0x8209908) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8209908, receiver=0x8361868, e=0xbfba5d6c) at kernel/qapplication.cpp:4458
#31 0x03bf3133 in QApplication::notify (this=0xbfba5d6c, receiver=0x8361868, e=0xbfba5d6c) at kernel/qapplication.cpp:3886
#32 0x011a9971 in KApplication::notify (this=0xbfba6080, receiver=0x8361868, event=0xbfba5d6c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x005b719e in QCoreApplication::notifyInternal (this=0xbfba6080, receiver=0x8361868, event=0xbfba5d6c) at kernel/qcoreapplication.cpp:787
#34 0x005e7c10 in sendEvent (event=0xbfba5d6c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8212434) at kernel/qeventdispatcher_unix.cpp:603
#36 0x005e5122 in timerSourceDispatch (source=0x8212400) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0388f25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x0388f990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x0388fc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x005e5ada in QEventDispatcherGlib::processEvents (this=0x81ed238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x03ca5e7a in QGuiEventDispatcherGlib::processEvents (this=0x81ed238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x005b61dd in QEventLoop::processEvents (this=0xbfba5fe4, flags=...) at kernel/qeventloop.cpp:149
#43 0x005b6421 in QEventLoop::exec (this=0xbfba5fe4, flags=...) at kernel/qeventloop.cpp:201
#44 0x005bb19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x03beb924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 293796.

Possible duplicates by query: bug 293911, bug 293910, bug 293904, bug 293896, bug 293821.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-12 21:22:15 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Paul Groskopf 2012-02-13 12:39:37 UTC
Created attachment 68757 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

I just start the application and it never let me do any thing before it crash.

-- Backtrace (Reduced):
#7  0x004f7e11 in QtPrivate::QStringList_contains (that=0xbfe88d84, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe88d84) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x85214f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x85214f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe88fa4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x005a4b7d in metacall (argv=0xbfe88fa4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x85214f0) at kernel/qmetaobject.cpp:237
Comment 3 Olivier Quinet 2012-02-15 21:13:48 UTC
Created attachment 68832 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

Nothing in particular.  Muon Software Center was the first program I tried to launch after a fresh install of Kubuntu.

- Unusual behavior I noticed:  opengl was buggy, I had to disabled it and use Xrender instead.

-- Backtrace (Reduced):
#7  0x00e0ae11 in QtPrivate::QStringList_contains (that=0xbfb6f274, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfb6f274) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x903b578) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x903b578, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb6f494) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00eb7b7d in metacall (argv=0xbfb6f494, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x903b578) at kernel/qmetaobject.cpp:237
Comment 4 energy.burst13 2012-02-23 01:10:33 UTC
Created attachment 69024 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed: Normal use, web browsing simultaneously.

-- Backtrace (Reduced):
#6  0x00007f049b6baa5e in QtPrivate::QStringList_contains (that=0x7fff04eb3800, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff04eb3800) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1273ec0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1273ec0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff04eb3dd0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x14584f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff04eb3f30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 5 energy.burst13 2012-02-23 01:10:33 UTC
Created attachment 69025 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed: Normal use, web browsing simultaneously.

-- Backtrace (Reduced):
#6  0x00007f049b6baa5e in QtPrivate::QStringList_contains (that=0x7fff04eb3800, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff04eb3800) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1273ec0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1273ec0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff04eb3dd0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x14584f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff04eb3f30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 6 energy.burst13 2012-02-23 01:10:33 UTC
Created attachment 69026 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed: Normal use, web browsing simultaneously.

-- Backtrace (Reduced):
#6  0x00007f049b6baa5e in QtPrivate::QStringList_contains (that=0x7fff04eb3800, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff04eb3800) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1273ec0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1273ec0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff04eb3dd0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x14584f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff04eb3f30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109