Bug 293904 - Muon crashes
Summary: Muon crashes
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-12 14:50 UTC by Dusan Tatomirovic
Modified: 2012-02-12 15:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dusan Tatomirovic 2012-02-12 14:50:56 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

trying to install updates to the new kubuntu install
every time the system would report that there is another process in the background using the same app.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78c7930 (LWP 20746))]

Thread 2 (Thread 0xb5be4b70 (LWP 20747)):
#0  0x015e40bb in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x015e4990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x015e4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x00740b37 in QEventDispatcherGlib::processEvents (this=0x87e09d8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x007111dd in QEventLoop::processEvents (this=0xb5be42b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00711421 in QEventLoop::exec (this=0xb5be42b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x0061490b in QThread::exec (this=0x87832a8) at thread/qthread.cpp:498
#7  0x006f1e2d in QInotifyFileSystemWatcherEngine::run (this=0x87832a8) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x006177b3 in QThreadPrivate::start (arg=0x87832a8) at thread/qthread_unix.cpp:331
#9  0x00570d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x00d310ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb78c7930 (LWP 20746)):
[KCrash Handler]
#7  0x0066be11 in QtPrivate::QStringList_contains (that=0xbfb05e14, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfb05e14) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8780530) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8780530, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb06034) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00718b7d in metacall (argv=0xbfb06034, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8780530) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8780530, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfb06034) at kernel/qmetaobject.cpp:232
#13 0x00727a6a in QMetaObject::activate (sender=0x8819710, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8819710) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8819710, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb06178) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00718b7d in metacall (argv=0xbfb06178, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8819710) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8819710, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfb06178) at kernel/qmetaobject.cpp:232
#18 0x00727a6a in QMetaObject::activate (sender=0x8780530, m=0x80950c0, local_signal_index=0, argv=0xbfb06178) at kernel/qobject.cpp:3278
#19 0x0040b7c5 in MuonMainWindow::backendReady (this=0x8780530, _t1=0x8791820) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0040b933 in MuonMainWindow::initObject (this=0x8780530) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8780530) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8780530, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb062a4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00718b7d in metacall (argv=0xbfb062a4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8780530) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8780530, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfb062a4) at kernel/qmetaobject.cpp:232
#25 0x00727a6a in QMetaObject::activate (sender=0x87e9818, m=0x848238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0072f375 in QSingleShotTimer::timeout (this=0x87e9818) at .moc/release-shared/qtimer.moc:82
#27 0x0072f42c in QSingleShotTimer::timerEvent (this=0x87e9818) at kernel/qtimer.cpp:308
#28 0x0072a994 in QObject::event (this=0x87e9818, e=0xbfb0669c) at kernel/qobject.cpp:1181
#29 0x0251bd84 in notify_helper (e=0xbfb0669c, receiver=0x87e9818, this=0x8698550) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8698550, receiver=0x87e9818, e=0xbfb0669c) at kernel/qapplication.cpp:4458
#31 0x02521133 in QApplication::notify (this=0xbfb0669c, receiver=0x87e9818, e=0xbfb0669c) at kernel/qapplication.cpp:3886
#32 0x010df971 in KApplication::notify (this=0xbfb069b0, receiver=0x87e9818, event=0xbfb0669c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0071219e in QCoreApplication::notifyInternal (this=0xbfb069b0, receiver=0x87e9818, event=0xbfb0669c) at kernel/qcoreapplication.cpp:787
#34 0x00742c10 in sendEvent (event=0xbfb0669c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x869faec) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00740122 in timerSourceDispatch (source=0x869fab8) at kernel/qeventdispatcher_glib.cpp:184
#37 0x015e425f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x015e4990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x015e4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00740ada in QEventDispatcherGlib::processEvents (this=0x867b238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x025d3e7a in QGuiEventDispatcherGlib::processEvents (this=0x867b238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x007111dd in QEventLoop::processEvents (this=0xbfb06914, flags=...) at kernel/qeventloop.cpp:149
#43 0x00711421 in QEventLoop::exec (this=0xbfb06914, flags=...) at kernel/qeventloop.cpp:201
#44 0x0071619d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x02519924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293896, bug 293821, bug 293811, bug 293810, bug 293809.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-12 15:20:46 UTC

*** This bug has been marked as a duplicate of bug 291262 ***