Bug 293821 - primer error
Summary: primer error
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-11 00:44 UTC by lucero
Modified: 2012-02-11 05:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lucero 2012-02-11 00:44:35 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- Unusual behavior I noticed: no prmite ver el software de instalacion

The crash can be reproduced some of the time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7708930 (LWP 1729))]

Thread 2 (Thread 0xb55a7b70 (LWP 1733)):
#0  0x05a94892 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x05a95637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x05a95c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0060eb37 in QEventDispatcherGlib::processEvents (this=0x992ead8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x005df1dd in QEventLoop::processEvents (this=0xb55a72b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x005df421 in QEventLoop::exec (this=0xb55a72b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x004e290b in QThread::exec (this=0x992ce78) at thread/qthread.cpp:498
#7  0x005bfe2d in QInotifyFileSystemWatcherEngine::run (this=0x992ce78) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x004e57b3 in QThreadPrivate::start (arg=0x992ce78) at thread/qthread_unix.cpp:331
#9  0x00906d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x00b910ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7708930 (LWP 1729)):
[KCrash Handler]
#7  0x00539e11 in QtPrivate::QStringList_contains (that=0xbffc3c24, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbffc3c24) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x97dd480) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x97dd480, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffc3e44) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x005e6b7d in metacall (argv=0xbffc3e44, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x97dd480) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x97dd480, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbffc3e44) at kernel/qmetaobject.cpp:232
#13 0x005f5a6a in QMetaObject::activate (sender=0x9705f80, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9705f80) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9705f80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffc3f88) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x005e6b7d in metacall (argv=0xbffc3f88, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9705f80) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9705f80, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbffc3f88) at kernel/qmetaobject.cpp:232
#18 0x005f5a6a in QMetaObject::activate (sender=0x97dd480, m=0x80950c0, local_signal_index=0, argv=0xbffc3f88) at kernel/qobject.cpp:3278
#19 0x00cfa7c5 in MuonMainWindow::backendReady (this=0x97dd480, _t1=0x97dc090) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00cfa933 in MuonMainWindow::initObject (this=0x97dd480) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x97dd480) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x97dd480, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffc40b4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x005e6b7d in metacall (argv=0xbffc40b4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x97dd480) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x97dd480, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbffc40b4) at kernel/qmetaobject.cpp:232
#25 0x005f5a6a in QMetaObject::activate (sender=0x9839ff0, m=0x716238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x005fd375 in QSingleShotTimer::timeout (this=0x9839ff0) at .moc/release-shared/qtimer.moc:82
#27 0x005fd42c in QSingleShotTimer::timerEvent (this=0x9839ff0) at kernel/qtimer.cpp:308
#28 0x005f8994 in QObject::event (this=0x9839ff0, e=0xbffc44ac) at kernel/qobject.cpp:1181
#29 0x012bfd84 in notify_helper (e=0xbffc44ac, receiver=0x9839ff0, this=0x970b7a0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x970b7a0, receiver=0x9839ff0, e=0xbffc44ac) at kernel/qapplication.cpp:4458
#31 0x012c5133 in QApplication::notify (this=0xbffc44ac, receiver=0x9839ff0, e=0xbffc44ac) at kernel/qapplication.cpp:3886
#32 0x00f15971 in KApplication::notify (this=0xbffc47c0, receiver=0x9839ff0, event=0xbffc44ac) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x005e019e in QCoreApplication::notifyInternal (this=0xbffc47c0, receiver=0x9839ff0, event=0xbffc44ac) at kernel/qcoreapplication.cpp:787
#34 0x00610c10 in sendEvent (event=0xbffc44ac, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x970eb34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0060e122 in timerSourceDispatch (source=0x970eb00) at kernel/qeventdispatcher_glib.cpp:184
#37 0x05a9525f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x05a95990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x05a95c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0060eada in QEventDispatcherGlib::processEvents (this=0x96ef238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x01377e7a in QGuiEventDispatcherGlib::processEvents (this=0x96ef238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x005df1dd in QEventLoop::processEvents (this=0xbffc4724, flags=...) at kernel/qeventloop.cpp:149
#43 0x005df421 in QEventLoop::exec (this=0xbffc4724, flags=...) at kernel/qeventloop.cpp:201
#44 0x005e419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x012bd924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293811, bug 293810, bug 293809, bug 293798, bug 293796.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-11 05:17:41 UTC

*** This bug has been marked as a duplicate of bug 291262 ***