Bug 293896 - Muon Installer Crash
Summary: Muon Installer Crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-12 13:15 UTC by Daniel L McGrew
Modified: 2012-02-12 13:28 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel L McGrew 2012-02-12 13:15:39 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I simply clicked on the desktop icon.
- Unusual behavior I noticed:
The bouncing mouse cursor appears, then the object dialog box pops up, but never fully populates. Then, it disappears and the crash report appears. 
Computer Info: Kubuntu 11.1
Linux 3.9.9-15-generic
KDE SC Version: 4.7.4
P4M900-M4
4GB RAM
590GB HD (WL640GSA3272)
Intel Duo Core 2.13GHz
NVIDIA 8400 GS/PCI/SSE2 (290.10)

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f648e73d780 (LWP 5090))]

Thread 2 (Thread 0x7f6479c6d700 (LWP 5094)):
#0  0x00007f648867103e in __pthread_mutex_lock (mutex=0x1dcfb18) at pthread_mutex_lock.c:62
#1  0x00007f6487b8cfcc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6487b8d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f648d4d5f3e in QEventDispatcherGlib::processEvents (this=0x1d70d30, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f648d4a9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f648d4a9ef7 in QEventLoop::exec (this=0x7f6479c6cdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f648d3c127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f648d48ccbf in QInotifyFileSystemWatcherEngine::run (this=0x1dede90) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f648d3c3d05 in QThreadPrivate::start (arg=0x1dede90) at thread/qthread_unix.cpp:331
#9  0x00007f648866eefc in start_thread (arg=0x7f6479c6d700) at pthread_create.c:304
#10 0x00007f648b32389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f648e73d780 (LWP 5090)):
[KCrash Handler]
#6  0x00007f648d411a5e in QtPrivate::QStringList_contains (that=0x7fff8dbbb130, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff8dbbb130) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1d2c110) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1d2c110, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8dbbb700) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f648d4bdeba in QMetaObject::activate (sender=0x1c04a00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1c04a00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8dbbb860) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f648d4bdeba in QMetaObject::activate (sender=0x1d2c110, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8dbbb860) at kernel/qobject.cpp:3278
#13 0x00007f648e333e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1d727e0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f648e333f8e in MuonMainWindow::initObject (this=0x1d2c110) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1d2c110) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1d2c110, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8dbbb930) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f648d4bdeba in QMetaObject::activate (sender=0x1dd4a50, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f648d4c5f7f in QSingleShotTimer::timerEvent (this=0x1dd4a50) at kernel/qtimer.cpp:308
#19 0x00007f648d4c1789 in QObject::event (this=0x1dd4a50, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f648bae4474 in notify_helper (e=0x7fff8dbbbea0, receiver=0x1dd4a50, this=0x1c170a0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1c170a0, receiver=0x1dd4a50, e=0x7fff8dbbbea0) at kernel/qapplication.cpp:4458
#22 0x00007f648bae92e1 in QApplication::notify (this=0x7fff8dbbc1a0, receiver=0x1dd4a50, e=0x7fff8dbbbea0) at kernel/qapplication.cpp:4365
#23 0x00007f648ccc9466 in KApplication::notify (this=0x7fff8dbbc1a0, receiver=0x1dd4a50, event=0x7fff8dbbbea0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f648d4aaafc in QCoreApplication::notifyInternal (this=0x7fff8dbbc1a0, receiver=0x1dd4a50, event=0x7fff8dbbbea0) at kernel/qcoreapplication.cpp:787
#25 0x00007f648d4d7d62 in sendEvent (event=0x7fff8dbbbea0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1c13cc0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f648d4d5514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f6487b8ca5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f6487b8d258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f6487b8d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f648d4d5ed6 in QEventDispatcherGlib::processEvents (this=0x1bee6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f648bb8c10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f648d4a9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f648d4a9ef7 in QEventLoop::exec (this=0x7fff8dbbc130, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f648d4ae789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff8dbbc418) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293821, bug 293811, bug 293810, bug 293809, bug 293798.

Reported using DrKonqi
Comment 1 Daniel L McGrew 2012-02-12 13:17:04 UTC
Muon package manager works, but Muon installer will not open (from the start menu or the desktop icon).
Comment 2 Jekyll Wu 2012-02-12 13:28:43 UTC

*** This bug has been marked as a duplicate of bug 291262 ***