Bug 293796 - Muon Software center Crashes at start-up
Summary: Muon Software center Crashes at start-up
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-10 19:38 UTC by ramkumar
Modified: 2012-02-10 20:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ramkumar 2012-02-10 19:38:06 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Muon Package Manager did the same thing , but it was loaded after the crash

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[KCrash Handler]
#7  0x00732e11 in QtPrivate::QStringList_contains (that=0xbfb34d64, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfb34d64) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x890c450) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x890c450, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb34f84) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x007dfb7d in metacall (argv=0xbfb34f84, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x890c450) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x890c450, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfb34f84) at kernel/qmetaobject.cpp:232
#13 0x007eea6a in QMetaObject::activate (sender=0x8960310, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8960310) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8960310, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb350c8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x007dfb7d in metacall (argv=0xbfb350c8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8960310) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8960310, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfb350c8) at kernel/qmetaobject.cpp:232
#18 0x007eea6a in QMetaObject::activate (sender=0x890c450, m=0x80950c0, local_signal_index=0, argv=0xbfb350c8) at kernel/qobject.cpp:3278
#19 0x004077c5 in MuonMainWindow::backendReady (this=0x890c450, _t1=0x8943c40) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00407933 in MuonMainWindow::initObject (this=0x890c450) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x890c450) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x890c450, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb351f4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x007dfb7d in metacall (argv=0xbfb351f4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x890c450) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x890c450, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfb351f4) at kernel/qmetaobject.cpp:232
#25 0x007eea6a in QMetaObject::activate (sender=0x89408b0, m=0x90f238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x007f6375 in QSingleShotTimer::timeout (this=0x89408b0) at .moc/release-shared/qtimer.moc:82
#27 0x007f642c in QSingleShotTimer::timerEvent (this=0x89408b0) at kernel/qtimer.cpp:308
#28 0x007f1994 in QObject::event (this=0x89408b0, e=0xbfb355ec) at kernel/qobject.cpp:1181
#29 0x06687d84 in notify_helper (e=0xbfb355ec, receiver=0x89408b0, this=0x8792b48) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8792b48, receiver=0x89408b0, e=0xbfb355ec) at kernel/qapplication.cpp:4458
#31 0x0668d133 in QApplication::notify (this=0xbfb355ec, receiver=0x89408b0, e=0xbfb355ec) at kernel/qapplication.cpp:3886
#32 0x00c0f971 in KApplication::notify (this=0xbfb35900, receiver=0x89408b0, event=0xbfb355ec) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x007d919e in QCoreApplication::notifyInternal (this=0xbfb35900, receiver=0x89408b0, event=0xbfb355ec) at kernel/qcoreapplication.cpp:787
#34 0x00809c10 in sendEvent (event=0xbfb355ec, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x87958bc) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00807122 in timerSourceDispatch (source=0x8795888) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0416525f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x04165990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x04165c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00807ada in QEventDispatcherGlib::processEvents (this=0x8775250, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0673fe7a in QGuiEventDispatcherGlib::processEvents (this=0x8775250, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x007d81dd in QEventLoop::processEvents (this=0xbfb35864, flags=...) at kernel/qeventloop.cpp:149
#43 0x007d8421 in QEventLoop::exec (this=0xbfb35864, flags=...) at kernel/qeventloop.cpp:201
#44 0x007dd19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x06685924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293772, bug 293752, bug 293747, bug 293690, bug 293675.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-10 20:03:30 UTC

*** This bug has been marked as a duplicate of bug 291262 ***