Bug 293911 - New Installation - [rpgram never stated properly
Summary: New Installation - [rpgram never stated properly
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-12 17:06 UTC by Stephen Clark
Modified: 2012-02-15 06:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.70 KB, text/plain)
2012-02-15 06:21 UTC, Timothy Tuck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Clark 2012-02-12 17:06:15 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Crash occurs shortly after clicking on icon and start up screen appearing

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff8209e2780 (LWP 1790))]

Thread 2 (Thread 0x7ff80bfba700 (LWP 1793)):
#0  0x00007ff81d5ad773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff819e22f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff819e23429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff81f76bf3e in QEventDispatcherGlib::processEvents (this=0x25395f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff81f73fcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff81f73fef7 in QEventLoop::exec (this=0x7ff80bfb9dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff81f65727f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007ff81f722cbf in QInotifyFileSystemWatcherEngine::run (this=0x24bd5a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ff81f659d05 in QThreadPrivate::start (arg=0x24bd5a0) at thread/qthread_unix.cpp:331
#9  0x00007ff81a904efc in start_thread (arg=0x7ff80bfba700) at pthread_create.c:304
#10 0x00007ff81d5b989d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff8209e2780 (LWP 1790)):
[KCrash Handler]
#6  0x00007ff81f6a7a5e in QtPrivate::QStringList_contains (that=0x7fff56818730, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff56818730) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x246ad30) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x246ad30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff56818d00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007ff81f753eba in QMetaObject::activate (sender=0x22f5630, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x22f5630, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff56818e60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007ff81f753eba in QMetaObject::activate (sender=0x246ad30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff56818e60) at kernel/qobject.cpp:3278
#13 0x00007ff8205c9e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x24da3b0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007ff8205c9f8e in MuonMainWindow::initObject (this=0x246ad30) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x246ad30) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x246ad30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff56818f30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007ff81f753eba in QMetaObject::activate (sender=0x24dd700, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007ff81f75bf7f in QSingleShotTimer::timerEvent (this=0x24dd700) at kernel/qtimer.cpp:308
#19 0x00007ff81f757789 in QObject::event (this=0x24dd700, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007ff81dd7a474 in notify_helper (e=0x7fff568194a0, receiver=0x24dd700, this=0x230fda0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x230fda0, receiver=0x24dd700, e=0x7fff568194a0) at kernel/qapplication.cpp:4458
#22 0x00007ff81dd7f2e1 in QApplication::notify (this=0x7fff568197a0, receiver=0x24dd700, e=0x7fff568194a0) at kernel/qapplication.cpp:4365
#23 0x00007ff81ef5f466 in KApplication::notify (this=0x7fff568197a0, receiver=0x24dd700, event=0x7fff568194a0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007ff81f740afc in QCoreApplication::notifyInternal (this=0x7fff568197a0, receiver=0x24dd700, event=0x7fff568194a0) at kernel/qcoreapplication.cpp:787
#25 0x00007ff81f76dd62 in sendEvent (event=0x7fff568194a0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x230ced0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007ff81f76b538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007ff819e22a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007ff819e23258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007ff819e23429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007ff81f76bed6 in QEventDispatcherGlib::processEvents (this=0x22e76f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007ff81de2210e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007ff81f73fcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007ff81f73fef7 in QEventLoop::exec (this=0x7fff56819730, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007ff81f744789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=5, argv=0x7fff56819a18) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293910, bug 293904, bug 293896, bug 293821, bug 293811.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-12 17:14:14 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Timothy Tuck 2012-02-15 06:21:59 UTC
Created attachment 68814 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

clicked to open muon and before it opens it crashes everytime.

-- Backtrace (Reduced):
#7  0x00699e11 in QtPrivate::QStringList_contains (that=0xbfc01694, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc01694) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8434818) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8434818, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc018b4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00746b7d in metacall (argv=0xbfc018b4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8434818) at kernel/qmetaobject.cpp:237