Bug 293910 - Muon Software Center Crashes
Summary: Muon Software Center Crashes
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-12 17:03 UTC by Logan
Modified: 2012-02-12 17:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Logan 2012-02-12 17:03:50 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I was using Firefox 10 and I wanted to install Thunderdbird and Muon crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7779930 (LWP 2127))]

Thread 2 (Thread 0xb5936b70 (LWP 2131)):
#0  0x0079ad10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x008e17d5 in do_gettime (frac=0xb5936020, sec=0xb5936018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x009b44b6 in QTimerInfoList::updateCurrentTime (this=0xb5000a14) at kernel/qeventdispatcher_unix.cpp:339
#4  0x009b480a in QTimerInfoList::timerWait (this=0xb5000a14, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x009b3053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb593612c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x009b30ed in timerSourcePrepare (source=0xb50009e0, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x03db688c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x03db7637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x03db7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x009b3b37 in QEventDispatcherGlib::processEvents (this=0x9b29be0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x009841dd in QEventLoop::processEvents (this=0xb59362b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00984421 in QEventLoop::exec (this=0xb59362b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0088790b in QThread::exec (this=0x9a70000) at thread/qthread.cpp:498
#14 0x00964e2d in QInotifyFileSystemWatcherEngine::run (this=0x9a70000) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0088a7b3 in QThreadPrivate::start (arg=0x9a70000) at thread/qthread_unix.cpp:331
#16 0x00777d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x041020ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7779930 (LWP 2127)):
[KCrash Handler]
#7  0x008dee11 in QtPrivate::QStringList_contains (that=0xbfe68ab4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe68ab4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x99ce0c8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x99ce0c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe68cd4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0098bb7d in metacall (argv=0xbfe68cd4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x99ce0c8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x99ce0c8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe68cd4) at kernel/qmetaobject.cpp:232
#13 0x0099aa6a in QMetaObject::activate (sender=0x98ea4c0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x98ea4c0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x98ea4c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe68e18) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0098bb7d in metacall (argv=0xbfe68e18, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x98ea4c0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x98ea4c0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe68e18) at kernel/qmetaobject.cpp:232
#18 0x0099aa6a in QMetaObject::activate (sender=0x99ce0c8, m=0x80950c0, local_signal_index=0, argv=0xbfe68e18) at kernel/qobject.cpp:3278
#19 0x006627c5 in MuonMainWindow::backendReady (this=0x99ce0c8, _t1=0x9a26bd8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00662933 in MuonMainWindow::initObject (this=0x99ce0c8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x99ce0c8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x99ce0c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe68f44) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0098bb7d in metacall (argv=0xbfe68f44, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x99ce0c8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x99ce0c8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe68f44) at kernel/qmetaobject.cpp:232
#25 0x0099aa6a in QMetaObject::activate (sender=0x9a45ba8, m=0xabb238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x009a2375 in QSingleShotTimer::timeout (this=0x9a45ba8) at .moc/release-shared/qtimer.moc:82
#27 0x009a242c in QSingleShotTimer::timerEvent (this=0x9a45ba8) at kernel/qtimer.cpp:308
#28 0x0099d994 in QObject::event (this=0x9a45ba8, e=0xbfe6933c) at kernel/qobject.cpp:1181
#29 0x0744fd84 in notify_helper (e=0xbfe6933c, receiver=0x9a45ba8, this=0x98e5158) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x98e5158, receiver=0x9a45ba8, e=0xbfe6933c) at kernel/qapplication.cpp:4458
#31 0x07455133 in QApplication::notify (this=0xbfe6933c, receiver=0x9a45ba8, e=0xbfe6933c) at kernel/qapplication.cpp:3886
#32 0x00edf971 in KApplication::notify (this=0xbfe69650, receiver=0x9a45ba8, event=0xbfe6933c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0098519e in QCoreApplication::notifyInternal (this=0xbfe69650, receiver=0x9a45ba8, event=0xbfe6933c) at kernel/qcoreapplication.cpp:787
#34 0x009b5c10 in sendEvent (event=0xbfe6933c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x98e6a84) at kernel/qeventdispatcher_unix.cpp:603
#36 0x009b3122 in timerSourceDispatch (source=0x98e6a50) at kernel/qeventdispatcher_glib.cpp:184
#37 0x03db725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x03db7990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x03db7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x009b3ada in QEventDispatcherGlib::processEvents (this=0x98c8238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x07507e7a in QGuiEventDispatcherGlib::processEvents (this=0x98c8238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x009841dd in QEventLoop::processEvents (this=0xbfe695b4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00984421 in QEventLoop::exec (this=0xbfe695b4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0098919d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0744d924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 293904, bug 293896, bug 293821, bug 293811, bug 293810.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-12 17:14:25 UTC

*** This bug has been marked as a duplicate of bug 291262 ***